Cannot make APACHE running!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot make APACHE running!

Postby jpsportugal » 02. December 2009 23:56

Well I am tired to search for solutions to make this software work but I had 0% success. Reinstalled many times, unistalled Skype, checked lots of threads, sites... but I cannot make it run since the beginning.
I am about to install it for the last time and if someone has any relevant help to offer I will give it a shot.

The info I get checking error logs is:

Code: Select all
: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs


with a few words before in my main language, portuguese.

Thank you.
jpsportugal
 
Posts: 3
Joined: 02. December 2009 23:45

Re: Cannot make APACHE running!

Postby Izzy » 03. December 2009 00:27

Missing support info - what XAMPP version and which Windows OS?
So assuming latest stable XAMPP version and Vista.

Use the Port Check button in your XCP or type netstat -a -n at the command prompt # after clicking on the Shell button in your XCP.

http://www.apachefriends.org/en/faq-xam ... ml#nostart

Also you can right click on xampp-portcheck.exe file in the xampp folder and select to run as an administrator if the port check button won't work on Vista.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Cannot make APACHE running!

Postby jpsportugal » 03. December 2009 00:39

Well you supposed it right but I have tried the 1st method and it didn't work because it's a matter of microsseconds to do the process and close. I cannot take any info about it.
As for the link you game it is not working and the 2nd method the info I get is:

Image
jpsportugal
 
Posts: 3
Joined: 02. December 2009 23:45

Re: Cannot make APACHE running!

Postby Izzy » 03. December 2009 01:12

Make sure that IIS is completely disabled:
viewtopic.php?f=16&t=33061

If you still can't find the process using that port 443 then you can change it in XAMPP by editing the \xampp\apache\conf\extra\httpd-ssl.conf file in your text editor.

Look for 443 and change it to 4433 or if you are not contemplating using https (SSL) then disable it in the \xampp\apache\conf\httpd.conf file at about line 500 or so:
Code: Select all
# Secure (SSL/TLS) connections
Include "conf/extra/httpd-ssl.conf"
Change to
Code: Select all
# Secure (SSL/TLS) connections
# Include "conf/extra/httpd-ssl.conf"

If you make changes in any conf file then save the file and then restart Apache.

BTW if you change the port to 4433 and still use https then you always have to add the port number in the address you type in the browser, for example:
https://localhost:4433/index.php

Sorry for the dead link, here it is again:
http://www.apachefriends.org/en/faq-xam ... ml#nostart
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Cannot make APACHE running!

Postby meteormatt » 03. December 2009 10:41

Izzy wrote:Make sure that IIS is completely disabled:
viewtopic.php?f=16&t=33061

If you still can't find the process using that port 443 then you can change it in XAMPP by editing the \xampp\apache\conf\extra\httpd-ssl.conf file in your text editor.

Look for 443 and change it to 4433 or if you are not contemplating using https (SSL) then disable it in the \xampp\apache\conf\httpd.conf file at about line 500 or so:
Code: Select all
# Secure (SSL/TLS) connections
Include "conf/extra/httpd-ssl.conf"
Change to
Code: Select all
# Secure (SSL/TLS) connections
# Include "conf/extra/httpd-ssl.conf"

If you make changes in any conf file then save the file and then restart Apache.

BTW if you change the port to 4433 and still use https then you always have to add the port number in the address you type in the browser, for example:
https://localhost:4433/index.php

Sorry for the dead link, here it is again:
http://www.apachefriends.org/en/faq-xam ... ml#nostart



:D :D :D
Very good.
User avatar
meteormatt
 
Posts: 4
Joined: 13. October 2009 09:10
Location: China

Re: Cannot make APACHE running!

Postby jpsportugal » 03. December 2009 22:37

Well Izzy, since yesterday night when I shutted my computer down I have not done anything relevant who could make this work but now I have open it to try and it just worked :D.
Anyway thank you x1000 for the advices and thank you for the service of XAMPP.

God bless you all :D.
jpsportugal
 
Posts: 3
Joined: 02. December 2009 23:45

Re: Cannot make APACHE running!

Postby Izzy » 04. December 2009 03:29

Your welcome and yes, it has been known that a cold boot has often cured some of these unusual and seeming irreparable issues both with XAMPP and indeed Windows itself.

Good luck and please enjoy XAMPP. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests