Any chance of a vc9 compile of php in XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Any chance of a vc9 compile of php in XAMPP

Postby ChaosX » 29. November 2009 01:00

Was wondering what the chance of getting a vc9 compiled version of php in XAMPP, I need to run scripts that use ImageMagick but can only find the vc9 dll by Mikko. Using the vc9 version throws an error with the vc6 version of php included with XAMPP, so I was wondering if there was a vc9 version of XAMPP or if there were plans to compile a vc9 version.

To me it seems like it would be easier and make more sense to find a vc9 version of php in XAMPP than to continue searching for a vc6 version of php_imagick.dll since most devs can no longer compile under vc6 or get a program that does.

I just need ImageMagcik to work with 1.7.2 version of XAMPP for Windows ...
ChaosX
 
Posts: 4
Joined: 29. November 2009 00:40

Re: Any chance of a vc9 compile of php in XAMPP

Postby Wiedmann » 29. November 2009 01:33

Was wondering what the chance of getting a vc9 compiled version of php in XAMPP,

Not at the moment.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Any chance of a vc9 compile of php in XAMPP

Postby Wiedmann » 02. December 2009 10:58

I just need ImageMagcik to work with 1.7.2 version of XAMPP for Windows ...

Just a quetsion:
You have solved your problem, or you still need a imagick (ImageMagick) extension for PHP 5.3.x?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Any chance of a vc9 compile of php in XAMPP

Postby Rasta » 10. December 2009 20:04

i don't know if chaosX was able to solve his problem, but i would really appreciate a vc6 build of php_imagick, because without it i would have to uninstall xampp and install all the stuff (apache, php, mysql) separately, that means pointless work and no more xampp for me...

why is it such a problem to compile a vc9 version of php in xampp? are there some strong dependencies with some little superspecial thing, or what?
Rasta
 
Posts: 1
Joined: 09. December 2009 14:01

Re: Any chance of a vc9 compile of php in XAMPP

Postby jhonnycano » 15. March 2010 19:30

I also need vc9 (I think) for using it with mongoDB, which comes in VC8 and VC9 flavors...
jhonnycano
 
Posts: 1
Joined: 15. March 2010 19:28

Re: Any chance of a vc9 compile of php in XAMPP

Postby Takster » 07. June 2010 13:07

Agreed, vc9 should be a priority. For imagemagick it's crucial. I don't need to spend hours working around limitations.
User avatar
Takster
 
Posts: 13
Joined: 29. August 2006 10:18
Operating System: USB etch-a-sketch

Re: Any chance of a vc9 compile of php in XAMPP

Postby dvb » 12. December 2010 19:44

I'm completely agree that xampp should be compiled using VC9 since everyone is slowly moving to VC9 and less binaries remain in VC6...
I've also came across this problem because of GraphicsMagick (fork of ImageMagick) but it seems that also other extensions suffer from this issue
dvb
 
Posts: 3
Joined: 06. October 2010 08:04

Re: Any chance of a vc9 compile of php in XAMPP

Postby JonB » 13. December 2010 09:57

You can't simply compile PHP with VC9 and have it work, Apache would also have to be a VC9 compile.

And, I think there are other dependency considerations on the host machine side.

just my observations
:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: dogmatic and 33 guests