Apache wont start Error:1

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache wont start Error:1

Postby terrymod » 26. November 2009 15:52

I get error:
Syntax error on line 252 of C:/xampp/apache/conf/httpd.conf:
Invalid command '\\home.php', perhaps misspelled or defined by a module not included in the server configuration

Here is CONF Code:

<IfModule dir_module>
DirectoryIndex index.php index.cfm index.pl index.cgi index.asp index.shtml index.html index.htm \ default.php default.pl default.cgi default.asp default.shtml default.html default.htm
\home.php home.pl home.cgi home.asp home.shtml home.html home.htm
</IfModule>

Is PHP not loaded correctly ?
Apache Server won't start -

Windows 2003 server:

Got cold fusion to install and start

But Apache won't start

Many thanks,

Terry
terrymod
 
Posts: 9
Joined: 25. November 2009 18:52

Re: Apache wont start Error:1

Postby Wiedmann » 26. November 2009 15:56

You have changed anything in the "httpd.conf" yourself?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache wont start Error:1

Postby terrymod » 26. November 2009 16:01

Removed some spaces between allowed page names and now that error has disappeared.

New Error:
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 75.148.127.241:80
no listening sockets available, shutting down
Unable to open logs

Listen in Conf:
Listen 75.148.127.241:80

Many thanks,

Terry
terrymod
 
Posts: 9
Joined: 25. November 2009 18:52

Re: Apache wont start Error:1

Postby terrymod » 26. November 2009 16:03

Wiedmann wrote:You have changed anything in the "httpd.conf" yourself?


Yes :

Changed the Following:

Admin Email: sales@homecraftersinc.com

Listen: Listen 75.148.127.241:80

ServerName www.biz1usa.com:80
terrymod
 
Posts: 9
Joined: 25. November 2009 18:52

Re: Apache wont start Error:1

Postby Wiedmann » 26. November 2009 16:08

Well, the part with "DirectoryIndex" is also changed... Because in the default config there is no error. And it looks differnet the in your above post. (Maybe you want use code tags)

Listen 75.148.127.241:80

I don't think "75.148.127.241" is an IP from your pc.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache wont start Error:1

Postby terrymod » 26. November 2009 17:07

Wiedmann wrote:Well, the part with "DirectoryIndex" is also changed... Because in the default config there is no error. And it looks differnet the in your above post. (Maybe you want use code tags)

Listen 75.148.127.241:80

I don't think "75.148.127.241" is an IP from your pc.



IP Address is correct -

I do not know what "Code Tags" are?

Directory Index ? c:/xammp/htdocs/ should be the directory ?

Isn't that correct ?
terrymod
 
Posts: 9
Joined: 25. November 2009 18:52

Re: Apache wont start Error:1

Postby Wiedmann » 26. November 2009 17:18

Directory Index ? c:/xammp/htdocs/ should be the directory ?

Code: Select all
<IfModule dir_module>
DirectoryIndex index.php index.cfm index.pl index.cgi index.asp index.shtml index.html index.htm \ default.php default.pl default.cgi default.asp default.shtml default.html default.htm
\home.php home.pl home.cgi home.asp home.shtml home.html home.htm
</IfModule>

This part doesn't look in this way in an original "http.conf". It should be:
Code: Select all
<IfModule dir_module>
    DirectoryIndex index.php index.pl index.cgi index.asp index.shtml index.html index.htm \
                   default.php default.pl default.cgi default.asp default.shtml default.html default.htm \
                   home.php home.pl home.cgi home.asp home.shtml home.html home.htm
</IfModule>


I do not know what "Code Tags" are?

That's a button if you write a new message. Mark the text and click on the code button.

IP Address is correct -

Maybe a firewall is blocking the access. BTW: Why have you changed the original value?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache wont start Error:1

Postby terrymod » 26. November 2009 17:26

Wiedmann wrote:
Directory Index ? c:/xammp/htdocs/ should be the directory ?

Code: Select all
<IfModule dir_module>
DirectoryIndex index.php index.cfm index.pl index.cgi index.asp index.shtml index.html index.htm \ default.php default.pl default.cgi default.asp default.shtml default.html default.htm
\home.php home.pl home.cgi home.asp home.shtml home.html home.htm
</IfModule>

This part doesn't look in this way in an original "http.conf". It should be:
Code: Select all
<IfModule dir_module>
    DirectoryIndex index.php index.pl index.cgi index.asp index.shtml index.html index.htm \
                   default.php default.pl default.cgi default.asp default.shtml default.html default.htm \
                   home.php home.pl home.cgi home.asp home.shtml home.html home.htm
</IfModule>


I do not know what "Code Tags" are?

That's a button if you write a new message. Mark the text and click on the code button.

IP Address is correct -

Maybe a firewall is blocking the access. BTW: Why have you changed the original value?



I added the "index.cfm" so Apache would recognize the ColdFusion tags which are: ".cfm " , just like PHP is: ".php"
terrymod
 
Posts: 9
Joined: 25. November 2009 18:52

Re: Apache wont start Error:1

Postby terrymod » 26. November 2009 17:30

I don't have a firewall set up yet.
terrymod
 
Posts: 9
Joined: 25. November 2009 18:52

Re: Apache wont start Error:1

Postby Wiedmann » 26. November 2009 17:34

I added the "index.cfm"

So this part must look like:
Code: Select all
<IfModule dir_module>
    DirectoryIndex index.php index.cfm index.pl index.cgi index.asp index.shtml index.html index.htm \
                   default.php default.pl default.cgi default.asp default.shtml default.html default.htm \
                   home.php home.pl home.cgi home.asp home.shtml home.html home.htm
</IfModule>
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache wont start Error:1

Postby terrymod » 30. November 2009 17:48

I finally got the Cold Fusion up :

Here is Sequence
1) Get Apache running by itself

2) Test an index page

3) Add " index "dot" .CFM to the Apache Conf file

4) Remove any gaps in spaces in the allowed in the types of pages Apache allows:

Found 2 large space gaps , closed them in and Apache stopped giving me a "default.php" error

5) Edit the Listening Ports in Conf File

Save and

6) Re Start Apache for any errors

( note : I saved previous logs with a new name, wiped the logs off the Apache / lib / error.logs

Then see if there are any new errors in the Error.Log file

7) DNS
If using 1 IP address and to create multiple Virtual Hosts on that IP

Go to DNS and Add your websites and point them to the IP address

8) Create your Website file folder in Xammp HTDOCS
Can also create your sub folders if it is easier

9) Write an index page for that website

Stop Apache

10) Configure Apache for the Virtual Hosts

Go to the "Includes" folder

Find: http_vhost file

11) Carefully read about setting up Virtual Hosts

12) Set Up your first primary virtual

13) Save "http_vhost

14) Restart Apache

15) Test your www.yourwebsite.com and see if it resolves







1) When installing CF 8 - you must have all the component options checked
The reason to do this is the File Directory tree won't work and it won't get installed unless you have not only the CF Data Sources but more importantly the Flex has the Java needed to work the tree to look up your data base locations. ( Even if you don't want to use the Flex ) Pretty stupid in my opinion.

2) Make sure the document root is pointed toward the Xaamp html docs not Apache docs - the CF Admin page won't come up.

3) Double check to see if IIS was loaded and running. I came across this with one of the errors about Apache. I never thought I loaded IIS and there it was - Running and causing the Port 80 conflict.

4) Stop Apache when loading
terrymod
 
Posts: 9
Joined: 25. November 2009 18:52


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests