xampp 1.7.2 + windows 7 (64 bit)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: xampp 1.7.2 + windows 7 (64 bit)

Postby jezmy » 05. September 2010 14:47

System : Win 7 64bit
I was having the same problem - XAMPP was working fine one day, and then just packed up - Apache would not run and the control panel just went sulky.

After a lot of digging around, it would seem that the problem (in my case) was that ports 80 and 443 were being used. As it turns out, by Microsoft IIS. Which I have never used, and certainly have not knowingly installed...

Solution :- Control Panel --> Programs and Features --> Turn Windows Features on or off You should find "Internet Information Services" there - just untick the box and press 'OK'. Restart your computer and you should be up and running ...

Hope this helps!
jezmy
 
Posts: 1
Joined: 05. September 2010 14:36

Re: xampp 1.7.2 + windows 7 (64 bit)

Postby rosh » 13. September 2010 03:02

klezmer41 was totally right! Skype was the problem!!

Running windows 7 64bit and was having problems running Apache and getting localhost to work.
Shut down Skype and it works like a charm.
rosh
 
Posts: 1
Joined: 13. September 2010 02:58

Re: xampp 1.7.2 + windows 7 (64 bit)

Postby Rodashar » 24. November 2010 06:59

I was getting this same error regarding the SSL cache. I did some quick searching and found you can set this value to "none". http://httpd.apache.org/docs/2.0/mod/mod_ssl.html. It says this is safe to do but you may notice a signifigant performance impact. This is not an issue for me as I am setting this up in a dev environment.

I don't understand why everyone is saying to just install the package on the C: drive. This is my computer and I should not have to bend how I like my files setup just to use an application. xampp needs to fix this issue and not expect me to jump through hoops to get this running. I could easily have looked for a different package then figured out how to get this running.
Rodashar
 
Posts: 1
Joined: 24. November 2010 06:52

Re: xampp 1.7.2 + windows 7 (64 bit)

Postby JonB » 24. November 2010 17:36

@ Rodasher -
I don't understand why everyone is saying to just install the package on the C: drive. This is my computer and I should not have to bend how I like my files setup just to use an application. xampp needs to fix this issue and not expect me to jump through hoops to get this running. I could easily have looked for a different package then figured out how to get this running.

Well - jump on it boss - install away - no one here or anywhere else in OpenSourceLand cares what you install OR where, that's part of the whole idea - you do what you want.

the DEFAULT is C: - but you can install XAMPP even on thumbdrives (you must not have read a lot) We recommend the root of C: because for many folks - this is their first 'webserver', and if you read through the forums you will find we get a lot of users who barely understand networking who want to make XAMPP work with things like Wordpress or SMF. So most of us FREE software VOLUNTEER helpers recommend a straight-forward installation.

THERE are some things you SHOULDN'T do when installing XAMPP -

XAMPP is truly cross platform, and its parts make use of things like regex - SOOO no folder names with spaces or special characters (that kinda leaves out Program Files, huh?)

I guess, other than that you can put XAMPP about anywhere you want

:mrgreen:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: xampp 1.7.2 + windows 7 (64 bit)

Postby aowie1 » 13. January 2011 22:56

If skype is your issue, go to Skype: Tools > Options > Advanced > Connection > Uncheck Use port 80 and 443 as alternatives for incoming connections.

Actually though, skype may not always be the issue if your ports are being used by other applications.
Running the port checker utility in xampp can help.

I personally found another application using port 443 and killed it to solve my problem. Xampp requires that both 80 and 443 be open and free to use.

Restart the apache service if needed and voila!
aowie1
 
Posts: 1
Joined: 13. January 2011 22:47

Re: xampp 1.7.2 + windows 7 (64 bit)

Postby auvi1 » 14. March 2011 19:31

ok... This is what's hapening...
I had the same problem has you, what I did is, I executed the port check (You got to go to the Xampp control panel application) and found that port 80 (the one that apache uses) was being used by Skype, so I turned off Skype and restarted apache from the CPA... :D and BRABISIMOOOO! it executed normally, so I went to Skype and stoped the app from loading on startup. Hope this helps some one else.
auvi1
 
Posts: 1
Joined: 14. March 2011 19:20

Re: xampp 1.7.2 + windows 7 (64 bit)

Postby FredD1 » 07. August 2011 08:05

XAMPP has many known issues with other software's which uses similar ports like Skype. i was getting an error "Busy" and can't seem to get MYSQL and Apache working, then i quit Skype and restarted XAMPP. and this time it worked without any issues. the same thing happens when you try to install XAMPP while Skype is running.
FredD1
 
Posts: 2
Joined: 07. August 2011 07:59

Re: xampp 1.7.2 + windows 7 (64 bit)

Postby Sharley » 07. August 2011 09:13

No big deal, simply reconfigure Skype not to use ports 80 and 443 then you can have Skype and Apache running at the same time.

Also if you start Apache first then you will be able to start Skype and have both running at the same time.

Or was this, your only post, signature spam for the benefit of the search engine bots that frequent these exceptionally good quality content forums?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: xampp 1.7.2 + windows 7 (64 bit)

Postby FredD1 » 16. August 2011 12:14

Well, i know both things work fine if we start XAMPP first but it failed if we change the order. like, if Skype is already running and we try to run XAMPP than we are most likely get an error "busy". as far as reconfiguring Skype is concerned, i think this a good idea and i would have to poke into Skype someday when i have spare time.

I am in favor of forum signatures but not forum SPAM!

Cheers
Fred
FredD1
 
Posts: 2
Joined: 07. August 2011 07:59

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests