Problem with xampp - Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with xampp - Apache

Postby nick2price » 13. November 2009 22:36

Hi. I have installed everything and most things work fine. However, in the control panel, whenever I try to start apache, Its says started, but the running logo does not show up next to it. I test it out by trying to get to the xampp splash screen, so i type in http://127.0.0.1. Instead of taking me to xampp, it takes me to a page called Internet Information Services. Is this right or not?

Having checked out another post, I must be getting this page because ISS is taking over my port 80, which is what apache is trying to run of (done a port check). Whats the best way around this? Can I just remove ISS or will this do harm, or would I just give ISS another port. Bare in mind that I am a complete begginer at this, so a little information on how to remove or re-port ISS may be required.

Thank you very much
nick2price
 
Posts: 3
Joined: 13. November 2009 22:32

Re: Problem with xampp - Apache

Postby Izzy » 13. November 2009 22:44

Best to disable IIS using the Windows Control Panel:
viewtopic.php?p=134260#p134260

If using XAMPP then no need really for IIS and visa versa.

Good luck and enjoy XAMPP.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with xampp - Apache

Postby supercat » 14. November 2009 01:00

After 7 hours of installing, uninstalling, reinstalling Xampp 1.7.1 (not the lastest version because I want to run Drupal 6), and having viewed, read and tried all the suggestions I can find, Apache will still not run.

I'm running Windows Vista. I have turned off the IIS. I have edited Windows Firewall Settings to allow Apache through. I have confirmed the Path to Executable (found in the "Services" dialog box) is set to c:\xampp\apache\bin\httpd.exe. I have turned off the User Account Conrol. I have run Xampp-portcheck.exe and confirmed that Apache (http) is Port 80, Appache WebDAV is 81 and https is 443. I have run independent port check software (ScanPort) that confirms Port 80 is open.

I have never had Skype installed on my system.

In Xampp Control - I click "start" and it seems to just hang, because the "running" never displays as it does for MySQL. I have tried to start and run Apache through Windows Task Manager > Services but keep getting "access denied" message. Have manually checked the folder properties Security tab to confirm permission to access.

What's my next step?

And in terms of uninstalling/reinstalling - I even did a disk wide program clean up with Restarts in between and still cannot get Apache working. :cry:
supercat
 
Posts: 9
Joined: 14. November 2009 00:46

Re: Problem with xampp - Apache

Postby Izzy » 14. November 2009 01:12

Because you have uninstalled and reinstalled many times without first ensuring that all NT Services are uninstalled and all components are stopped including closing the XAMPP Control Panel, it may have compounded your issue.

Any clues in the Apache error log file:
\xampp\apache\logs\error.log

Have you tried starting Apache with the apache_start.bat file and see what messages are returned, which you can paste here if you don't understand them.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with xampp - Apache

Postby supercat » 14. November 2009 01:40

OK, well I checked the error.log file again and its empty.

Also did the apache_start.bat. That was an interesting exercise, as a dialog box appeared saying Windows wanted to know if this program should be "blocked" or "unblocked". I responded "unblocked", but wondering why this appeared at all considering I had instructed Windows Firewall to allow Appache through. Anyway the resultant dialog box says:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...

The it just seems to hang.

Appreciate you help here. I'm going nuts. You're probably right that the number of times I've installed, unintalled etc have an effect, but all the advice I was reading were saying make sure Xampp stops the service, try reinstalling etc.

The initial problem here was that I downloaded and installed Xampp 1.7.2 (the latest version) as instructed on Drupal (http://drupal.org/node/161975). This all went very successful and I managed to successfully complete all the directions and then clicked for the next page (http://drupal.org/node/307956) only to read that Drupal does not install correctly on 1.7.2 and that I needed to have installed 1.7.1. Obviously, this information should have appeared on the preceding page! I'm going to post to Drupal.

So, somewhat annoyed and not knowing how to go back to a previous version of Xampp, I proceeded to install 1.7.1 thinking that by naming the folder differently (c:\xampp_1.7.1) than the original (c:\xampp), I could keep both versions live and install Drupal 6 under the c:\xampp_1.7.1 folder.

So, yes this action got me into trouble, which I realized when I checked the path that was actually being used to start Apache (Task Manager > Services) and realized two Apache's had been installed. I deleted the one I didn't need from the Services list. Did a restart. Didn't help.

After that, I uninstalled Xampp 1.7.2. Restarted. Still couldn't get Apache running. Useing the installer.exe, I re-installed Xampp 1.7.1 - and still couldn't get Apache running.

That's when I started googling forums for help and tips.
supercat
 
Posts: 9
Joined: 14. November 2009 00:46

Re: Problem with xampp - Apache

Postby Izzy » 14. November 2009 01:51

Are you logged into Vista as an Administrator or even a Super Admin which may break the permission issue?

Alternatively, when running a bat or exe file right click and select to run as an Administrator.


From your post I am going to assume that you have a sticking Service entry in the Windows registry from a previous install.


Go to your XAMPP Control Panel (XCP) and try and remove the tick in the Apache Svc box.

If you can and it remains un-ticked after answering the question then try and Start Apache again - don't tick the Svc box again, simply use the Start button.

If that fails then run the apache_uninstallservice.bat file in the apache folder and then try and start Apache again from in the XCP.

Let me know if that sorts it out or not.
Last edited by Izzy on 14. November 2009 01:57, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with xampp - Apache

Postby supercat » 14. November 2009 01:57

OMG - your suggestion to uncheck the box beside Apache and then click the Start button actually got it running!!!

Am I save to re-check the box or should I just leave it unchecked?

Also, I did right-click and run as Administrator on the bat file before I tried the check box action, and I got the same results just a little more informatoin:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
The system cannot find the path specified.

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
supercat
 
Posts: 9
Joined: 14. November 2009 00:46

Re: Problem with xampp - Apache

Postby Izzy » 14. November 2009 02:02

You can tick the Svc box if you want Apache to start when ever you reboot your PC and it should work from here on in, perhaps.

The message indicates that Apache can't find the path which may have been fixed after the Svc fix also Apache can't start again if it is already running - like most bat file messages in XAMPP they lack any useful, accurate or helpful comments and so need some interpretation.

Good luck and I hope you enjoy XAMPP after all these hassles.
Last edited by Izzy on 14. November 2009 02:06, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with xampp - Apache

Postby supercat » 14. November 2009 02:05

Izzy

Thank you so much for your help. It was a pleasure to have connected with a user so well versed in this stuff.

I'm going to sign off for now, because its 8pm here and I'm starving (I live in Canada).

I'll definitely keep my eye on this forum for future advice first and foremost.

Thanks again
Susan
supercat
 
Posts: 9
Joined: 14. November 2009 00:46

Re: Problem with xampp - Apache

Postby Izzy » 14. November 2009 02:11

You're most welcome Susan and to make sure all is now fixed, perhaps try a reboot just to be absolutely sure.

Enjoy your evening meal. :)
Last edited by Izzy on 14. November 2009 02:16, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with xampp - Apache

Postby supercat » 14. November 2009 02:15

OK. Will do.
supercat
 
Posts: 9
Joined: 14. November 2009 00:46

Re: Problem with xampp - Apache

Postby danna » 17. November 2009 13:57

OMG - your suggestion to uncheck the box beside Apache and then click the Start button actually got it running!!!


This happened to me before and i didn't know that it was that easy to solve the problem.



Regards,
Danna
Ordinateur portable pas cher
danna
 
Posts: 1
Joined: 17. November 2009 13:54

Re: Problem with xampp - Apache

Postby supercat » 21. November 2009 00:47

OK, I'm back. Its been a week. Wondering if you might have some suggestions related to my problem, as I've googled every variation of this issue and cannot find a solution.

I've been doing a self-tutored crash course in drupal 6 and today was playing around with changing themes etc. So everything was running fine until I was downloading, installing, enabling and changing themes. The last action I took was to change to the "Zen" theme (a very tried and true theme) and then started encountering rendering problems. Online I found information that led me to believe I should turn on the css aggregation in /admin/setttings/performance (See: http://www.perpetuallydehydrated.com/index.php/2009/02/15/zen-theme-breaking-ie-internet-explorer-css-its-not-your-modules/).

At this point things started to go downhill so thought I'd shut down all programs and restart.

Opened Xampp and clicked the Start buttons for Apache and SQL - according to Xampp both are "running". However, when I try to browse to "localhost" to reach my Drupal Welcome page, Windows pops up an error message saying that "Apache HTTP server stopped working" and end result is I cannot access Drupal / localhost.

I've checked Apache's error logs and there's nothing there other than messages to tell me Apache has started listening to port 80 and 443. I can also use the Xampp SQL Admin / phpAdmin to access the Drupal database manually. There are literally tons of tables in that dababase, so not sure if there's some PHP thing gone awry in the database and if so where to find it (I've posted this as Drupal.org too) OR how else to diagnose the Apache problem or is just a Windows thing and if so how come I can't browse "localhost"

Any suggestions?
supercat
 
Posts: 9
Joined: 14. November 2009 00:46

Re: Problem with xampp - Apache

Postby Izzy » 21. November 2009 06:11

Can you access just http://localhost/ and see the XAMPP Welcome page?


Check also the Windows Event Viewer for a clue for issues related to Windows - usually accessed from an Administrator Tools menu.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with xampp - Apache

Postby supercat » 21. November 2009 18:00

Cannot access http://localhost (my localhost should display the Drupal Welcome page) either by name or IP (127.0.0.1)

The Windows Event Viewer registers a number of what seems to be the same Application Error and identifies the same file httpd.exe and php5ts.dll files :

Faulting application httpd.exe, version 2.2.11.0, time stamp 0x493f5d44, faulting module php5ts.dll, version 5.2.9.9, time stamp 0x49a56925, exception code 0xc00000fd, fault offset 0x00151f03, process id 0x15e0, application start time 0x01ca6a38aa69106d.

The php5ts.dll - PHP Script interpreter - I guess has a problem.

Clicking the "start" next to SQL and Apache in Xampp control panel renders "running" for both, but when I browse to localhost or IP the Windows error message just keeps saying Apache server stopped working. However, Xampp control panel gives not indication that there's an issue.
supercat
 
Posts: 9
Joined: 14. November 2009 00:46

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 70 guests