Tomcat installation fails

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Tomcat installation fails

Postby calast » 11. November 2009 03:05

I have been running xampp successfully for years, and am now running 1.7.2 on XP. I recently decided I needed the Tomcat upgrade to do some Java servlet work, so downloaded the self-extracting version, pointed it at my xampp install directory, and clicked on install. All the files got installed, but then the cmd shell comes up and says "Sorry, but ... nothing to do" - somewhat disturbing. All the files are there, but when you try to install tomcat as a service, the bat file just says unknown service tomcat. So something didn't work with the self-extracting archive. I tried this twice just to make sure it was not a momentary glitch of some kind, but the behavior is consistent. Any idea what s going on here, and how to get past it?
calast
 
Posts: 10
Joined: 31. July 2009 22:29

Re: Tomcat installation fails

Postby Izzy » 11. November 2009 05:20

Try manually running the setup_xampp.bat file in the xampp folder.

The self extracting exe file is simply a WinRAR archive file so if you have WinRAR or 7zip then right click on the file and select to open the archive.

You will then find all the Tomcat Addon files which can be manually extracted (dragged) to their correct locations by overwriting when asked - then run the setup_xampp.bat file to complete the install.

Full install instruction are in the readme-addon-tomcat.txt file in the xampp folder or in the opened WinRAR archive file.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Tomcat installation fails

Postby Wiedmann » 11. November 2009 07:58

but then the cmd shell comes up and says "Sorry, but ... nothing to do"

That's the wrong Tomcat version for your XAMPP 1.7.2.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Tomcat installation fails

Postby calast » 11. November 2009 17:39

It's the version from the XAMPP web site. If that's the wrong one, why is it there? And what is the right one?

Manual installation did not work any differently, by the way.
calast
 
Posts: 10
Joined: 31. July 2009 22:29

Re: Tomcat installation fails

Postby Wiedmann » 11. November 2009 17:55

It's the version from the XAMPP web site

What's the filename?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Tomcat installation fails

Postby calast » 11. November 2009 19:15

Wiedmann wrote:What's the filename?


xampp-tomcat-addon-win32-6.0.20.zip (or .exe)
calast
 
Posts: 10
Joined: 31. July 2009 22:29

Re: Tomcat installation fails

Postby Wiedmann » 11. November 2009 20:39

and says "Sorry, but ... nothing to do"

Well, this message does not exists in XAMPP 1.7.2 or the Tomcat Addon 6.0.20.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Tomcat installation fails

Postby calast » 11. November 2009 22:33

Yes, you are absolutely correct. My mistake. I honestly believed I was running 1.7.2, but it was really 1.7.1. Doing an upgrade made things much better, although it caused some problems that I will address in a separate thread. Sorry for the waste of time.
calast
 
Posts: 10
Joined: 31. July 2009 22:29


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests