Fatal error: Maximum execution time of 60 seconds exceeded..

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Fatal error: Maximum execution time of 60 seconds exceeded..

Postby apache.indian » 08. November 2009 06:13

Hi All,

I'm wondering whether anyone else has encountered this error, and if yes, then what have they done to resolve the error?

I receive at least one of the following errors (sometimes all three listed below) everytime I try to install a Joomla extension, to the XAMPP+Joomla installation I have on my localhost (which is a 16GB USB Stick);

Fatal error: Maximum execution time of 60 seconds exceeded in F:\xampp\htdocs\SynergyIntegration\libraries\joomla\installer\installer.php on line 911
Fatal error: Maximum execution time of 60 seconds exceeded in F:\xampp\htdocs\SynergyIntegration\libraries\joomla\session\storage\database.php on line 82
Fatal error: Maximum execution time of 60 seconds exceeded in F:\xampp\htdocs\SynergyIntegration\libraries\joomla\session\storage\database.php on line 51

I believe there might be some setting that needs to be changed somewhere....but I'm not sure what/where...so any help in this regard will be greatly appreciated.

Thanks,

C
apache.indian
 
Posts: 5
Joined: 08. November 2009 05:57

Re: Fatal error: Maximum execution time of 60 seconds exceeded..

Postby Izzy » 08. November 2009 06:23

Have you checked the Joomla web site to see if anyone there has the same issue and knows what settings in Joomla that need changing?

BTW on a removable USB drive there should be no drive letter allocated when you installed XAMPP which means, by your error messages, that Joomla extensions can't find XAMPP perhaps.

What version of XAMPP and which Windows OS?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Fatal error: Maximum execution time of 60 seconds exceeded..

Postby apache.indian » 08. November 2009 14:42

Thanks for your reply Izzy....I think you might be getting me closer to the solution...but I'm not exactly sure what the solution is (or how to solve it). But it looks like it may be something related to the drive letter.

BTW, I'm a total newbie with all of this stuff i.e. XAMPP, Joomla etc.....so I'm learning as I'm going along. Just had a company develop my website (I wanted Drupal, but they used Joomla) and they suggested using XAMPP (instead of Apache2Triad, which is what I was using with Drupal on my localhost - C: drive).

Anyways, I believe the problem may be with XAMPP (rather than Joomla)...but I could be wrong....because when the errors are displayed on screen the XAMPP favicon thingie (white X on an orange background) is displayed against the URL/address line, as well as on the Firefox tab. Prior to the error being displayed, the Joomla favicon used to be showing there.

I'll still try posting to the Joomla forum...to see if someone there had similar problems...and found a solution to the problem...but it seems more likely that the answer may lie here, in this forum.

Later,


C
apache.indian
 
Posts: 5
Joined: 08. November 2009 05:57

Re: Fatal error: Maximum execution time of 60 seconds exceeded..

Postby apache.indian » 08. November 2009 14:49

Sorry....forgot to mention...I'm using XAMPP 1.6.8 and Windows Vista.

Initially started off using the latest and greatest 1.7.2...but had problems with that...and read somewhere on the web that it was possiblly due to the fact that Joomla doesn't work with PHP 5.3 (which is what was packaged in XAMPP 1.7.2).

So I tried using 1.7.1......and that too wouldn't work.

So I ended up going back another version or two, to 1.6.8. I hope these problems I'm experiencing are not related to v1.6.8!!!
apache.indian
 
Posts: 5
Joined: 08. November 2009 05:57

Re: Fatal error: Maximum execution time of 60 seconds exceeded..

Postby apache.indian » 08. November 2009 17:26

As it turns out, I've been able to figure out the reason for the original (timeout) error i.e. "Maximum execution time of 60 seconds...blah blah blah"...and I've implemented a solution....however, a new problem/error seems to have crept in.

The error(s) are as follows;
* Component Install: Another Component is already using directory: "F:\xampp\htdocs\SynergyIntegration\components\com_ckforms"
* Component Install: Another Component is already using directory: "F:\xampp\htdocs\SynergyIntegration\administrator\components\com_ckforms"

Anyone know what this means....and/or how to resolve it?

Thanks,


C
apache.indian
 
Posts: 5
Joined: 08. November 2009 05:57

SUCCESS !!! All problems resolved...component installed succ

Postby apache.indian » 08. November 2009 19:21

Okay guys,

I've been able to resolve my own problems...and for the benefit of others (who may end up with the same problems as myself) here's what I did:

In order to resolve the first problem i.e. timeout error "Fatal error: Maximum execution time of 60 seconds exceeded in F:\xampp\htdocs\SynergyIntegration\libraries\joomla\installer\installer.php on line 911", I did the good old DOS search command (which I still use till today) on my USB stick drive (localhost drive) for the file PHP.INI...and changed/increased the timeout and memory allocation settings there.

Now, since the installation of my component failed mid-stream....due to the timeout error.....it left some folders lurking around on the USB drive's directory structure.

In order to resolve that problem I deleted the folder/directory named "com_ckforms" under the components folder...and I also deleted a folder/directory named "ckforms" under the "\administrator" folder/directory of my XAMPP installation on the USB stick.

I was then able to successfully install the CKForms component.

Hope this helps others.

Later,

C
apache.indian
 
Posts: 5
Joined: 08. November 2009 05:57

Re: Fatal error: Maximum execution time of 60 seconds exceeded..

Postby adnet23 » 15. October 2010 18:40

where in the php.ini file do i change the execution time limit?
adnet23
 
Posts: 4
Joined: 19. January 2009 22:27

Re: Fatal error: Maximum execution time of 60 seconds exceed

Postby mpg187 » 10. November 2010 04:44

When I try to restore my Backups from my site to my localhost copy of phpBB I get this error. This didn't happen before, but it does now (maybe because my database is getting bigger?)

I have tried it on Multiple VMs (Ubuntu, Server 2003). Last time I checked it worked on the VM I use at school...
Administrator of OP420 Technology Forum
User avatar
mpg187
 
Posts: 4
Joined: 10. November 2010 04:32
Location: Operation420.net most of the time...

Re: Fatal error: Maximum execution time of 60 seconds exceed

Postby Altrea » 10. November 2010 06:08

mpg187 wrote:This didn't happen before, but it does now (maybe because my database is getting bigger?)
I have tried it on Multiple VMs (Ubuntu, Server 2003). Last time I checked it worked on the VM I use at school...

Thats right, indirectly. That happend if your system isn't fast enough to process the whole restore inside the execution time limit. The bigger your export the more time it will take on the same system. Some systems are faster than the others. Thats clear, isn't it?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Fatal error: Maximum execution time of 60 seconds exceed

Postby mpg187 » 11. November 2010 00:55

Well how come this VM goes faster? I think the computers at school have better specs than my laptop, so maybe that's why.

What can I do to make it work?
Administrator of OP420 Technology Forum
User avatar
mpg187
 
Posts: 4
Joined: 10. November 2010 04:32
Location: Operation420.net most of the time...

Re: Fatal error: Maximum execution time of 60 seconds exceed

Postby Altrea » 11. November 2010 05:59

mpg187 wrote:Well how come this VM goes faster?

Don't know. Could be anything, Hardware and/or Software. I don't know the specs of your systems.
Are the Webservers both configured the same way?

mpg187 wrote:What can I do to make it work?

- You can increase the max execution time limit in your php.ini.
- You can import your Database dump with the MySQL CLI Tool mysqldump
- You can use tools like mysqldumper for your backups and restores. This program avoids the time limits.
- You can split the .sql files by Hand into smaller files (be careful with that!)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Fatal error: Maximum execution time of 60 seconds exceed

Postby mpg187 » 14. November 2010 04:09

Oh I forgot to say before that last time I checked I can restore on the host, unless VMs hog resources more and slow things down. But at school VMs work, but maybe because those systems can handle the extra load...
Administrator of OP420 Technology Forum
User avatar
mpg187
 
Posts: 4
Joined: 10. November 2010 04:32
Location: Operation420.net most of the time...


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 23 guests