problem starting apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

problem starting apache

Postby smolyi » 07. November 2009 12:02

Hello friend!
i seem to have problem starting my Apache.
when i start it, it says "busy ..." and then writes "WARNING: terminating worker thread 0.
and then : "apache started"
but the start button doesnt change to "stop" button. ..
the Svc checkbox is uncehcked. when it is, it wont start at all.

the error log:
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

moreover, when i try to browse the localhost on the web explorer it requires a user name and password. i have tried many logical combinations that didnt work, including the default one (user: root, password: )but yet, it didnt work.
how can i set the password?
thank you very much
smolyi
 
Posts: 1
Joined: 07. November 2009 11:50

Re: problem starting apache

Postby tenshi13 » 07. November 2009 13:49

Hi,
not sure bout the login part
but the one regarding the port,

if you're usin XAMPP as a production server then try to edit the apache's httpd.conf
find the part for port
the default will be a line like tis:
port=80

try edit it to
port=127.0.0.1:80

tat's wud i did prevly... hope it helps

regards
Ethan
tenshi13
 
Posts: 3
Joined: 07. November 2009 11:43

Re: problem starting apache

Postby Izzy » 07. November 2009 22:17

smolyi wrote:the error log:
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Click on the Port Check button in your XAMPP Control Panel (XCP) and see what is using the above port 80 that Apache needs, then stop that program.

Usually Skype - disable port 80 and port 443 in the configuration.
Or IIS (Microsoft's inetserv - Internet Information Server) - disable in your Windows Control Panel.

You can't have another server running on the same port.
smolyi wrote:moreover, when i try to browse the localhost on the web explorer it requires a user name and password
This may point to the program that is using port 80 and should disappear when you have removed the offending port hog.
XAMPP won't ask for a password until you set one after Apache is running using the Security page - readme_en.txt file.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: problem starting apache

Postby ttapping » 09. June 2010 16:18

In the http.conf file, I changed the listening port to an unused port (Listen 127.0.0.1:88) and all was good. Did NOT have to mess with IIS! ;-)

Good tip to use the xampp-portcheck.exe utility.

HTH.

Tim
ttapping
 
Posts: 1
Joined: 09. June 2010 16:11


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests