How to upgrade mod_ssl to the latest version?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

How to upgrade mod_ssl to the latest version?

Postby imthewolfman » 07. November 2009 03:55

Hello,

I have recently ran a web vulnerability scanner on my website and it says that my current version of mod_ssl/2.2.11 is too outdated and that I should upgrade to the latest version, or else my site might fall victim to a Denial of service or possible arbitrary code execution.

I already have everything that came with XAMPP version 1.7.1 installed (Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9). I just need to upgrade my current version of mod_ssl to the latest version which is 2.8.31 according to the official website. It seems however that the latest version is still in beta stage for win32 systems and that I need MS Visual C++ to compile the package which I don't have.

Is there an easier method to upgrade mod_ssl? Can I just possibly replace the "mod_ssl.so" file in xampp\apache\modules and just call it a day?
imthewolfman
 
Posts: 4
Joined: 16. August 2009 11:16

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 82 guests