MySQL refuses to Start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL refuses to Start

Postby jenn21dw » 06. November 2009 04:52

Windows Vista
XAMPP Lite V. 1.7.1 (needed this one for use w Joomla)

Apache is running fine
MySQL refuses to start

When I click on SCM, go to MySQL, and try to start from there, I get - "Windows could not start on local computer - error 1067: the process terminated unexpectedly"
Under properties when i right click in SCM, it says: "C:\DOCS\xampplite-win32-1.7.1_1\xampplite\mysql\bin\mysqld.exe" --defaults-file="C:\DOCS\xampplite-win32-1.7.1_1\xampplite\mysql\bin\my.ini" MySQL

I installed XAMPP in C:/DOCS because my computer would not let me do it in C: - not sure why, I am logged on as admin
In control panel, when I uncheck it and click start, the box reads - MySQL started - port

now, i am getting a box in SCM saying - Windows was unable to query status for service MySQL - the remote connection on local computer has been broken.
the specified service does not exhist as an installed service.

I have to say I am very frustrated, have been trying to fix issues for 2 days now. I cannot completely uninstall the version of XAMPP I originally installed - deleted all folders, but they keep coming back, seemingly empty, but still there.

also, when i save something to my htdocs, it doesn't show up on my local server - i get Object not found error 404

can someone please help???????
Posts: 4
Joined: 04. November 2009 03:16

Re: MySQL refuses to Start

Postby Izzy » 06. November 2009 05:17

You must first remove all traces of your previous XAMPP installation before trying to install a new version.

Did you follow either of the 2 uninstall instruction methods in the XAMPP for Windows home page?
Or in the file?

If the old 1.7.2 folder won't delete then either a service or a file is still being used by Windows and may be the reason you are having trouble with installing xampplite in to the proper default location.

Perhaps disabling the UAC temporarily may help:

To disable UAC go to
Start>Control Panel>User Accounts
there you will find an option
Turn User Account Control on or off
just click on it and uncheck
User Account Control to help protect your computer
click OK.

You may also consider becoming a Super Administrator that may give you more control of your PC.

Before you try and remove 1.7.1 lite, which you should to get a fresh start, make sure there are no ticks in the Svc boxes in your XAMPP control Panel.

Make sure all components are stopped and the XCP is closed.

You should now be able to remove the 1.7.1 folder.

Next reboot and try and remove the original XAMPP 1.7.2 folder again.

Post back if you get this far as we may be able to get rid of the MySQL NT Service, that is giving issues, from the registry.
Posts: 3344
Joined: 25. April 2006 17:06

Re: MySQL refuses to Start

Postby jenn21dw » 06. November 2009 07:34

will attempt and report back tomorrow - its getting late here .... Thanks a ton!
Posts: 4
Joined: 04. November 2009 03:16

Re: MySQL refuses to Start

Postby guilhermo » 12. November 2009 14:20


I downloaded the windows essentials package from and installed it on the directory where xampp would install it (C:\xampp\mysql).
Just it.

It works!

Guilhermo Luna
Posts: 1
Joined: 12. November 2009 13:55

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests