What Went Wrong with 1.7.2 PHP does not get parased

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby Liquid1 » 23. January 2010 21:02

Can someone please repile PLEASE? Have been stuck with this problem for weeks now and I need to get my site back up and running.
was xammp not started to help people with no idea how to install apachie php etc I cannot find the php.ini file or a mySQL.ini file for that matter to change.
] A little bit of help would be very welcome about now
Liquid1
 
Posts: 9
Joined: 23. January 2010 02:11

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby Liquid1 » 24. January 2010 00:20

Thanks for the support guys...have voted with my feet and dropped xampp, I don't have time to wast waiting for people who know how to fix this to play god.
I will advise my other I.T mates to stay clear of xampp from now on, here is the heads up guys People don't like been made to look a fool after years of telling people how good something is, only to find the true support side is naff.
take care,
Liquid
Liquid1
 
Posts: 9
Joined: 23. January 2010 02:11

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby y0ursource » 24. January 2010 19:07

you say its because of coding short tags as the issue right? wrong... even using <?php and ?> makes no difference
people in the thread have even explained they have tried using the correct tags and shortcut tags same issue.

This is a missing cog in the wheel it's not going to go away so putting your head into the sand and thinking its people
who's coded scripts is doing it wrong its not... its xampp something is wrong why wont you look into this properly?

its actually thinking a > is a ?> thats the problem so any html tag what so ever that has a < > its seeing > as ?>

why on earth wont you test this out yourself?

This is not a PHP5 issue i have installed manually MYSQL Server, + PHP5 + Apache stand-alone and it does not do it.
it is SOMETHING you have missed or missing in your bundled package.

anything newer than 1.7.1 will not work with PHP any script any website anything with HTML, PHP, will not work on anything newer than 1.7.1
you keep updating 1.7x more and more but you are not fixing this major issue.

this effects vbulletin, ipb, phpbb, mybb, torrent scripts, hosting scripts, everything!!!!

the only reason no-body has come accross this problem (hosting site wise) they are running Standalone php5 not XAMPP!!!

My god why won't you listen to your users this is a MAJOR!!! error.
y0ursource
 
Posts: 12
Joined: 06. November 2009 02:03

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby Liquid1 » 25. January 2010 02:38

Also the following...V3 Chat, flash chat, phpbb"ALL OF THEM", jamoola, all of tufat's scripts, osdate, flashchat, easysite, phpflashmyadmin,flashcard,infact ever single thing have payed money for will not load up rite
... infact all its good for at the moment is an html web server, god am fed up, everything the lad above is telling you is true but still nothing from the team there Why?? .
Liquid1
 
Posts: 9
Joined: 23. January 2010 02:11

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby Liquid1 » 25. January 2010 03:01

I wonder if thay have copy n pasted some of the old code refering to the old PHP..."Just an idea" thats making conflicts...lol its good when you start thinking up where thay got it wrong lol
Liquid1
 
Posts: 9
Joined: 23. January 2010 02:11

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby Wiedmann » 25. January 2010 09:51

its actually thinking a > is a ?> thats the problem so any html tag what so ever that has a < > its seeing > as ?>

why on earth wont you test this out yourself?

Did you have a (out of the box working) small sample script which shows the problem?
(together with a description of the current and the expected output)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby y0ursource » 25. January 2010 19:04

lol i shouldn't need anything as an example script to test look above this post 1.7.2/3 upwards does not work with anything
you test it out yourself, phpbb, mybb, flashchat, flashtalk, ipb, vbulletin, you name it .. it wont work right!!

here's your sample

http://sourceforge.net/projects/tbdevne ... r/download

Basic pre-made torrent script since its the easiest to find to show you how screwed up 1.7.2/3 is as it works perfectly on 1.7.1.

new 1.7.2 running y0ursource on XAMPP look at the mess it has when it hits the PHP
http://img683.imageshack.us/img683/6272/proof1.jpg

Again below another screen running same script index.php with 1.7.2
http://img199.imageshack.us/img199/3463/proof2a.jpg

Below is what the 2 images above should look like this was done with 1.7.1
http://img691.imageshack.us/img691/6246/ysproof1.jpg

Again another 1.7.1 this is what the second screen should look like
http://img691.imageshack.us/img691/8650/ysproof2.jpg
y0ursource
 
Posts: 12
Joined: 06. November 2009 02:03

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby Wiedmann » 25. January 2010 19:52

here's your sample

No, that's a complete software package and not a simple sample script.
--> If you think something is wrong with ">" and "?>" please provide a sample script. I can't reproduce this.

you test it out yourself, phpbb, mybb, flashchat, flashtalk, ipb, vbulletin, you name it .. it wont work right!!

I don't know anything about these software packages and can't give support for 3rd party software. Please ask the support of these packages which Aapche/MySQL/PHP version is supported from these software and how you must configure your server to get these software working (in case the software is not working with the default settings for Apache/MySQL/PHP).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby Liquid1 » 26. January 2010 00:07

Wiedmann please understand it's NOT our software My paid for software as worked for years"very well" for 1000's of people, it's not PHP as such, it's something not working rite in the xampp package
Liquid1
 
Posts: 9
Joined: 23. January 2010 02:11

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby y0ursource » 26. January 2010 01:52

yes it's a complete package so what??? run and install the damn thing like everyone else
and look at the sheer mess , then do the same again only this time with v1.7.1 and see the real outcome.

no there is no short script to test ffs every software package be it forums or anything of that kind comes as a full package lol.

my god you know there's a massive problem here and you refuse to test it with a "package" that millions of people are using daily
and telling you it does not work no more on xampp... forget your short scripts and use the packages that people are using and saying it does not work.

or are you affraid were all right and you dont have a damn clue how to fix this complete cluster fuck of a mess?
y0ursource
 
Posts: 12
Joined: 06. November 2009 02:03

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby Wiedmann » 26. January 2010 07:44

yes it's a complete package so what???

Ask the support of this software package what's the problem and what are the requirements to run this software package.

(especially for forum software you must do this also for each mod you are using)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby y0ursource » 26. January 2010 18:08

you know i've heard some reply's in my time from authors or people who work on scripts but this is a classic.

sorry you don't know any of them packages lmao this bloody forum is run from one of them packages you dont know.
tell me what "packages" do you know and i'll actually take my time to test with the ones YOU know hows that.

hell i should be support here for the help and lenth's your willing to go too.

lets face it people this issue will never get fixed xampp is now completely useless as a package all its useful for is a web server.
there is a fault people are telling you over and over again their paid premium software no longer works on v1.7.2/3 and you still
continue to go the route of "its not our problem check with the 3rd party vendors etc etc"

Tell me o wise one what software should we be using as a 3rd party to check that its xampp and not their software?
lets face it were never going to get any further with this because you refuse to take the time and test different packages for yourself.

you've made xampp to run a webserver, which supports php, and has a db engine but when we try to use it for that it was designed for
you tell us to contact 3rd party about the problem lol, it's laughable.

there must be someone else here a admin or a team member who actually wrote and put xampp together we can talk to about this
because you sir are less than helpful and bordering on useless.

What did the Creator use to test xampp on?? the testing beta processes what scripts and packages did they use to beta test the xampp package?
or did no testing take place since none of you seem to know any packages or scripts at all that uses php lol

this is a complete joke

BTW i'll ASK myself the 3rd party Creator what my script supports

y0ursource: = www.y0ursource.com = AKA i am the bloody vendor !!!!
y0ursource
 
Posts: 12
Joined: 06. November 2009 02:03

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby cube » 27. January 2010 10:27

Wiedmann wrote:
its actually thinking a > is a ?> thats the problem so any html tag what so ever that has a < > its seeing > as ?>

why on earth wont you test this out yourself?

Did you have a (out of the box working) small sample script which shows the problem?
(together with a description of the current and the expected output)


Code: Select all
<?
function test($x$y)
{
    if (
$x $y) {
        echo 
"x is greater than y";
    } else {
        echo 
"y is greater than or equal to x";
    }
}

echo 
test(1,2);
?>    


Problem is that the PHP code after the > in the if statement is streamed to the browser.

Doesn't happen if you change <? to <?php

Quentin
cube
 
Posts: 4
Joined: 26. January 2010 21:24

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby Wiedmann » 27. January 2010 10:54

Doesn't happen if you change <? to <?php

Exactly what we have written all over this thread:
You have to use "<?php" and not "<?" and so that's the expected behavior.
(or you must change the php.ini setting "short_open_tag" which is not recommended)

So there is no bug and the first chapter in the PHP manual is explaining this too:
http://de.php.net/manual/en/language.basic-syntax.phpmode.php
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: What Went Wrong with 1.7.2 PHP does not get parased

Postby mkm854 » 27. January 2010 11:17

kindly follow this path:C:\xampp\apache\conf\extra in local drive:

next open:httpd-xampp.conf

search FilesMatch Tag and replace by
<FilesMatch "\.(html|htm|php|rhtml|shtml)$">
SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler application/x-httpd-php-source
</FilesMatch>

Thanks

try this I will definetly working on win XP
mkm854
 
Posts: 5
Joined: 27. January 2010 10:26

PreviousNext

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests