need some help

Problems with the Windows version of XAMPP, questions, comments, and anything related.

need some help

Postby jess2626 » 02. November 2009 02:16

im making an online game that is hamachi

but everytime i go to enter it i get a page that says:

Safari can’t open the page.
Too many redirects occurred trying to open “http://localhost/security_check_token”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.

any ideas how to fix it?
jess2626
 
Posts: 2
Joined: 02. November 2009 01:54

Re: need some help

Postby Izzy » 02. November 2009 02:38

jess2626 wrote:im making an online game that is hamachi...
...any ideas how to fix it?
An Advanced Search in forum XAMPP for Windows using Keyword hamachi would have found this very recent topic:
viewtopic.php?f=16&t=37847
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: need some help

Postby jess2626 » 03. November 2009 01:14

i have, i went into C:\xampp\apache\conf\extra\httpd-xampp.conf
and i dont see what you posted

all i see is this
# XAMPP settings
#
<IfModule alias_module>
<IfModule mime_module>
#ScriptAlias /php/ "C:/xampp/php/"
#Action application/x-httpd-php "/php/php-cgi.exe"
LoadModule php5_module "C:/xampp/apache/bin/php5apache2.dll"
AddType application/x-httpd-php-source .phps
AddType application/x-httpd-php .php .php5 .php4 .php3 .phtml .phpt

<Directory "C:/xampp/htdocs/xampp">
<IfModule php5_module>
<Files "status.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
</Directory>

Alias /security "C:/xampp/security/htdocs/"
<Directory "C:/xampp/security/htdocs">
<IfModule php5_module>
<Files "xamppsecurity.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>

Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
<Directory "C:/xampp/phpMyAdmin">
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>

Alias /webalizer "C:/xampp/webalizer/"
<Directory "C:/xampp/webalizer">
<IfModule php5_module>
<Files "webalizer.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>

Alias /contrib "C:/xampp/contrib/"
<Directory "C:/xampp/contrib">
<IfModule php5_module>
<Files "webalizer.php">
php_admin_flag safe_mode off
</Files>
</IfModule>

AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
</IfModule>
</IfModule>


# Access restriction via Remote
<IfModule auth_remote_module>
<Directory "C:/xampp/htdocs/fonts">
AllowOverride All
AuthType Basic
AuthName "AUTH REMOTE TEST"
AuthRemoteServer localhost
AuthRemotePort 80
AuthRemoteURL /forbidden/
Require valid-user
#User: user / Password: pass
</Directory>
</IfModule>

# Access restriction via MySQL
<IfModule mysql_auth_module>
<Location /restricted>
AuthMySQLEnable On
AuthName "MySQL Secured Place"
AuthType Basic
require valid-user
AuthMySQLHost localhost
AuthMySQLUser root
# AuthMySQLPassword
AuthMySQLDB webauth
AuthMySQLUserTable user_pwd
AuthMySQLNameField name
AuthMySQLPasswordField pass
AuthMySQLPwEncryption none
</Location>
</IfModule>


no where do i see this :
#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
Order deny,allow
Deny from all
Allow from ::1 127.0.0.0/8 \
fc00::/7 5.0.0.0/8 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 \
fe80::/10 169.254.0.0/16

ErrorDocument 403 /error/HTTP_XAMPP_FORBIDDEN.html.var
</LocationMatch>
jess2626
 
Posts: 2
Joined: 02. November 2009 01:54

Re: need some help

Postby Izzy » 03. November 2009 01:22

When posting on these forums for support and to save wasting time you should always post your XAMPP version and Windows OS.

My reply assumed you were using XAMPP 1.7.2 like the OP of the link I gave.

Answers for your browser's message may be found here and what your browser seems to have set in motion by that message is a prevention process for an endless loop - which points at the settings in your Hamachi configuration.

Try clearing your browser's cache or use a different browser like Firefox or IE to test again.

Also check your Apache error.log file for possible clues.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests

cron