Tomcat not installed by default in XAMPP Win32 1.7.2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Tomcat not installed by default in XAMPP Win32 1.7.2

Postby sj22 » 26. October 2009 14:19

Greetings:
I did an installation of Win 32 1.7.2 and apache, mysql, filezilla and mercury was installed. I was able to check the box on the left and start all four. Howerver, Tomcat is greyed out. How could I install the Tomcat?

Thanks
SJ
sj22
 
Posts: 6
Joined: 26. October 2009 14:08

Re: Tomcat not installed by default in XAMPP Win32 1.7.2

Postby Izzy » 26. October 2009 17:59

You can download and install the Tomcat addon from the XAMPP for Windows Home Page - same page you downloaded 1.7.2 from.

BTW it would be a good idea to read the above Home Page and the FAQ linked form the same page both contain helpful information, plus the readme file that came with XAMPP and, before installing Tomcat, it's associated readme file.

Good luck.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Tomcat not installed by default in XAMPP Win32 1.7.2

Postby sj22 » 28. October 2009 21:13

Thanks Izzy.
I installed Tomcat add on and restarted all the services. However, when i try to open a php file it just shows the content, it is not running. is there anything that i need to change on httpd.conf under apache to make php work?

-SJ
sj22
 
Posts: 6
Joined: 26. October 2009 14:08

Re: Tomcat not installed by default in XAMPP Win32 1.7.2

Postby Izzy » 28. October 2009 23:27

Are Apache and MySQL started - check by looking for the green running next to Apache and MySQL in the XAMPP Control Panel.

Look in the error log file - \xampp\apache\logs\error.log

Make sure your php script starts with <?php not <?

Can you see the Welcome Page when you type http://localhost in your browser?

What are you typing in your browser to access the php page that just gives code?

How are you trying to open the php file that just gives code?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Tomcat not installed by default in XAMPP Win32 1.7.2

Postby sj22 » 28. October 2009 23:49

Hi Izzy,

My mistakes:
I was not placing the install files under c:\xampp\htdocs

I was able to start the installation by http:\\localhost:8080\install\

I have a question about Mercury, which I will post under another thread.

>>> I am also going to put the following info so that it will be helpful for other users trying to install Group Office under XAMPP

Group Office installation on Windows 2008 server with XAMPP for Windows 1.7.2

- Uninstall IIS and SQL server and everything else - just have the base windows 2008 system
- Go to xampp.org and download the latest XAMPP
- Install XAMPP
- Go to xampp.org and download Tomcat add-on and install tom-cat
- Get Group Office install package; extract and place files under c:\xampp\htdocs\goff <goff is a name i had chosen, you can choose any name>
- Start your browser and go to http:\\localhost:8080\goff\install to start the Group Office Installation and follow the prompts.

I am running into a mail server issue, which i will post as a separate thread when I find the resolution


>>>>>

Izzy Thanks for your help

-SJ

Pls close this thread and submit to knowledge base
sj22
 
Posts: 6
Joined: 26. October 2009 14:08


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests