Apache Problems

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Problems

Postby thehodapp » 23. October 2009 17:18

So I have XAMPP installed, and it was working the other day, but I logged on yesterday and when I tried to run Apache it wouldn't work. The console tells me there is an error and it terminates the worker thread.

Here is the log file for apache.
Code: Select all
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted.  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


Any help would be greatly appreciated.
thehodapp
 
Posts: 5
Joined: 22. October 2009 04:55

Re: Apache Problems

Postby Wiedmann » 23. October 2009 17:56

could not bind to address 0.0.0.0:80

Stop the program which is using port 80 and you can start Apache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache Problems

Postby thehodapp » 23. October 2009 17:59

Thank you very much.

Is there an easy way to see the program using that port?
thehodapp
 
Posts: 5
Joined: 22. October 2009 04:55

Re: Apache Problems

Postby thehodapp » 23. October 2009 22:37

Nevermind I figured it out. This website explained how to do it:

http://otfans.net/showthread.php?t=149601

Thanks again for the help.
thehodapp
 
Posts: 5
Joined: 22. October 2009 04:55


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 25 guests