Xampp 1.7.2 Server Root error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp 1.7.2 Server Root error

Postby TJH09 » 23. October 2009 15:22

I am currently battling trying to get Apache on Xampp 1.7.2 to run succesfully. I have narrowed the problem down to the directory logged in the apache httpd.exe file; which I found from the error log:

Code: Select all
httpd.exe: Syntax error on line 35 of E:/apache/conf/httpd.conf: ServerRoot must be a valid directory


Line 35 in httpd.exe reads:

Code: Select all
ServerRoot "/xampp/apache"


I currently have xampp installed onto my Freecom USB drive in the top directory (currently E:\), so to get Apache to run properly is it simply a matter of changing the above line in httpd.exe to the following, since the apache folder is in the top directory of my USB:

Code: Select all
ServerRoot "/apache"


Thanks!
TJH09
 
Posts: 2
Joined: 23. October 2009 15:13

Re: Xampp 1.7.2 Server Root error

Postby Izzy » 23. October 2009 23:06

Open your XAMPP Control Panel and look to see if there are any ticks in the Svc boxes.

If there are then it means you have installed those components with a tick as an NT Service when you installed XAMPP.

This defeats the object of installing on a portable USB device.

Try removing the ticks and reboot your PC then again try to start the servers.

The same would apply if you added the E:\ to your paths in the conf file - it would make your XAMPP on the USB unportable because chances are that the E:\ drive would not be mapped in the next PC you placed the USB device.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Xampp 1.7.2 Server Root error

Postby TJH09 » 25. October 2009 11:43

Thanks Izzy,

I have managed to get Apache working, I didn't have any of the Services installed. However, now mySQL is playing up and won't start - its behaving in the same way as Apache did (press Start...nothing happens even though mySQL is said to be running).

Does anyone have any hints on tackling mySQL running problems?

Or would the best solution be to simply buy a brand new USB drive and only install Xampp on there, since it has had so much trouble with my current drive?
TJH09
 
Posts: 2
Joined: 23. October 2009 15:13

Re: Xampp 1.7.2 Server Root error

Postby stuffdone » 26. October 2009 00:30

TJH09 wrote:Thanks Izzy,

I have managed to get Apache working, I didn't have any of the Services installed. However, now mySQL is playing up and won't start - its behaving in the same way as Apache did (press Start...nothing happens even though mySQL is said to be running).

Does anyone have any hints on tackling mySQL running problems?

Or would the best solution be to simply buy a brand new USB drive and only install Xampp on there, since it has had so much trouble with my current drive?


Same here. Installed on a machine running Windows 2000 SP4 and the MySQL won't start.
Web Designer since 1995 ( http://www.stuffdone.com ).
Please assume I don't know this stuff, because I don't
stuffdone
 
Posts: 10
Joined: 26. October 2009 00:16
Location: NE Florida

Re: Xampp 1.7.2 Server Root error

Postby stuffdone » 26. October 2009 01:14

It is started now. I un-checked the box in the control panel under "svc" and clicked "start" and it works now.
Web Designer since 1995 ( http://www.stuffdone.com ).
Please assume I don't know this stuff, because I don't
stuffdone
 
Posts: 10
Joined: 26. October 2009 00:16
Location: NE Florida


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 88 guests