xampp 1.7.2 apache don't start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp 1.7.2 apache don't start

Postby shrg18 » 22. October 2009 00:25

the error log shows:
(OS 10048)... : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

the port-check shows:
Apache <HTTP> 80: SYSTEM
(all other ports listed Free)

I use Windows Vista Home Basic and set super user administrator.

when uninstalled all applications include Skype, port 80 was still taken by SYSTEM, error log showed the same message.
shrg18
 
Posts: 43
Joined: 16. August 2007 13:59
Location: windsor, on, canada
Operating System: windows 8

Re: xampp 1.7.2 apache don't start

Postby Izzy » 22. October 2009 02:49

Try and disable IIS if it is used.

Temporarily disable your firewall and or your AV scanner.

Try again after a reboot.

If you can now access Apache, configure the above firewall/AV to allow the Apache and MySQL ports.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp 1.7.2 apache don't start

Postby shrg18 » 22. October 2009 17:38

Izzy wrote:Try and disable IIS if it is used.

Temporarily disable your firewall and or your AV scanner.

Try again after a reboot.

If you can now access Apache, configure the above firewall/AV to allow the Apache and MySQL ports.

thank you. it works.
shrg18
 
Posts: 43
Joined: 16. August 2007 13:59
Location: windsor, on, canada
Operating System: windows 8

Re: xampp 1.7.2 apache don't start

Postby kolimasson » 28. October 2009 18:23

Hi I've got the same problem.
I'm on Vista, all my port are free (especially port 80), but Apache just start running for two second before stoping

What ISS is?
kolimasson
 
Posts: 2
Joined: 28. October 2009 18:21

Re: xampp 1.7.2 apache don't start

Postby Izzy » 28. October 2009 23:36

kolimasson wrote:Hi I've got the same problem.
I'm on Vista, all my port are free (especially port 80), but Apache just start running for two second before stoping

What ISS is?
Well if you had the same problem then the checks I posted should have helped you as well. ;)

IIS is the Microsoft built in web server - Internet Information Server or inetserv and uses port 80 by default but in your case if port 80 is free then it is already diasbled.

Try starting Apache by double clicking on the apache_start.bat file in the xampp folder as it will usually give feedback why it can't start.

Read the error log file in \xampp\apache\logs

Make sure you are logged into Vista as an administrator and maybe temporarily disable UAC.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp 1.7.2 apache don't start

Postby kolimasson » 29. October 2009 18:15

thank you for your answer, but I don't have any error file
so I don't know where the bug comes from
kolimasson
 
Posts: 2
Joined: 28. October 2009 18:21

Re: xampp 1.7.2 apache don't start

Postby Izzy » 29. October 2009 20:08

Izzy wrote:Try starting Apache by double clicking on the apache_start.bat file in the xampp folder as it will usually give feedback why it can't start.
Paste here the results.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp 1.7.2 apache don't start

Postby albebart » 31. October 2009 23:05

I've got the same problem, Vista Home Premium, using norton360.
I read your previous suggestion, bat...
When I start Apache by double clicking on the apache_start.bat, it takes a little bit then return:

"apache" is not started.
Hit a key... etc etc....

In apache/Logs/error it appears:
"(OS 10048)Di norma è consentito un solo utilizzo di ogni indirizzo di socket (protocollo/indirizzo di rete/porta). : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs"

I don't know how to check if port 80 is free or not... :oops:
and I cold find IIS in my service manager... so i think it's not installed... :oops:

help me please.
Bart
albebart
 
Posts: 3
Joined: 31. October 2009 22:53

Re: xampp 1.7.2 apache don't start

Postby albebart » 31. October 2009 23:43

Excuse me Izzy, but now it seems work.
The problem could be skype....

For the other: I find this info in
http://www.apachefriends.org/en/faq-xam ... ml#nostart

Thanks
Bart
albebart
 
Posts: 3
Joined: 31. October 2009 22:53

Re: xampp 1.7.2 apache don't start

Postby Izzy » 01. November 2009 00:08

Bart wrote:I don't know how to check if port 80 is free or not...
Bart, in your XAMPP Control Panel there is a button Port Check - give that a click.

Or if the Port Check won't work, click on the Shell button and at the # prompt type exactly this:
netstat -a -n -o -p TCP
It should tell you the process that is using port 80 and 443, and other ports - see below for finding what process is using the ports by checking the PID (Process ID) in the Processes tab of the Task Manager.

Bart wrote:and I cold find IIS in my service manager... so i think it's not installed...
IIS would usually be intserv.exe (internet server or Internet Information Server - IIS) so look in the Task Manager if it is running by right clicking on the TaskBar and select Task Manager from the menu then Processes tab and look for intserv.exe and if you find it then you will have to disable it in your Windows Control Panel.

BTW Skype can be configured not to use port 80 and 443 so you have the best of both worlds - Skype and your web server.

Good luck.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp 1.7.2 apache don't start

Postby albebart » 02. November 2009 10:53

Hi Izzy

Thank you for your support!!!

All is working, now...
albebart
 
Posts: 3
Joined: 31. October 2009 22:53


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests