Get errors when launching localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Get errors when launching localhost

Postby cmccann6 » 13. October 2009 20:30

Have the following configuration for XAMPP with Joomla 1.5.14:

###### ApacheFriends XAMPP (Basispaket) version 1.7.1 ######

+ Apache 2.2.11
+ MySQL 5.1.33 (Community Server)
+ PHP 5.2.9 + PEAR (Support for PHP 4 has been discontinued)
+ XAMPP Control Version 2.5 from http://www.nat32.com
+ XAMPP CLI Bundle 1.3 from Carsten Wiedmann
+ XAMPP Security 1.0
+ SQLite 2.8.15
+ OpenSSL 0.9.8i
+ phpMyAdmin 3.1.3.1
+ ADOdb 5.06a
+ Mercury Mail Transport System v4.62
+ FileZilla FTP Server 0.9.31
+ Webalizer 2.01-10
+ Zend Optimizer 3.3.0
+ eAccelerator 0.9.5.3 für PHP 5.2.9 (but not activated in the php.ini)

---------------------------------------------------------------

* System Requirements:

+ 64 MB RAM (RECOMMENDED)
+ 250 MB free fixed disk
+ Windows NT, 2000, 2003, XP (RECOMMENDED), VISTA
+ Only 32 Bit (NOT for 64 bit systems)

When I launch localhost administrator, http://localhost/myjoomla/administrator/index.php, this works fine with no problems. But when I try and open http://localhost/myjoomla/index.php, I get the following errors:

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
10/13/09 08:15:32
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9

Any suggestions?

Thanks.
cmccann6
 
Posts: 4
Joined: 13. October 2009 20:27

Re: Get errors when launching localhost

Postby Wiedmann » 13. October 2009 20:38

But when I try anBut when I try and open http://localhost/myjoomla/index.php, I get the following errors:
Object not found!

(assuming a default XAMPP installation:) It seems there is no file "\xampp\htdocs\myjoomla\index.php".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Get errors when launching localhost

Postby Nobbie » 13. October 2009 20:40

cmccann6 wrote:Any suggestions?


Obviously, this is a Joomla Issue - why not asking there?
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Get errors when launching localhost

Postby cmccann6 » 13. October 2009 22:17

I think I am going to try and move Joomla to the root of XAMPP and see what happens. Thanks.
cmccann6
 
Posts: 4
Joined: 13. October 2009 20:27

Re: Get errors when launching localhost

Postby cmccann6 » 13. October 2009 22:36

No difference. Joomla is now is root but still get the error:


Warning: require_once(C:\xampp\htdocs\includes\defines.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampp\htdocs\index.php on line 21

Fatal error: require_once() [function.require]: Failed opening required 'C:\xampp\htdocs\includes\defines.php' (include_path='.;C:\xampp\php\pear;C:\xampp\php\pear\') in C:\xampp\htdocs\index.php on line 21
cmccann6
 
Posts: 4
Joined: 13. October 2009 20:27

Re: Get errors when launching localhost

Postby cmccann6 » 13. October 2009 22:59

Resolved by supplying missing defines.php in the Joomla includes directory.
cmccann6
 
Posts: 4
Joined: 13. October 2009 20:27


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests