How can I change the defalt collation?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

How can I change the defalt collation?

Postby miguelopez » 11. October 2009 03:48

Hi all,

I want to know which are the steps to change the default collation, because when I have created the table, the collation latin1_swedish_ci appears. I tried to get a solution by myself searching in this and another forums, also with help from google, but only I can find this http://dev.mysql.com/doc/refman/5.0/es/ ... erver.html and I have entered these commands trying to change the collation to utf8_general_ci into the shell but appears a error message.

I'm using Windows 7.

Thanks in advance.
miguelopez
 
Posts: 3
Joined: 11. October 2009 03:12

Re: How can I change the defalt collation?

Postby Izzy » 11. October 2009 04:20

miguelopez wrote:I want to know which are the steps to change the default collation
The default connection collation is set to utf8_general_ci in the xampp\phpMyAdmin\libraries\config-defaults.php file under the sub heading:
* Language and character set conversion settings

Read the big note at the beginning of this file and take notice of what it says.

You can easily change collation for database/tables etc. when you create your database and tables using phpMyAdmin.

http://localhost/phpmyadmin
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: How can I change the defalt collation?

Postby miguelopez » 25. October 2009 17:21

However, it's boring and takes some time make the changes to every table and database, so I want to change if in config-defaults.php file is possible to change latin1_swedish_ci to another collation BY DEFAULT in order to avoid make the changes manually.

Thanks again.
miguelopez
 
Posts: 3
Joined: 11. October 2009 03:12


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests