XAMPP 1.7.2 or XAMPP 1.71

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP 1.7.2 or XAMPP 1.71

Postby amanda099 » 10. October 2009 15:50

Dear Room !
I am installing a shopping cart application but it does not work with PHP 5.3 which is bundled with XAMPP 1.7.2
I searched their forum and found that I need to use an earlier version of XAMPP , XAMPP 1.71 or early version.
I would like to keep XAMPP 1.7.2
I would appreciate any suggestions on this issue !
Amanda Nguyen
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby Izzy » 11. October 2009 00:25

Amanda, you can have more than one instance of XAMPP on your PC, I have 5, in fact you are only limited in number by your disk space, but you can only run one instance at a time unless you want to mess with changing listening ports etc. and is not really necessary in a development environment or, in my case, a troubleshooting environment.

IMHO, if you want to add more XAMPP versions, it is better to use the self extracting EXE (7zip) or the ZIP archives not the installer versions then when the files are extracted to the folder of choice you would run the setup_xampp.bat file to set the paths correctly.

I use xampp - xampp1 - xampp2 etc. as the folders for the different versions but you may want to use a different method to identify the different versions.

You can also have a shortcut on your desktop to each of the different version's XAMPP Control Panels for ease of starting and stopping them.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby amanda099 » 12. October 2009 23:07

Izzy

..but you can only run one instance at a time unless you want to mess with changing listening ports etc...

If I can only run one instance at a time, can all my applications using different instances of XAMPP versions run side by side ?
..and is not really necessary in a development environment or, in my case, a troubleshooting environment.

I am hosting my website from my own Windows XP computer; do you call it a development environment in my case ? Could you define 'development environment' wholly for me if that is not what you meant ?

IMLTHO Amanda Nguyen
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby Izzy » 12. October 2009 23:55

Amanda, you can only run 1 server at a time on the default port 80 period.

Using the Alias directive (examples in the httpd-xampp.conf file) or VirtualHosts directive (examples in the httpd-vhosts.conf file) you can have your various web content in any folder location on your PC including in another XAMPP version's folder.
Advanced Search the forum and please read these:
http://httpd.apache.org/docs/2.2/mod/mo ... html#alias
http://httpd.apache.org/docs/2.2/vhosts/
http://httpd.apache.org/docs/2.2/mod/directives.html

You're best asking the cart software site when they will be upgrading their cart to work with php 5.3 then you need only have XAMPP 1.7.2 installed and running.

If they say sometime in the future perhaps and you can't find a shopping cart that likes to work in the 21st century then your best plan is to install XAMPP 1.7.1 and use it as your front line production server.

You can, using my method above, still retain XAMPP 1.7.2 and use it by changing the Listen directive in the httpd.conf and the httpd-ssl.conf files if required so that you can develop and/or test your scripts/apps using http://localhost:[new listen port]/your script or app/.

Remember to always make a copy of any .conf or .ini file before editing and after editing restart the component the configuration file relates to.



Development server means develop and/or test your scripts/apps using http://localhost then you would upload your developed site to a dedicated hosting service.

Production server means the same as you want to do now, that is run your XAMPP on your home based PC connected to the Internet to serve your web site's...
(...but, as the readme points out, this is not recommended.
Also make sure and check that you are not breaking your ISP's Terms of Service by running a web server from home
).
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby amanda099 » 15. October 2009 16:52

Hi Izzy
Okay , I need to ruminate over that to get beyond my discombobulation , then I shall get right back atcha !
Amanda
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby amanda099 » 15. October 2009 17:39

Might I ask where the link for downloading XAMPP 1.7.1 is ?
Amanda
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby Izzy » 15. October 2009 18:01

The link to the SourceForge Archive is on the XAMPP for Windows Home Page, the same page you downloaded 1.7.2 from.

http://sourceforge.net/project/showfile ... e_id=89552
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby amanda099 » 16. October 2009 23:19

Hi Izzy

I have now extracted xampp-win32-1.7.1 into C:\xampp1 on my computer using the self extracting EXE (7z) and being in the battle field.

When I run the setup_xampp.bat file I receive the following info:
Code: Select all
ApacheFriends XAMPP setup win32 Version 1.7
Copyright <c> 2002-2009 Apachefriends
Authors: Kay Vogelgesang <kvo@apachefriends.org>
         Carsten Wiedmann <webmaster@wiedmann-online.de>

Configure for server 1.7.1
Configure XAMPP with awk for 'Windows_NT'
Please wait ...
Enable AcceptEx Winsocks v2 support for NT systems DONE!

##### Have fun with ApacheFriends XAMPP! #####

Press any key to continue ...


Then I press enter and everything disappears.
Then I rename the file C:\xampp1\xampp-control into C:\xampp1\xampp1-control and make its shortcut on my desktop.
Then I click on the shortcut to xampp1-control on the desktop. On the lower half of the XAMPP Control Panel, there are:

Code: Select all
XAMPP Control Panel Version 2.5 (9.May, 2007)
Windows 5.1 Build 2600 Platform 2 Service Pack 3
Current Directory: C:\xampp1
Install Directory:
*** WARNING: Directory mismatch ***
Status Check OK


My guess is that, I should respond to the warning *** WARNING: Directory mismatch *** I looked for
the setup button on the XAMPP Control Panel to see what I can do, But there is no such button. So how do I proceed from there ? What is your best advice ?

You can, using my method above, still retain XAMPP 1.7.2 and use it by changing the Listen directive in the httpd.conf and the httpd-ssl.conf files if required so that you can develop and/or test your scripts/apps using http://localhost:[new listen port]/your script or app/.

Now I have the shopping cart folder in XAMPP 1.7.2, C:\xampp\htdocs\imabeauty\zencart\ (imabeauty is the root folder of my website, zencart contains the shopping cart files and folders)
Please give me the instructions on how to change the Listen directive in the httpd.conf and the httpd-ssl.conf files in XAMPP 1.7.2
what [new listen port] should I use ?

And humongus cyberhugz from a most grateful Amanda Nguyen for putting up with me and being so very helpful !
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby Izzy » 17. October 2009 03:46

Edited to make it simpler.

amanda099 wrote:Then I rename the file C:\xampp1\xampp-control into C:\xampp1\xampp1-control
No need to rename this file and also you have not enabled the file extension visibility setting on your PC which can give you file recognition issues down the track.

Open Windows Control Panel and select Folder Options.
Then un-tick the box "Hide extensions for known file types"
Click Apply then OK and close the Control Panel window.

Now check your file again and this time it should show as xampp-control.exe or, as you have inadvisedly changed the name, it should read xampp1-control.exe.

amanda099 wrote:*** WARNING: Directory mismatch ***
You can safely ignore this message as it relates to a non existent registry entry and is hard coded in older XAMPP version's XCP.


To change the Listen directive in 1.7.2 open the C:\xampp\apache\conf\httpd.conf file in your text editor (notepad for example) and find the line Listen 80 and change it to Listen *:8080 for example which is the alternative to port 80.

Now when you want to access 1.7.2 files you would always have to add the new port number to the address in your browser, for example:
http://localhost:8080
http://localhost:8080/phpmyadmin
http://mywebsite:8080/zendcart/index.php
Get the idea?


Now to use the zencart in the 1.7.2 folder using 1.7.1 you would need to create an Alias directive in the httpd-xampp.conf file in the C:\xampp\apache\conf\extra\ folder of version 1.7.1

There are already some working Alias examples in the 1.7.1 httpd-xampp.conf file and if you add your Alias for the zencart files after the phpmyadmin Alias entry so yours, for example, may look like this
Code: Select all
    Alias /zencart "C:\xampp1\htdocs\imabeauty\zencart\"
    <Directory "C:\xampp1\htdocs\imabeauty\zencart">
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
Then when you have 1.7.1 running and you type in your browser:
http://yourwebsite/zencart/index.php
then it should go to the zencart folder in the 1.7.2 version of XAMPP and load the zencart files.


You may also have to change the SSL port in httpd-ssl.conf in the extra folder of version 1.7.2 like so:
Listen 443
to
Listen 4433
and in 2 other locations in this httpd-ssl.conf file that specify 443, change those 2 also to 4433.

Accessing the secure socket layer now in 1.7.2 would need you to add the port number much like the regular http requests outlined above.
for example:
https://localhost:4433
https://yourwebsite:4433/zendcart/index.php

There is already a self signed SSL certificate provided in XAMPP that will always give an error message that can usually be ignored when developing but would cause concern if used on your production server - see the reading advice above.


Don't forget to make backup copies of the conf files and to restart the Apache server after editing.
Last edited by Izzy on 19. October 2009 06:58, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby amanda099 » 18. October 2009 23:12

Izzy

First of all I'd like to clarify how I assign names to folders :
C:\xampp\ is the folder of version 1.7.2
C:\xampp1\ is the folder of version 1.7.1
I installed xampp 1.7.2 first and it has always been and is in C:\xampp\ . I didn't change xampp 1.7.2 folder's name when I installed xampp 1.7.1.

Should this now be:
Now I have the shopping cart folder in XAMPP 1.7.2, C:\xampp1\htdocs\imabeauty\zencart\

I didn't make mistake in the previous post by stating that :
"Now I have the shopping cart folder in XAMPP 1.7.2, C:\xampp\htdocs\imabeauty\zencart\"
No need to rename this file and also you have not enabled the file extension visibility setting on your PC which can give you file recognition issues down the track.

I have rerenamed xampp1-control (of xampp 1.7.1)back to xampp-control
To change the Listen directive in 1.7.2 open the C:\xampp1\apache\conf\httpd.conf file in your text editor (notepad for example) and find the line Listen 80 and change it to Listen *.8080 for example which is the alternative to port 80.

Apache of version 1.7.2 didn't want to start after I changed the line Listen 80 to Listen *.8080 in the C:\xampp\apache\conf\httpd.conf file of version 1.7.2
If 1.7.1 Apache won't start by giving a port already in use when you have 1.7.2 running in parallel ....

Could you possibly say that in a way I might better understand that . Can you break it down just a teensy bit easier ? I'm slipping under the waves a little bit. ...what is a port already in use here ?


Kindly Amanda
PS. I've scoped out zen-cart absitively & concluded utmostly there's not a snowballs' chance in hades of knowing when they will upgrade their zen-cart. As of yet I have yet to find a more attractive one than zen-cart. And I wish to take my website to a much higher level & love a challenge !
Last edited by amanda099 on 18. October 2009 23:40, edited 4 times in total.
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby Izzy » 18. October 2009 23:24

Apache of version 1.7.2 didn't want to start after I changed the line Listen 80 to Listen *.8080 in the C:\xampp\apache\conf\httpd.conf file of version 1.7.2
Change that to Listen *:80

Read the error.log file if you get a situation where Apache can't start.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby amanda099 » 18. October 2009 23:29

Oh, You replied before I finished my post , Please get back to my post !
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: XAMPP 1.7.2 or XAMPP 1.71

Postby amanda099 » 19. October 2009 17:52

Might I ask should I create the database for zencart using phpMyAdmin of the 1.7.2 or 1.7.1 version ?
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests