Problems accessing php files with XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems accessing php files with XAMPP

Postby gh05 » 06. October 2009 21:08

Hi,

I've installed XAMPP and have placed some php files in the htdocs folder. I've run apache and mysql but when I type http://localhost/htdocs/index.php, it says that the page can't be found.

Can anyone tell me what I'm doing wrong?

Thanks,

GH
gh05
 
Posts: 6
Joined: 06. October 2009 21:04

Re: Problems accessing php files with XAMPP

Postby Izzy » 06. October 2009 21:26

Don't include htdocs in the URI.

http://localhost/index.php should do it.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problems accessing php files with XAMPP

Postby gh05 » 06. October 2009 22:22

I tried typing http://localhost/index.php and still get the same result - cannot display page.

I read elsewhere that I should also be able to access phpadmin by typing http://localhost/phpmyadmin but this also gives 'cannot display page'.

Is it likely to be something with my settings or could I have installed it wrong?

Thanks.
gh05
 
Posts: 6
Joined: 06. October 2009 21:04

Re: Problems accessing php files with XAMPP

Postby Izzy » 07. October 2009 06:51

What do the error logs tell you?

Look in the error log file for any clues C:\xampp\apache\logs\

Is Apache and MySQL running?

Check in the XAMPP Control Panel for the green running indication.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problems accessing php files with XAMPP

Postby gh05 » 07. October 2009 12:07

Thanks, I'll check this when I have access to XAMPP again,. In work at the moment.

One thing though... I realised that when I type in http://localhost I get an image saying ISS (Internet Shared Services). Do you think this could be causing a problem?

Thanks.
gh05
 
Posts: 6
Joined: 06. October 2009 21:04

Re: Problems accessing php files with XAMPP

Postby gh05 » 07. October 2009 19:12

Hi,

My error log is as below:

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

I noticed that actually Apache isn't starting after all and it's simply saying 'busy' when i press start. Mysql starts fine.

Any ideas?

Thanks,

Gareth
gh05
 
Posts: 6
Joined: 06. October 2009 21:04

Re: Problems accessing php files with XAMPP

Postby Izzy » 07. October 2009 22:11

You have another server using the ports that Apache needs exclusively.

From your XAMPP Control Panel (XCP) click on the Port-Check button or double click on xampp-portcheck.exe in the xampp folder and see what it is and then you will be able to correct this issue.

Usually Skype
(change the ports in the configuration)
and or IIS
(Microsoft Internet Information Server - inetserv - disable in Windows Control Panel).

Also make sure that any firewall or anti-virus scanners and ZoneAlarm are configured to allow the ports that XAMPP uses - Port Check reveals the list of ports.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problems accessing php files with XAMPP

Postby gh05 » 08. October 2009 11:04

Hi,

I've tried to disable IIS by typing iisreset /stop from the run menu (although when I type localhost I still get the IIS7 icon.) Does this mean that IIS is still running?

Anyway if i run a 'port check' it tells me:

Service Port Status
Apache (HttP) 80 SYSTEM
Apache (WebDav) 81 FREE
Apache (HTTPS) 443 FREE

Is there any other port that I could tell it to use?

Thanks.
gh05
 
Posts: 6
Joined: 06. October 2009 21:04

Re: Problems accessing php files with XAMPP

Postby Izzy » 08. October 2009 11:48

It sure looks like IIS is still on localhost port 80.

gh05 wrote:I've tried to disable IIS...
I don't know what OS you are using but in this topic there is instructions to disable IIS in both XP and Vista:
viewtopic.php?p=134260#p134260

Here is another topic about the SYSTEM issue that may help if you are using Vista:
viewtopic.php?p=135356#p135356
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problems accessing php files with XAMPP

Postby gh05 » 10. October 2009 00:23

Working now. Many Thanks for your help Izzy! Much appreciated.
gh05
 
Posts: 6
Joined: 06. October 2009 21:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests