localhost/xampp wont work/ 127.0.0.1/xampp does

Problems with the Windows version of XAMPP, questions, comments, and anything related.

localhost/xampp wont work/ 127.0.0.1/xampp does

Postby not1337 » 03. October 2009 20:17

Hey,

I didn't see any other post with this same exact issue. I created a clean install of XAMPP 1.7.2

I'm running XP
I do have "127.0.0.1 localhost" in my hosts file.
Nothing is blocking port 80. Apache is running on it.
I am able to see php apps on localhost/ e.g. "http://localhost/phpmyadmin/" comes up fine.

But when I try to open "http://localhost/xampp/" I get the "application/x-httpd-php" prompt which doesn't know what to do with the PHP file and wants to DL the source.

If I navigate to "http://127.0.0.1/xampp" I am able to see the page just fine. Which makes this more confusing. I can ping localhost, other pages work, why not this one?

I'm guessing its an httpd.conf issue or one of its includes. Please help.

Thanks.
not1337
 
Posts: 2
Joined: 03. October 2009 20:00

Re: localhost/xampp wont work/ 127.0.0.1/xampp does

Postby Wiedmann » 03. October 2009 20:38

I am able to see php apps on localhost/

What happens (can you see) if you access http://localhost/ in your browser?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: localhost/xampp wont work/ 127.0.0.1/xampp does

Postby not1337 » 04. October 2009 04:42

nope. Same behavior as localhost/xampp. If I go to http://127.0.0.1 I get the xampp page. If I go to http://localhost I get the php source of the xampp page.
not1337
 
Posts: 2
Joined: 03. October 2009 20:00

Re: localhost/xampp wont work/ 127.0.0.1/xampp does

Postby Izzy » 04. October 2009 07:08

not1337 wrote:If I go to http://127.0.0.1 I get the xampp page. If I go to http://localhost I get the php source of the xampp page.
Try this:

Find this IPv6 line in your hosts file, if it exists:
:11 localhost

Comment it out so it looks like this (or delete it):
# :11 localhost

Save the file and try again to access http://localhost.

If it doesn't exists try adding it under the 127.0.0.1 localhost entry, save the file, then try http://localhost again.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: localhost/xampp wont work/ 127.0.0.1/xampp does

Postby alucard01 » 05. October 2009 15:04

Maybe apache setting incorrect. Can you please post your apache setting?
alucard01
 
Posts: 122
Joined: 15. May 2005 13:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 27 guests