Chmod under Vista?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Chmod under Vista?

Postby Bluesplayer » 03. October 2009 12:26

Hi

I am trying to install a program on my Xampp server under Vista. The installer is saying that I need to chmod a file to 0777 which currently shows 0666. By clicking the read only box the file becomes 0444 so that isn't any good. How can this file be 0666 and yet all the rest are 0777? How can a directory in this program have a different chmod than the rest? I take it the control for this is inside the program itself somewhere? I can't seem to find a way to alter the permissions and FileZilla permission boxes are empty.

Regards
Bluesplayer
Bluesplayer
 
Posts: 3
Joined: 03. October 2009 12:05

Re: Chmod under Vista?

Postby Nobbie » 03. October 2009 13:51

Windows does not support chmod, this a linux command (due to the different rights management). Simply ignore that part of installation description for windows.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Chmod under Vista?

Postby Bluesplayer » 03. October 2009 13:57

Seems odd that certain files on this installation have such chmod settings and I can't ignore them as the install won't continue unless I alter the settings. There is ioncube security on this software installation and I think that is the reason for my problem. I am going to install a full server now without vista or any operating system. Hopefully I know enough to have a go at this.

Thanks
Bluesplayer
Bluesplayer
 
Posts: 3
Joined: 03. October 2009 12:05

Re: Chmod under Vista?

Postby Nobbie » 03. October 2009 16:42

Bluesplayer wrote:I am going to install a full server now without vista or any operating system.


You must install an operating system, there is no Computer without any operating system. Install any linux OS and you will have chmod-support.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Chmod under Vista?

Postby Bluesplayer » 03. October 2009 16:50

I am having a go at Ubuntu which looks amazing. Just have to figure out now how to install it on my scsi drives. For some reason the partitioning isn't working. Should get it up and running soon though.
Bluesplayer
 
Posts: 3
Joined: 03. October 2009 12:05


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests