a problem with getting the apache service to start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

a problem with getting the apache service to start

Postby drako0812 » 03. October 2009 10:47

Yeah, I've looked at some other posts that have had similar problems, but I haven't found a solution yet.

The error.log for apache contains the following:

Code: Select all
Syntax error on line 505 of I:/Program Files (x86)/XAMPP/xampp/apache/conf/httpd.conf:
SSLSessionCache: Invalid argument: size has to be >= 8192 bytes
Syntax error on line 505 of I:/Program Files (x86)/XAMPP/xampp/apache/conf/httpd.conf:
SSLSessionCache: Invalid argument: size has to be >= 8192 bytes
Syntax error on line 505 of I:/Program Files (x86)/XAMPP/xampp/apache/conf/httpd.conf:
SSLSessionCache: Invalid argument: size has to be >= 8192 bytes
Syntax error on line 505 of I:/Program Files (x86)/XAMPP/xampp/apache/conf/httpd.conf:
SSLSessionCache: Invalid argument: size has to be >= 8192 bytes


I'm using XAMPP on Windows Vista Home Premium x64 SP2 if that has anything to do with it.

EDIT:
I thought you might want to know what the line in question was, but I'll do you one better and show the small block of "code":

# Secure (SSL/TLS) connections
Include "conf/extra/httpd-ssl.conf"
#
# Note: The following must must be present to support
# starting without SSL on platforms with no /dev/random equivalent
# but a statically compiled-in mod_ssl.
#
<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
SSLSessionCache "shmcb:logs/ssl.scache(512000)"
SSLSessionCacheTimeout 300
</IfModule>
I listen to Coast to Coast AM, and you should, too. :)
drako0812
 
Posts: 2
Joined: 03. October 2009 10:38

Re: a problem with getting the apache service to start

Postby Nobbie » 03. October 2009 11:31

Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: a problem with getting the apache service to start

Postby drako0812 » 03. October 2009 11:47

Well, I tried it out, but it came up with another error. I might try reinstalling into "I:/Program Files/" rather than "I:/Program Files (x86)/", since the parentheses seem to be the problem.

Anyway, here's the error:
Code: Select all
Syntax error on line 506 of I:/Program Files (x86)/XAMPP/xampp/apache/conf/httpd.conf:
SSLSessionCache: Invalid argument


Oh, and I commented out the old line, so that's why the line number is different.

EDIT:
Yep, reinstalling it in a different folder worked.
I listen to Coast to Coast AM, and you should, too. :)
drako0812
 
Posts: 2
Joined: 03. October 2009 10:38


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 80 guests