How to install Apache 2.2.13 under XAMPP?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

How to install Apache 2.2.13 under XAMPP?

Postby Thomas ODell » 03. October 2009 06:33

Hi, I am a new XAMPP user, not very familiar with Apache or XAMPP.

I installed XAMPP 1.7.2 on my Windows XP virtual machine under OSX. After I installed, my Secunia Personal Software Inspector informed me that Apache 2.2.12 is insecure, and that I needed to update to Apache 2.2.13. I followed the update and installed Apache 2.2.13 under C:\xampp\apache. The installation proceeded without any error, but when I tried to start the apache service, I got the error "Syntax error on line 122 of C:/xampp/apache/conf/extra/httpd-xampp.conf: The specified IP address is invalid."

I commented out the LocationMatch under "New XAMPP Security Concept" and now apache starts up properly. But I am nervous about what security I have disabled and what other damage I have done to XAMPP.

Thanks in advance for your quick response,

Thomas O'Dell
Academic Associate
School of Infocomm Technology
Republic Polytechnic
Thomas ODell
 
Posts: 2
Joined: 03. October 2009 06:10

Re: How to install Apache 2.2.13 under XAMPP?

Postby Izzy » 03. October 2009 08:18

Thomas ODell wrote:I followed the update and installed Apache 2.2.13 under C:\xampp\apache.
It is not possible to overwrite Apache in XAMPP with another version effectively as Apache in XAMPP is compiled and configured specifically to work in the component compilation environment that is XAMPP.

I am sure that the developers are aware of the update that is required and available and will soon have an update for XAMPP in the pipeline - they are very much on the ball.


An alternative for you is to install an older version of XAMPP that includes an Apache version that you feel is safe to use until XAMPP is updated and they are available from the SourceForge Repository.

You can of course download and install the latest versions of Apache, MySQL, Perl and PHP as individual components, then configure them yourself to work together or wait for XAMPP to be upgraded

Good luck..
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: How to install Apache 2.2.13 under XAMPP?

Postby Thomas ODell » 03. October 2009 08:37

Thanks for your prompt response.

According to Secunia, the security problem in Apache relates to some Integer Overflow vulnerabilities due to inclusion of a vulnerable version of the APR-util library. The vulnerabilities can potentially be exploited to cause a DoS (Denial of Service) or to compromise a vulnerable system. (See http://secunia.com/advisories/36138/ for more details.)

What effect with this vulnerability have on students running XAMPP under default configuration to study PHP?

Regards,

Thomas O'Dell
Academic Associate
School of Infocomm Technology
Republic Polytechnic
Singapore
Thomas ODell
 
Posts: 2
Joined: 03. October 2009 06:10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests