Mercury incompatible Windows Vista

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mercury incompatible Windows Vista

Postby healer » 29. September 2009 12:30

I installed xampp-win32-1.7.2.exe on Windows Vista Home Basic. There was an error message. This problem happens because of partial incompatibility with Windows. Please tell me how to solve the problem.
healer
 
Posts: 7
Joined: 26. December 2005 11:58

Re: Mercury incompatible Windows Vista

Postby Izzy » 30. September 2009 01:01

healer wrote:There was an error message...Please tell me how to solve the problem...
To try and "solve the problem" first we need more info about the problem.

What is this error message exactly?

How exactly are you installing XAMPP and how are you answering the questions in the installation setup script?

The more details you provide the easier it is to find the solution.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mercury incompatible Windows Vista

Postby healer » 30. September 2009 02:04

The error message came up every now and then as "Interactive services dialog detection" saying "A program can't display a message on your desktop. The program may need information or permission to complete a task." The I click on "Show me the message" The screen would just go blank. I click on "Show progdram details". The details are as follows.

Program(s) or device(s) requesting attention.
Message title: Mercury/32
Program path: F:\xampp|MercuryMail\mercury.exe
Received: Today, 30 September 2009, 2 minutes ago.

The problem happens because of partial incompatibility with Windows.
Please contact the program or device manufacturer(s) for more information.

The mail functions do not work at all. By the way, can we attach image to posts in this forum?

I ran the xampp-win32-1.7.2.exe as an administrator to install it. I ran the setup_xampp.bat to relocate it. What else did I need to do? I did the same with xampplite-win32-1.7.1.exe. Anyway I only have problem with the Mercury. I use the Apache server, mySQL and PHP. I don't use anything else. Apache server, mySQL and PHP don't seem to have any problem. I just need the mail function as well if it is possible.

What installation setup script are you referring to? Does it come up automatically with the executable installation program or some script I need to run?
healer
 
Posts: 7
Joined: 26. December 2005 11:58

Re: Mercury incompatible Windows Vista

Postby Izzy » 30. September 2009 02:45

...By the way, can we attach image to posts in this forum?
You can provide an image using the Img button when composing a message - you would need to use an image hosting service and link to the image and remember that an image over 800 x 600 is too big.

What installation setup script are you referring to?
After you double click on xampp-win32-1.7.2.exe to install XAMPP you should see a console window that asks you some questions and is the installation script I refer to which in fact is the xampp_setup.bat file that automagically loads after double clicking the above exe file.

You would only need to run setup_xampp.bat file again after installation if you need to change things and in your case you could install XAMPP to any drive or partition as explained in the installation instructions on the XAMPP for Windows Home Page or in the readme file.


I have not seen your Mercury problem before so I can only suggest a few things.

Try disabling UAC and logging in to Vista as an administrator or a Super Administrator before installing XAMPP and before trying to manually tick the Svc boxes in the XCP - Svc boxes refer to the installation of the respective XAMPP component as an NT Service that will start the respective XAMPP component when Windows boots and is not usually required to run XAMPP in it's recommended role as a development tool.

Did you tick the Svc box next to Mercury in the Xampp Control Panel (XCP)?

Did you try and start Mercury by clicking on the Start button in XCP after ticking the Svc box?

What happens next?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mercury incompatible Windows Vista

Postby healer » 30. September 2009 13:36

I have just re-installed the xampp-win32-1.7.2.exe as an administrator again. I ran the XCP and ticked the Svc boxes to Apache, to MySql, to Mercury to install all these services. They all started without any problem. However, before long the same error message for the Mercury came up.

Do I need to do any configuration on the Mercury?
healer
 
Posts: 7
Joined: 26. December 2005 11:58

Re: Mercury incompatible Windows Vista

Postby Izzy » 30. September 2009 23:20

Stop Mercury first then remove the tick in the Svc box, then click OK when asked.

Now click on Start next to Mercury which should show Running in green then wait and see if the error message appears again.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mercury incompatible Windows Vista

Postby healer » 01. October 2009 10:33

It works this way without error. What could be the reason? It means I can't run it as an installed service, can I? How can I start and stop the Mercury on the command line? At present I have both the Apache and MySQL installed as service in manual mode. Every time I want to use the web server I run a batch file to start them, like net start apache2.2 and net start mysql. Can I do the same with Mercury? I do not want to have the XAMPP Control panel started and have it taking up the memory.

I am testing a production web site on my local web server. I test the email function, Contact Us. It seems to have sent the email without any error. However I didn't receive anything. Don't I need to set up something for it to work. I remember quite long time ago I needed to set up something directly on the Apache web server to get the mail functions work. Am I barking up the wrong tree?
healer
 
Posts: 7
Joined: 26. December 2005 11:58


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests