XAMPP FOR WINDOWS XP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP FOR WINDOWS XP

Postby nikis » 26. September 2009 20:41

I am a novice, have no knowledge of Jav, PHP, My SQL and Java Script, but a knowledge of the HPTML language.
I use the instructions from Dan Rahmels book "Beginning Joomla!", trying to download and install the Version 1.7.2 of XAMPP for Windows XP, which unfortunately does not comply to the XAMPP 1.7.0 used by Mr. Rahmel in his book, in my PC.
The 1.7.2. version requires that you set up in several stages the XAMPP by yourself.
1)I am downloading XAMPP by the Method A:Installation with the EXE (basic package) 44 MB, for the XAMPP Windows XP.
I have downloaded xampp-win32-1.7.2.exe. Then I double click on it and I am asked if I want to open this file which possibly has some bad code. I click on the small square with the OK.
Then the open Window security warning opens. Name: xampp-win32-1.7.2.exe, Editor : Unknown Type: Executable, From:C:\Documents and Settings\User\Desktop. I click on the [Execute](not on [Invalid].
2) The window of XAMPP for Windows opens, with instructions as folows:
* Press Install button to start installation
* Use Browse button to e.t.c.
e.t.c.
Destination folder is C:\ . I click on the install button, starting the installation window of XAMPP. According to Mr. Rahmels book the XAMPP Control Panel Application should open, but it does not open!
3) Instead of it, a black window with white letters opens and the title is: C:\Windows\System32\cmd.exe opens.
[XAMPP 1.7.32. - Setup]
[Copyright 2009 Carsten Widman <Free BSD License>]
Shoul I add shortcuts to starmenu/desktop?<y/n>:y
I click Return that is yes.
Now another window as the previous [XAMPP1.7.2.-Setup] opens, asking:
Should I locate the XAMPP paths correctly?: y
It asks me:Should I proceed ?< y/n=exit setup>:y
I click to both y and Return.
Still another Setup Windoe opens asking me: With USB sticks you must not use drive letters. Should I make a portable XAMPP without drive letters?Your chioce?<y/n>:n
As I will not use USB sticks, but I want to istall everything in my PC to study JOOMLA!, I choose no and click Return.
Then files are relocated XAMPP, XAMPPbase package,Apache, e.t.c.
XAMPP is ready ti use. Press Returnto continue. I press Return. The Setup Window informs me that "the timezone in "php.ini" and "my.ini"values is set to "Eueope/Helsinki", and that I should correct these values if wrong. As I don't know how to make changes for GREECE, I press Return to continue. Still another XAMPP 1.7.2 Setup Window opens informing me that:
1. Start XAMPP Control Panel
2. Relocate XAMPP <Current Path:C:\xampp>
3. Disable Server HTTPS <SSL>
4. Disable Server Site Includes <SSI>
5. Enable IPv4 only <current:IPv4/6<auto>>
7. Disable Apache:ASP
x Exit
Please choose <1-7/x>:
I choose x to Exit, hoping that the Control Panel of XAMPP will open, and press Return.
Then, a Source Forge page opens informing me that my XAMPP download will start shortly .....!
But I have already downloaded XAMPP, what have I done wrong ???
Where is the XAMPP Control Panel Application ? How am I going to make the Main Page of XAMPP for Windows appear ?
Thanking you in appreciation of your help
With kindest regards
Nick
nikis
 
Posts: 3
Joined: 25. September 2009 18:24

Re: XAMPP FOR WINDOWS XP

Postby Izzy » 27. September 2009 02:58

1. Start XAMPP Control Panel
2. Relocate XAMPP <Current Path:C:\xampp>
3. Disable Server HTTPS <SSL>
4. Disable Server Site Includes <SSI>
5. Enable IPv4 only <current:IPv4/6<auto>>
7. Disable Apache:ASP
x Exit
Please choose <1-7/x>:
I choose x to Exit, hoping that the Control Panel of XAMPP will open, and press Return.
You chose/typed x to Exit instead of typing 1 to Start XAMPP Control Panel (XCP).

The XCP is located in the C:\xampp folder - xampp-control.exe - create a shortcut for this on your desktop if there is not one there already.


The Setup Window informs me that "the timezone in "php.ini" and "my.ini"values is set to "Eueope/Helsinki", and that I should correct these values if wrong. As I don't know how to make changes for GREECE...
Open C:\xampp\php\php.ini file in your notepad text editor and look for this section:
Code: Select all
[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = "Europe/Helsinki"
Go to this link http://us2.php.net/manual/en/timezones.europe.php to get your time zone and replace the Europe/Helsinki with your own time zone ie. Europe/Athens so it now looks like this
Code: Select all
[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = "Europe/Athens"
Save the php.ini file and restart Apache to have those changes recognized.



Open in notepad C:\xampp\mysql\bin\my.ini and look for
Code: Select all
default-time-zone       = "Europe/Helsinki"
and change it much like you did for the php.ini file so it looks like this
Code: Select all
default-time-zone       = "Europe/Athens"
Save the file and restart MySQL.

As always make a backup "Copy of" any ini or conf file before editing.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: XAMPP FOR WINDOWS XP

Postby nikis » 27. September 2009 10:53

Dear Izzy,

Thank you very much for all the troubles you have gotten in to assist me.

I will correct all my former movements and try new ones informing you of my succes accordingly.

Thank you again,
With kindest regards
Nikis
nikis
 
Posts: 3
Joined: 25. September 2009 18:24

Re: XAMPP FOR WINDOWS XP

Postby Izzy » 27. September 2009 11:07

Your welcome Nikis and I look forward to hearing back from you that all is now as it should be and you can at last move forward with XAMPP.

Good luck.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: XAMPP FOR WINDOWS XP

Postby tekgnu » 07. December 2009 18:06

Just as an FYI, the default-time-zone in my.ini, was not accurate (which was the same time zone string I had in my PHP.ini. I literally just commented out the line with the default-time-zone and everything worked. According to what I have read it should pull the time zone from the host system.
tekgnu
 
Posts: 1
Joined: 07. December 2009 18:03

Re: XAMPP FOR WINDOWS XP

Postby Jenathan777 » 09. December 2009 06:59

I have installed xampp for windows 1.7.2 but PHP doesn't work.

coding this into the body section of an html page

<?php
echo phpinfo();
?>

produces no result - why?
Jenathan777
 
Posts: 4
Joined: 09. December 2009 06:35

Re: XAMPP FOR WINDOWS XP

Postby Jenathan777 » 09. December 2009 07:01

PS can anyone tell me what the timezone settings are for Australian Central Time?
Jenathan777
 
Posts: 4
Joined: 09. December 2009 06:35

Re: XAMPP FOR WINDOWS XP

Postby Bill Smith » 09. December 2009 07:39

Hi Jenathan777,

I copied your php echo code into a document that I named "test.php" and then ran it using in my browser by typing "http://localhost/test.php" and it worked perfectly.

The 2 key things seem to be 1) Use a .php, and not a .htm or .html; and 2) Be sure to include "http://localhost..." or appropriate IP address.
Bill Smith
 
Posts: 7
Joined: 09. December 2009 07:14

Re: XAMPP FOR WINDOWS XP

Postby Izzy » 10. December 2009 06:13

Jenathan777 wrote:PS can anyone tell me what the timezone settings are for Australian Central Time?
Go here and select your country Australia then the nearest location time zone to you:
http://us2.php.net/manual/en/timezones.php
Perhaps
Code: Select all
date.timezone = "Australia/Adelaide"


Did you fix your php issue?

If http://localhost/ gives you the XAMPP page with all the demos then PHP is working just fine.

Double check all your code is correct and the file containing php code has a .php file extension.

To validate your code, copy and paste your full page markup into the box provided here to see if it contains errors and how to fix them if errors are found:
http://validator.w3.org/#validate_by_input

Also check the \xampp\apache\logs\error.log file from time to time.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests