Document Root change on 1.7.2 not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Document Root change on 1.7.2 not working

Postby Sal » 25. September 2009 02:54

When i change the document root inside httpd.conf and then i open my browser and type:
http://localhost/phpinfo.php
(phpinfo.php simply contains: <?Php phpinfo(); ?>)
i get no output. Leaving every thing like it is at its installation, everything works.
I think that this version has changed something about the php.ini file because i can't find it where it usually was, and that was in the apache/bin dir. Did anyone find a solution for this?


this is what i change in the httpd.conf file

#DocumentRoot "C:/xampp/htdocs"
DocumentRoot "C:/Documents and Settings/Sal/Documenti/Apache htdocs"

#<Directory "C:/xampp/htdocs">
<Directory "C:/Documents and Settings/Sal/Documenti/Apache htdocs">
Sal
 
Posts: 6
Joined: 25. September 2009 02:30

Re: Document Root change on 1.7.2 not working

Postby Gadrin » 25. September 2009 04:03

>



My E-Book does pretty much the same...You did stop/restart apache right ?

1. Locate the section of the file that resembles this text:
#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot “C:/Program Files/Apache Group/Apache2/htdocs”

2. Change the last line of this section to
DocumentRoot “C:/Program Files/Apache Group/Apache2/test”
Notice that this uses forward slashes instead of backslashes.

3. Locate the section of the file that resembles this text:
#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something’s not working as
# you might expect, make sure that you have specifically enabled it
# below.
#
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory “C:/Program Files/Apache Group/Apache2/htdocs”>

4. Change the last line of this section to
<Directory “C:/Program Files/Apache Group/Apache2/test”>

5. Save your file and restart Apache so it can recognize the changes you made to the config
file. (Make sure you have created this directory before restarting Apache or you will get an
“Operation Failed!” error.)

>
Gadrin
 
Posts: 27
Joined: 08. April 2009 23:43

Re: Document Root change on 1.7.2 not working

Postby Sal » 25. September 2009 04:10

I start apache after the changes and not before :-)
And the directory is already there because i was using it successfully with xampp version 1.7.1.
I think it has something to do with the move of the php.ini out of the apache/bin directory.
Is there anyone using xampp 1.7.2 and that has a different web root directory working?

@gadrin: it seems that you're using the normal apache installation and not xampp.
Sal
 
Posts: 6
Joined: 25. September 2009 02:30

Re: Document Root change on 1.7.2 not working

Postby Sal » 28. September 2009 20:57

Nobody have an answer for this issue?
Sal
 
Posts: 6
Joined: 25. September 2009 02:30

Re: Document Root change on 1.7.2 not working

Postby Sal » 30. September 2009 15:22

where are the experts? the apachefriends, do i need change AMP installer because there's no solution?
Sal
 
Posts: 6
Joined: 25. September 2009 02:30

Re: Document Root change on 1.7.2 not working

Postby Nobbie » 30. September 2009 19:19

>(phpinfo.php simply contains: <?Php phpinfo(); ?>)

"<?Php" is no valid tag. Try "<?php" instead.
Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Re: Document Root change on 1.7.2 not working

Postby Sal » 02. October 2009 03:47

OMG! grrrr damn php 5.3. thanks.

anyway, i'm using <?Php and it works
Sal
 
Posts: 6
Joined: 25. September 2009 02:30


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests