My website wont run?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

My website wont run?

Postby blgrsguy » 18. September 2009 17:13

Trying to get the company website to run on XAMPP so I can take it to a trade show and let people use it without paying the exorbitant WIFI fee at the trade show. Simple test php files work such as a "hello world". However, I think XAMPP doesn't like the index.php file from our company website. Whenever I try http://localhost/ourwebsite/ I get a "The connection to the server was reset while the page was loading" in firefox. No I did not code the site and the guy that did has never used XAMPP. Hopefully its just as simple as turning a feature on somewhere?

Both Apache and Mysql are running as services (green 'running' lights on both).

I hope somebody can help me out here we are a very small organization and I'm just a marketing guy.
blgrsguy
 
Posts: 4
Joined: 18. September 2009 17:01

Re: My website wont run?

Postby Gadrin » 18. September 2009 18:52

2 Questions:

1. What's the path to your XAMPP folder ?
2. Whats the path to your OURWEBSITE folder ?

They should be similar.

For instance, on my laptop my testing folder is where
I keep my PHP files and the path looks like

C:\xampp\htdocs\test

and to get to a web page called Dir-Test.php, I enter:

http://localhost/test/Dir-Test.php

and it runs the PHP script on that page.

>
Gadrin
 
Posts: 27
Joined: 08. April 2009 23:43

Re: My website wont run?

Postby blgrsguy » 18. September 2009 19:36

Gadrin wrote:2 Questions:

1. What's the path to your XAMPP folder ?
2. Whats the path to your OURWEBSITE folder ?

>


C:\xampp\htdocs\xampp

C:\xampp\htdocs\ourwebsite

So what I'm wondering is do my php files need to be tweaked or do some config files need to be tweaked in Apache somewhere and how would I know.
blgrsguy
 
Posts: 4
Joined: 18. September 2009 17:01

Re: My website wont run?

Postby Gadrin » 18. September 2009 19:55

Create a file called hfx.php with the following contents:

Code: Select all

<?php

echo "Hello from XAMPP!";

?>



and save it in your c:\xampp\htdocs\ourwebsite folder.

Then click on this link: http://localhost/ourswebsite/hfx.php

and what happens ?

If you don't see the message, then it could be your localhost isn't configured correctly.
See your hosts file

C:\Windows\System32\drivers\etc\hosts

it should look like this:

Code: Select all
# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost


>
Gadrin
 
Posts: 27
Joined: 08. April 2009 23:43

Re: My website wont run?

Postby blgrsguy » 18. September 2009 20:41

Gadrin wrote:Create a file called hfx.php with the following contents:

Code: Select all

<?php

echo "Hello from XAMPP!";

?>



and save it in your c:\xampp\htdocs\ourwebsite folder.

Then click on this link: http://localhost/ourswebsite/hfx.php

and what happens ?

>


"Hello from XAMPP!" works. So I'm guessing something in my php files is running differently in XAMPP than when it is on our web server at the hosting company.
blgrsguy
 
Posts: 4
Joined: 18. September 2009 17:01

Re: My website wont run?

Postby Gadrin » 18. September 2009 21:43

blgrsguy wrote:"Hello from XAMPP!" works. So I'm guessing something in my php files is running differently in XAMPP than when it is on our web server at the hosting company.


Well, good. Now if you google for the error message text, one of the links mentions that
that error message is usually related to Firewall issues. So maybe start there on
the PC that's having problems and see if you can figure it out.

Maybe the PC's firewall is preventing the PC from getting to the server.

The connection to the server was reset while the page was loading

>
Gadrin
 
Posts: 27
Joined: 08. April 2009 23:43

Re: My website wont run?

Postby blgrsguy » 18. September 2009 22:08

Ok something I tried actually worked. I renamed index.php to homepage.php. Navigated to http://localhost/ourwebsite/homepage.php and it works, well, somewhat. I am now having problems with my sql database but I'm working with the guy who wrote the code to resolve that. I have windows firewall disabled and now I'm checking to see if there might be another firewall running somewhere.
blgrsguy
 
Posts: 4
Joined: 18. September 2009 17:01

Re: My website wont run?

Postby Gadrin » 18. September 2009 22:21

Good luck to you. 8)

>
Gadrin
 
Posts: 27
Joined: 08. April 2009 23:43


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests