unable to localhost/xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

unable to localhost/xampp

Postby gauri_agr » 17. September 2009 14:17

Hi,

I install fresh xampp using exe file. I started apache. When I type http://localhost/ , it redirect to http://localhost/localstart.asp .

I am unable to see http://localhost/xampp page.

Also I am unable to see index.php and index.html page. I am unable to guess the cause

I have checked the httpd.conf for documentroot and directoryindex , it seems correct.

Thanks & Regards
Gauri
gauri_agr
 
Posts: 11
Joined: 17. September 2009 14:13

Re: unable to localhost/xampp

Postby Altrea » 17. September 2009 17:16

Du you have an IIS running which blocks your port 80?
shows your xampp control panel a green "running" sign?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: unable to localhost/xampp

Postby gauri_agr » 17. September 2009 19:38

thanks for the reply , yes my IIS was running on port 80 so I stoped it and then started first apache and then IIS. its working fine


but when I rebooted , again IIS was working on port 80 so how can I force first apache aquire the port 80 during reboot

or any other solution?

Regards
Gauri
gauri_agr
 
Posts: 11
Joined: 17. September 2009 14:13

Re: unable to localhost/xampp

Postby Altrea » 17. September 2009 20:32

- If you don't use IIS, you can disable the start of the IIS-Service

- if you need both webserver you can switch your IIS-port (or your Apache port) to any free port
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: unable to localhost/xampp

Postby gauri_agr » 17. September 2009 23:12

hi I tried to look at xampp_portcheck and found

XAMPP PortCheck v1.4 by (c) 2009 Carsten Wiedmann (FreeBSD License)
Send bug reports to the author at <carsten_sttgt@gmx.de>,
or go to the XAMPP homepage at http://www.apachefriends.org/.

This script uses openport.exe:
Copyright (C) 2005 Diamond Computer Systems Pty. Ltd.
Official website: http://www.diamondcs.com.au/

Please wait a moment...


RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 C:\WINDOWS\system32\inetsrv\inetinfo.exe
Apache (WebDAV) 81 free
Apache (HTTPS) 443 C:\WINDOWS\system32\inetsrv\inetinfo.exe

MySQL 3306 C:\xampp\mysql\bin\mysqld.exe

FileZilla (FTP) 21 C:\WINDOWS\system32\inetsrv\inetinfo.exe
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 C:\WINDOWS\system32\inetsrv\inetinfo.exe
Mercury (POP3) 110 free
Mercury (IMAP) 143 free
Mercury (HTTP) 2224 free
Mercury (Finger) 79 free
Mercury (PH) 105 free
Mercury (PopPass) 106 free

Tomcat (AJP/1.3) 8009 free
Tomcat (HTTP) 8080 free

Press <Return> to continue.


so I tried to use port 81 by chaning two files

httpd and extra/httpd-ssl but I am unable to run apache.

Please let me know how to change the port. Can we assign any free port or there is some limit...could you please guide me

Thanks
Gauri
gauri_agr
 
Posts: 11
Joined: 17. September 2009 14:13

Re: unable to localhost/xampp

Postby Gadrin » 17. September 2009 23:30

You're in luck I spotted this earlier. Apache can co-exist with another WWW server...

Go to this URL and make sure you read #4...
http://httpd.apache.org/docs/2.0/platfo ... .html#inst

More details at: viewtopic.php?f=16&t=37233

>
Gadrin
 
Posts: 27
Joined: 08. April 2009 23:43

Re: unable to localhost/xampp

Postby gauri_agr » 18. September 2009 03:27

I think I am unable to follow the instruction to change the port from 80 to 8080 for apache.

could any one can guide me which file I need to change for making this change?

Thanks & Regards
Gauri
gauri_agr
 
Posts: 11
Joined: 17. September 2009 14:13

Re: unable to localhost/xampp

Postby Gadrin » 18. September 2009 04:01

my bad, I thought I posted this too...

If you had installation problems, note that you might experience errors, such as the “no services installed”
error if Apache is trying to share port 80 with another Web server or application, such as a firewall. To fix
this, open your httpd.conf file in the c:\program files\Apache group\Apache2\conf directory
and locate the following lines:

Code: Select all
    # Listen: Allows you to bind Apache to specific IP addresses and/or
    # ports, instead of the default. See also the <VirtualHost>
    # directive.
    #
    # Change this to Listen on specific IP addresses as shown below to
    # prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
    #
    #Listen 12.34.56.78:80
    Listen 80
    Change the last line of this block to read
    Listen 8080

Then locate the following lines:

Code: Select all
    #
    # ServerName gives the name and port that the server uses to identify itself.
    # This can often be determined automatically, but we recommend you specify
    # it explicitly to prevent problems during startup.
    #
    # If this is not set to valid DNS name for your host, server-generated
    # redirections will not work. See also the UseCanonicalName directive.
    #
    # If your host doesn’t have a registered DNS name, enter its IP address here.
    # You will have to access it by its address anyway, and this will make
    # redirections work in a sensible way.
    #
    ServerName www.yourdomainnamehere.com:80
    Change the last line of this code to the following:
    ServerName www.yourdomainnamehere.com:8080
Gadrin
 
Posts: 27
Joined: 08. April 2009 23:43

Re: unable to localhost/xampp

Postby gauri_agr » 19. September 2009 00:06

i made changes in two files httpd that u have mentioned and one more file extra/httpd-ssl for 8080 so my apache started.

but i am unable to open

http://localhost:8080/

it says
Bad request!
Your browser (or proxy) sent a request that this server could not understand.

If you think this is a server error, please contact the webmaster.

Error 400
localhost
9/18/2009 7:04:48 PM
Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0


............................


here is the port info


XAMPP PortCheck v1.4 by (c) 2009 Carsten Wiedmann (FreeBSD License)
Send bug reports to the author at <carsten_sttgt@gmx.de>,
or go to the XAMPP homepage at http://www.apachefriends.org/.

This script uses openport.exe:
Copyright (C) 2005 Diamond Computer Systems Pty. Ltd.
Official website: http://www.diamondcs.com.au/

Please wait a moment...


RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 C:\WINDOWS\system32\inetsrv\inetinfo.exe
Apache (WebDAV) 81 C:\xampp\apache\bin\httpd.exe
Apache (HTTPS) 443 C:\WINDOWS\system32\inetsrv\inetinfo.exe

MySQL 3306 C:\xampp\mysql\bin\mysqld.exe

FileZilla (FTP) 21 C:\WINDOWS\system32\inetsrv\inetinfo.exe
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 C:\WINDOWS\system32\inetsrv\inetinfo.exe
Mercury (POP3) 110 free
Mercury (IMAP) 143 free
Mercury (HTTP) 2224 free
Mercury (Finger) 79 free
Mercury (PH) 105 free
Mercury (PopPass) 106 free

Tomcat (AJP/1.3) 8009 free
Tomcat (HTTP) 8080 C:\xampp\apache\bin\httpd.exe

Press <Return> to continue.



thanks helping me
gauri_agr
 
Posts: 11
Joined: 17. September 2009 14:13

Re: unable to localhost/xampp

Postby Gadrin » 19. September 2009 00:36

Yes, I tried it on another PC we have here and couldn't get IIS and XAMPP to work (I couldn't get pages from either one).

I changed it back and got XAMPP to show the page (after stopping IIS).

So I'm confused too. I'll see about working on this, during the weekend.

I tried this: Apache & IIS Working on Same PC

Almost all the replies he got worked. My XAMPP Control Panel shows Apache on port 80 (not 8080) after the edits. Weird. :cry:

>
Gadrin
 
Posts: 27
Joined: 08. April 2009 23:43

Re: unable to localhost/xampp

Postby cragdire » 20. September 2009 02:58

Hi,

I am having the same issues. I changed my httpd file under Apache to 8080 and started the apache service and I just did a port ck and Apache is on 80 not 8080.
I did have IIS on 80, but it's not there. It does show that Tomcat has 8080 being used and it's not started.

The admin buttons doesn't go to anything. The page is blank.

Any ideas

Mike
cragdire
 
Posts: 10
Joined: 17. September 2009 11:29

Re: unable to localhost/xampp

Postby Izzy » 20. September 2009 03:19

cragdire wrote:Hi,

I am having the same issues. I changed my httpd file under Apache to 8080 and started the apache service and I just did a port ck and Apache is on 80 not 8080.
I did have IIS on 80, but it's not there. It does show that Tomcat has 8080 being used and it's not started.

The admin buttons doesn't go to anything. The page is blank.

Any ideas

Mike
Please don't cross post.

If you changed the port to 8080 then the Admin button for Apache won't work but http://localhost:8080 should.

BTW did you disable IIS in the Windows Control Panel?

If so there is no need to change the port in the httpd.conf file

Also make sure you have change the ports Skype uses if you have Skype installed.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: unable to localhost/xampp

Postby cragdire » 20. September 2009 03:25

Your Awesome Izzy :)

It works.

Mike

PS, my last cross post. Ever!
cragdire
 
Posts: 10
Joined: 17. September 2009 11:29

Re: unable to localhost/xampp

Postby mariana » 20. September 2009 18:44

I installed XAMPP and everything was ok, mysql was enabled and others. After we secure, I restarted mysql and when I looked at \ \ \ "status \ \ \" I noticed that mysql is disabled. Yet I went forward with a question mark, I wanted to install wordpress platform, everything was ok until I give \ \ \ 'install \ \ \ "and then informed me that it can not access the database. Why? Where am I wrong or what did? :(
Multumesc mult!!!!
mariana
 
Posts: 2
Joined: 20. September 2009 18:02

Re: unable to localhost/xampp/security/

Postby aloly » 08. October 2009 15:39

i try to open the security page but that happens
Access forbidden!
You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If you think this is a server error, please contact the webmaster.

Error 403
localhost
10/08/09 16:23:01
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.9
aloly
 
Posts: 1
Joined: 08. October 2009 15:35

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: Bonniem and 65 guests