installed over existing xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

installed over existing xampp

Postby rebelbrowser » 17. September 2009 04:16

Help !
Tonite I installed the latest xampp over the old one thinking it would be an upgrade.
All I needed was to upgrade the php5 to 5.2 or higher.
It did just what you thought it would do.
It wrote where it could, and was denied in some locations.
Now I have a stalled apache and all stock files....

Lets see if you can help me decide what to do from here.
We either can revert those files back to the way they were to make it work again or just start all over from scratch.
Did it erase/delete my database files too ?
Can we reattach everything back to the way it was or is it finally over after enjoying my server for almost a full year ?

nite, I will read you tomorrow... :tired
I really screwed up the server this time.
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17

Re: installed over existing xampp

Postby Nobbie » 17. September 2009 11:37

Didn't you make a backup before?
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: installed over existing xampp

Postby rebelbrowser » 17. September 2009 12:37

strangely, no
regretabley no...

excuse: my drives are all too full.
I shared this pc with the wife some many years ago, and she later discovered a dig camera.

I have plans to learn ghosting.... and get a terrabyte drive.
but I didnt know how to migrate properly the php thing...

so whats the damage ?
I see "Apache service not installed".
eventlog reads ip address not valid, and syntex error line 122.

122 fe80::/10 169.254.0.0/16

isnt that a private ip... i tried my servers lan number and it didnt go.
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17

Re: installed over existing xampp

Postby rebelbrowser » 19. September 2009 14:00

I managed to fix everything back to square, its working juts like before the mishap...

Thing is I am still interested in migrating the php to the lates version to run new stuff (ampache).
It needs php 5.3 I have 5.2
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17

Re: installed over existing xampp

Postby Nobbie » 19. September 2009 14:18

I dont think that ampache *needs* PHP 5.3 (because it runs on 5.2 for all systems different from Windows). Dont know why they recommend it.

Otherwise do a full backup of your current Xampp, de-install everything and install Xampp 1.7.2

Then restore all your documents and scripts (from htdocs), all ini-settingsand configurations (must be done manually, as some configuration files have changed) and the data-folder of MySQL (which holds all databases). And then "good luck"...
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: installed over existing xampp

Postby rebelbrowser » 19. September 2009 16:06

hey there hi..

I have everything somewhat back to normal...
I like what your saying.. about ampache.

I am trying to keep all this together, but I am all over the place with this one.
viewtopic.php?f=16&t=37263

perhaps this is a better place. join me there will ya !
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests