Can't start apache!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't start apache!

Postby tramvajman » 16. September 2009 02:58

When click start see "Busy..."
"Apache started"
But didn't started. Apache don't work.

See C:\xampp\apache\logs\error.log

[Wed Sep 16 07:45:16 2009] [notice] Digest: generating secret for digest authentication ...
[Wed Sep 16 07:45:16 2009] [notice] Digest: done
[Wed Sep 16 07:45:17 2009] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Wed Sep 16 07:45:17 2009] [notice] Server built: Jul 22 2009 11:35:54
[Wed Sep 16 07:45:17 2009] [crit] (22)Invalid argument: Parent: Failed to create the child process.
[Wed Sep 16 07:45:17 2009] [crit] master_main: create child process failed. Exiting.
[Wed Sep 16 07:45:17 2009] [notice] Parent: Forcing termination of child process 36
[Wed Sep 16 07:45:53 2009] [notice] Digest: generating secret for digest authentication ...
[Wed Sep 16 07:45:53 2009] [notice] Digest: done
[Wed Sep 16 07:45:53 2009] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Wed Sep 16 07:45:53 2009] [notice] Server built: Jul 22 2009 11:35:54
[Wed Sep 16 07:45:53 2009] [crit] (22)Invalid argument: Parent: Failed to create the child process.
[Wed Sep 16 07:45:53 2009] [crit] master_main: create child process failed. Exiting.
[Wed Sep 16 07:45:53 2009] [notice] Parent: Forcing termination of child process 36

I use Windows XP SP3
tramvajman
 
Posts: 2
Joined: 16. September 2009 02:49

Re: Can't start apache!

Postby vicki_uk09 » 16. September 2009 13:45

I am getting a similar problem, I'm using magento and when I access the admin page Apache stops working, this is my error log.
Code: Select all
[Wed Sep 16 13:32:39 2009] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Wed Sep 16 13:32:39 2009] [notice] Server built: Jul 22 2009 11:35:54
[Wed Sep 16 13:32:39 2009] [notice] Parent: Created child process 1764
[Wed Sep 16 13:32:40 2009] [notice] Digest: generating secret for digest authentication ...
[Wed Sep 16 13:32:40 2009] [notice] Digest: done
[Wed Sep 16 13:32:42 2009] [notice] Child 1764: Child process is running
[Wed Sep 16 13:32:42 2009] [notice] Child 1764: Acquired the start mutex.
[Wed Sep 16 13:32:42 2009] [notice] Child 1764: Starting 150 worker threads.
[Wed Sep 16 13:32:42 2009] [notice] Child 1764: Starting thread to listen on port 443.
[Wed Sep 16 13:32:42 2009] [notice] Child 1764: Starting thread to listen on port 80.
[Wed Sep 16 13:32:42 2009] [notice] Child 1764: Starting thread to listen on port 443.
[Wed Sep 16 13:32:42 2009] [notice] Child 1764: Starting thread to listen on port 80.


Any help would be gratefully appreciated.

Thanks,

Vicki
vicki_uk09
 
Posts: 2
Joined: 16. September 2009 13:42

Re: Can't start apache!

Postby Darecki » 16. September 2009 14:56

Have the same problem. Please help :(
Just installed the xampp and all went ok (according to messages).
But when trying to start Apache, nothing happens.
MySQL works.

System details: Intel Pentium Core2Duo, 4GB RAM, Vista x64
Darecki
 
Posts: 1
Joined: 16. September 2009 14:47

Re: Can't start apache!

Postby tramvajman » 16. September 2009 22:08

tramvajman
 
Posts: 2
Joined: 16. September 2009 02:49

Re: Can't start apache!

Postby vicki_uk09 » 17. September 2009 09:53

tramvajman wrote:Download and install Xampp 1.7.1 Final.
It's work!!!
link: http://sourceforge.net/projects/xampp/files/XAMPP%20Windows/1.7.1/xampp-win32-1.7.1-installer.exe/download


I tired uninstalling xampp 1.7.2 and try 1.7.1 final but its not fixed the problem :(

Vicki x
vicki_uk09
 
Posts: 2
Joined: 16. September 2009 13:42

Re: Can't start apache! - Solution

Postby Golgar_2000 » 02. October 2009 07:33

Hi, I Believe I Have A Solution.
I Have Always Manually Gone & Downloaded, Installed & Configured All The Separate Programs, Apache, PHP, etc. Never Had A Problem I Couldn't Fix Or Find A Solution For, Anyway, I Have Just Downloaded & Installed XAMPP 1.7.2 Also The Tomcat Add-on. Now Everything Was Fine First Run All Services Ran Fine.

Apache
MySql
FileZilla
Mercury &
Tomcat.

The Problem Started After I Restarted My Computer. No Apache? It Says It Started But Nothing, Hmmm Strange. All The Configuration Files Where Correct. So I Mucked Around For A While, Researched Everywhere & Even Tried To Install Apache Over The Apache Directory In XAMPP. Still Nothing. So I Started Again. Uninstall, Re-Install. Hey Apache Is Working Again. This Time No Restart. So I Just Clicked The Stop Apache Button, All Good. Ok Start Apache, NOTHING AGAIN. Sound Familiar?

Now Is Not The Time To Scream, It Has Already Told You The Problem. Apache. Very Simple, Go & Check Out The Error Log (Open With Notepad) The Log Files Are Located Here

" \xampp\apache\logs

Go To The Bottom Of The Log File & You Will See The Date, Time & Status. I Found That A File Was Missing Or Could Not Be Located. The Problem Was Related To Tomcat Which Stopped Apache From Starting.

"mod_jk.so" Was Missing From " \xampp\tomcat\Server\xampp\apache\modules\

So I Found A Copy Of "mod_jk.so" Located In " \xampp\apache\modules

So Very Simple. I Copied "mod_jk.so" From “ \xampp\apache\modules To “ \xampp\tomcat\Server\xampp\apache\modules\

Clicked The Start Apache Button & TADA Apache Is Working Again.

Now If A Different File Is Missing Try Searching Your Computer For It & If You Don’t Have It Download The ZIP File From Apache.org & You Should Find It In There.

In Conclusion If Apache Won't Start Or Won't Stay On Check You Log Files It Will Tell You The Problem. I Hope This Has Helped.
Golgar_2000
 
Posts: 10
Joined: 02. October 2009 06:18

Re: Can't start apache!

Postby Izzy » 02. October 2009 08:20

Golgar_2000 wrote:"mod_jk.so" Was Missing From " \xampp\tomcat\Server\xampp\apache\modules\
http://community.apachefriends.org/f/viewtopic.php?p=149962#p149962
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Can't start apache! (my solution)

Postby makro » 09. February 2010 09:58

I had the same issue of apache starting but stooping immediatly but in my error log there was no mention of a missing module.

Code: Select all
[Tue Feb 09 08:52:46 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Feb 09 08:52:46 2010] [notice] Server built: Nov 11 2009 14:29:03
[Tue Feb 09 08:52:46 2010] [crit] (22)Invalid argument: Parent: Failed to create the child process.
[Tue Feb 09 08:52:46 2010] [crit] master_main: create child process failed. Exiting.
[Tue Feb 09 08:52:46 2010] [notice] Parent: Forcing termination of child process 36


I finally got it to stay on by running the xampp setup tool again and choosing to disable mod_perl. (option 6).

Hope it helps someone else!
makro
 
Posts: 1
Joined: 09. February 2010 09:16

Re: Can't start apache!

Postby torvista » 04. April 2012 11:30

I finally got it to stay on by running the xampp setup tool again and choosing to disable mod_perl. (option 6).


Me too.
My installation had been working for over a year with no problems with Apache and Mysql as services autostarting. Then..it worked last thing at night and would not work in the morning until I disabled mod_perl.
torvista
 
Posts: 8
Joined: 27. July 2009 04:15

Re: Can't start apache!

Postby rmart1981 » 04. April 2012 14:07

Thanks!!!!
rmart1981
 
Posts: 1
Joined: 04. April 2012 13:58
Operating System: WINXP


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests