method POST does not function any more with version 1.7.2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

method POST does not function any more with version 1.7.2

Postby zygwi » 15. September 2009 08:20

I get some values with method POST.

My XAMPP last version was 1.6.5.

I try to install the 1.7.2, but it does not work any more.

What kind of problem should I have ?

XAMPP is installed on Window Server 2003.
zygwi
 
Posts: 30
Joined: 11. January 2005 16:16
Location: FRANCE

Re: method POST does not function any more with version 1.7.2

Postby Stepke-DSL » 15. September 2009 08:24

Can you post the code where you send the data and where you get the data?
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux

Re: method POST does not function any more with version 1.7.2

Postby zygwi » 15. September 2009 09:09

Here is a very simple example which does not function any more :

Form1.php :

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" >
<head>
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
<meta name="author" content="" />
<meta name="keywords" content="design, css, style, xhtml, w3c, geremi, prevoyance" />
<meta name="description" content="tools of research for " />
<meta name="robots" content="all" />

<title>Outils de recherche </title>

<script language="Javascript" type="text/javascript">
function bValid(frm) {
if ( frm.titi.value.length != 0 ) {
window.document.forms["toto"].submit();
}
}
</script>

</head>

<body id="pilote">

<form name="toto" method="POST" action="form1_post.php">

<div id="">
<table>
<tr><td>titi</td><td><input type="text" name="titi"></td></tr>
<tr><td colspan="2"><input type="button" value="Tester" onClick="bValid(this.form)" alt=""></td></tr>
</table>
</div>

</form>

</body>
</html>


form1_post.php :
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" >
<head>
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
<meta name="author" content="" />
<meta name="keywords" content="design, css, style, xhtml, w3c, geremi, prevoyance" />
<meta name="description" content="tools of research for " />
<meta name="robots" content="all" />

<title>Outils de recherche </title>


</head>

<body id="pilote">

<form name="toto">

<div id="">
<table>
<tr><td>titi</td><td><input type="text" name="titi" value="<?=$_POST['titi']?>" /></td></tr>
</table>
</div>

</form>

</body>
</html>
zygwi
 
Posts: 30
Joined: 11. January 2005 16:16
Location: FRANCE

Re: method POST does not function any more with version 1.7.2

Postby Stepke-DSL » 15. September 2009 09:13

Next time use the code-tags...

try this
Code: Select all
<form name="toto">

<div id="">
<table>
<tr><td>titi</td><td><input type="text" name="titi" value="<? echo $_POST['titi']; ?>" /></td></tr>
</table>
</div>

</form>


hope this helps
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux

Re: method POST does not function any more with version 1.7.2

Postby zygwi » 15. September 2009 09:23

Stepke-DSL wrote:Next time use the code-tags...


:? Sorry ...

Stepke-DSL wrote:try this
Code: Select all
<form name="toto">

<div id="">
<table>
<tr><td>titi</td><td><input type="text" name="titi" value="<? echo $_POST['titi']; ?>" /></td></tr>
</table>
</div>

</form>


hope this helps


Double effects !
the first time, that functions.
But after, the POST is empty. :?:
zygwi
 
Posts: 30
Joined: 11. January 2005 16:16
Location: FRANCE

Re: method POST does not function any more with version 1.7.2

Postby Stepke-DSL » 15. September 2009 10:09

you must specify the action and the method in form1_post.php.
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux

Re: method POST does not function any more with version 1.7.2

Postby zygwi » 15. September 2009 10:14

Stepke-DSL wrote:you must specify the action and the method in form1_post.php.


Code: Select all
<form name="toto" method="POST" action="form1_post.php">


No effect on form1_post.php source.
zygwi
 
Posts: 30
Joined: 11. January 2005 16:16
Location: FRANCE

Re: method POST does not function any more with version 1.7.2

Postby zygwi » 15. September 2009 10:27

for information :

The first time, it's OK, and after :
<br /><b>Notice</b>: Undefined index: titi in <b>D:\Siteweb\Informations\form1_post.php</b> on line <b>21</b><br />


The line 21 :
Code: Select all
<tr><td>titi</td><td><input type="text" name="titi" value="<?php echo $_POST['titi']; ?>" /></td></tr>
zygwi
 
Posts: 30
Joined: 11. January 2005 16:16
Location: FRANCE

Re: method POST does not function any more with version 1.7.2

Postby Altrea » 15. September 2009 12:14

zygwi wrote:The first time, it's OK[...]

What does that mean?

POST is only filled, if the form is executed.
your Form transfers all inputted data to your other site "form1_post.php". After transfering the data and rendering of that page, your POST-Data isn't stored anymore. If you want, that this POST value is setted, you must transfer another form (or the same form like before), or find another way to store your data longer than one page loading (e.g. store your data in a SESSION)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: method POST does not function any more with version 1.7.2

Postby Stepke-DSL » 15. September 2009 12:57

what is the output of
Code: Select all
print_r($_POST);
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux

Re: method POST does not function any more with version 1.7.2

Postby zygwi » 15. September 2009 13:02

Altrea wrote:
zygwi wrote:The first time, it's OK[...]

What does that mean?


At the first submit, the value is transmitted.
After, I do “preceding page” and re-submit and there is nothing. No Value transmitted.
zygwi
 
Posts: 30
Joined: 11. January 2005 16:16
Location: FRANCE

Re: method POST does not function any more with version 1.7.2

Postby zygwi » 15. September 2009 13:12

Stepke-DSL wrote:what is the output of
Code: Select all
print_r($_POST);


Array()
zygwi
 
Posts: 30
Joined: 11. January 2005 16:16
Location: FRANCE

Re: method POST does not function any more with version 1.7.2

Postby zygwi » 15. September 2009 13:25

I made other complementary tests.

I tested with Firefox 3.5.3, I do not have problems. Only IE 6 poses problems to me. But, i have no choice, I do used IE 6.

I tested with WAMPSERVER in the place of XAMPP, IE6 that functions.

I thus suppose that the problem comes from the file http.conf of XAMPP.
zygwi
 
Posts: 30
Joined: 11. January 2005 16:16
Location: FRANCE

Re: method POST does not function any more with version 1.7.2

Postby Stepke-DSL » 15. September 2009 13:28

so you do not send any data at the second post...
post the code for the second sending.
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux

Re: method POST does not function any more with version 1.7.2

Postby zygwi » 15. September 2009 15:53

I'll be come crazy !! :roll:

I suppose the problem come from IE6. With Firefox, no problem, with IE6, if I wait about 5 seconds before submit, it's ok, but if i submit immediatly after filling the form, i submit no value.

Is someone have the same problem ?
zygwi
 
Posts: 30
Joined: 11. January 2005 16:16
Location: FRANCE

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests