PHPADMIN not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHPADMIN not working

Postby msasupp1 » 14. September 2009 21:54

Hi,

I am new to web hosting and need help. I just downloaded and installed XAMPP 1.7.2 on Windows/XP Sp2. I see in the XAMPP control panel that mysql and apache are running (green light). When I click ADMIN next to APACHE, i get http://localhost/xampp/ in the browser address bar and 'page not found' error. Similary clicking 'admin' for mysql pastes http://localhost/phpmyadmin/ in the address bar and 'page not found' error. If I type address //localhost/ it display 'it works !' . I understand it is the display from C:\xampp\htdocs\index.html
I tried to run the following file: C:\xampp\htdocs\xampp\splash.php by typing in the address bar : http://localhost/xampp/splash.php but got error 'page not found'.
- What went wrong ?
I want to proceed to install Joomla.
msasupp1
 
Posts: 4
Joined: 14. September 2009 19:52

Re: PHPADMIN not working

Postby dmphotography » 15. September 2009 16:09

First, try going to http://127.0.0.1 and see if it works there. If so, do the following:

Go to C:/Windows/System32/drivers/etc/ and open up the file hosts with Notepad.
Verify you have an entry in it that looks like this:

Code: Select all
127.0.0.1       localhost


If not, add it and then save that file. This should fix your problem if that was the issue.

Otherwise, verify your web browser isn't running in Offline mode.
If the computer is connected to the internet, it shouldn't be running in this mode.
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
dmphotography
 
Posts: 191
Joined: 15. December 2008 14:25
Location: Columbus, MS
Operating System: Windows 7

Re: PHPADMIN not working

Postby msasupp1 » 15. September 2009 16:29

I found that document root is actually:
C:\Program Files\Apache Software Foundation\Apache2.2\htdocs

Since XAMPP installs APACHE in the above folder.

I tested it and //localhost/PHPINFO.PHP works but it flashes the info in a DOS PROMPT window and then closes it ! Not much use :) Is there another way to run PHPINFO.PHP to be able to display the results
msasupp1
 
Posts: 4
Joined: 14. September 2009 19:52

Re: PHPADMIN not working

Postby dmphotography » 15. September 2009 16:44

msasupp1 wrote:I found that document root is actually:
C:\Program Files\Apache Software Foundation\Apache2.2\htdocs

Since XAMPP installs APACHE in the above folder.

I tested it and //localhost/PHPINFO.PHP works but it flashes the info in a DOS PROMPT window and then closes it ! Not much use :) Is there another way to run PHPINFO.PHP to be able to display the results


No, your problem is that you've installed Apache previously and it's starting instead of XAMPP.

XAMPP does not install Apache in it's own folder apart from XAMPP. I recommend going to your control panel and uninstalling Apache, then XAMPP should work just fine.
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
dmphotography
 
Posts: 191
Joined: 15. December 2008 14:25
Location: Columbus, MS
Operating System: Windows 7

Re: PHPADMIN not working

Postby msasupp1 » 15. September 2009 16:51

In fact, I just finished doing that before reading your reply, and it works as expected :) You are so right !!
Thanks
msasupp1
 
Posts: 4
Joined: 14. September 2009 19:52


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests