Use location other than htdocs/xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Use location other than htdocs/xampp

Postby devuser » 13. September 2009 02:31

I have a fresh install of 1.7.1. It works fine but I need to change the path to something other than htdocs/xampp. I've gone through all the docs and threads that I can find and tried them all but none have worked for one reason or another. I've spent a full eight hours on this problem today with nothing to show for it so I'm hoping someone knows the answer. I can't believe there isn't a simple way to make such a change, seeing all the problems others have had with it.

Anyway, all of my installed files, which were previously setup for EasyPhp, are located in E:/Programing/EasyPHP1-8/www. I changed
Code: Select all
header("Location: splash.php");
in xampp/htdocs/xampp/index.php to
Code: Select all
header("Location: E:/Programing/EasyPHP1-8/www");
, restarted apache and went to http://localhost/. I was redirected to http://localhost/xampp/.

Then I changed
Code: Select all
<Directory "E:/Programing/xampp/htdocs/xampp">
in xampp/apache/conf/extra/httpd-xampp.conf to
Code: Select all
<Directory "E:/Programing/EasyPHP1-8/www">
, restarted apache and went to http://localhost/. I was redirected to http://localhost/xampp/.

I tried a number of other things - I can't remember them all at this point - but none worked. If anyone has even a suggestion as to what to try next, please do so.
devuser
 
Posts: 8
Joined: 13. July 2009 15:50

Re: Use location other than htdocs/xampp

Postby dmphotography » 13. September 2009 04:42

Change everything you've changed so far back to the default settings.
Open up xampp/apache/conf/httpd.conf and search for the following lines:

Code: Select all
DocumentRoot "C:/xampp/htdocs"
(or where ever you installed XAMPP)

and change it to

Code: Select all
DocumentRoot "E:/Programing/EasyPHP1-8/www"


Next in that same document, find

Code: Select all
<Directory "C:/xampp/htdocs">


and change it to

Code: Select all
<Directory "E:/Programing/EasyPHP1-8/www">


Save that file and close it out, then restart XAMPP.
It should work just fine for ya now.
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
dmphotography
 
Posts: 191
Joined: 15. December 2008 14:25
Location: Columbus, MS
Operating System: Windows 7

Re: Use location other than htdocs/xampp

Postby devuser » 14. September 2009 02:34

Thank you very much. That fixed it.
devuser
 
Posts: 8
Joined: 13. July 2009 15:50


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests