XAMPP and Windows 7 Pro

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: XAMPP and Windows 7 Pro

Postby JonB » 24. August 2010 15:29


That's a correct 'symptom solution', but is really unnecessary. If you un-install the previous standalone Apache and MySQL installations correctly, the un-install process will remove both the Windows Service Manager instances and those registry entries associated with the installations.

At that point you can simply check the 'svc' checkboxes in the XAMMP Control Panel, and the new (and correct) Service Instances will be created.

The only scenario where you would really need to change the path to executable, and do anything with the registry would be either:

A. The Standalone Apache and MySQL installations were manually deleted, leaving the registry entries and Service instances in place - so you must brute force clear them out.


B. You need to temporarily disable them to run XAMPP - and you wish to 'not break' the original installations.

REMEMBER - XAMPP is registry-agnostic. Other than thr XAMPP 'installer' itself, XAMPP makes no Windows registry entries. Everything is run through Command Line Interface calls embedded either in Batch Files (or scripts as penguin-heads would prefer) or calls made by the XAMPP Control Panel.

Good luck to all
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: XAMPP and Windows 7 Pro

Postby king1david » 07. August 2011 19:52

Thanks Buckmajor,
Back to work for me!
I uninstalled Skype (not a problem, don't use it anyway) and still had a problem with Apache flashing green, then turning off.
Note: This came up after I tried to install Artisteer (joomla! template builder), which would not run on my Windows 7 Ultimate.

I followed Buckmajor's instructions; change the IP Port that Apache listens on
default is port 80, standard for all web traffic
Change httpd.conf

port 8666 (could be anything above 1024):
PCs, look in C:\xampp\apache\conf\httpd.conf folder

Find the line that says:
Listen 80

#Listen [::]:80
Listen 80

changed it to
Listen 8666

#Listen [::]:80
Listen 8666

Then use http://localhost:8666/xampp/
(the port is designated by the colon and then the number).

run http://localhost:8666 to run Apache

Run Backend

and http://localhost:8616 to run my local IIS for .NET projects.

Posts: 1
Joined: 07. August 2011 19:33

Re: XAMPP and Windows 7 Pro

Postby TriStarGod » 25. September 2011 22:46

For me, the solution was to turn off World Wide Web Publishing in Services. Solved everything with a click of a button. No regedits necessary.
Posts: 1
Joined: 25. September 2011 22:43

Re: XAMPP and Windows 7 Pro

Postby Eranda Wakista » 17. October 2011 05:49

Hi all

I had the same problem when i was trying to install XAAMP on windows 7.The issue was the port 80.Just check whether you have configured IIS as your web server since IIs settings are included in windows 7.

If you have configured IIS in your PC it might use the port 80 for their default web site.Please follow the below steps.Ths really worked for me

1.Go to Computer management window from start menu(start-Right click on computer-select manage)
2.Click on services and applications from the menu
3.Select internet and information services.
4.Then you will find that the IIS server has created a default site and is using the port 80.
5.Remove the default site by right clicking on it
6.re-boot you pc or try nstalling xaamp again.
Eranda Wakista
Posts: 1
Joined: 17. October 2011 05:35
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: Nobbie and 73 guests