Cannnot Find Apache Under Services

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannnot Find Apache Under Services

Postby ryy705 » 02. September 2009 23:38

hello,

I am trying to connect to a remote MS SQL Server. But right now I get the followin error
Code: Select all
mssql_connect() [function.mssql-connect]: message: Login failed for user 'x'. (severity 14) in c:\xxx.php


According to what I read on http://us.php.net/function.mssql-connect
I have to do the following to connect to MS SQL because MS SQL wants the webserver username and password when connecting to a trusted server:
Code: Select all
-    Open Control Panels
-    Double click administrative tools
-    Double click services
-    Right click on Apache and choose properties
-    Under the "Log On" tab choose "This Account" and type in a valid domain user account & password
-    Restart the Apache service


But I cannot find "Apache" under services!! Is it called something else when installed with XAMP?
Many thanks in advance for your help
ryy705
 
Posts: 4
Joined: 02. September 2009 23:22

Re: Cannnot Find Apache Under Services

Postby Wiedmann » 03. September 2009 00:10

But I cannot find "Apache" under services!!

Because the Name is "Apache2.2". But if you have not installed the service, there can't be such service. (And there is no need to install the service.)

Code: Select all
mssql_connect() [function.mssql-connect]: message: Login failed for user 'x'. (severity 14) in c:\xxx.php

I guess you have not enabled mixed mode authentication in MS SQL?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Cannnot Find Apache Under Services

Postby ryy705 » 03. September 2009 14:36

Thank you for your prompt reply.

I do not have full reign over the database sever.
So, I will try to install apache as a service instead.
Should I just run:
Code: Select all
\xampp\apache\apache_installservice.bat

Do I have to uninstall Xamp first?
ryy705
 
Posts: 4
Joined: 02. September 2009 23:22

Re: Cannnot Find Apache Under Services

Postby Wiedmann » 03. September 2009 14:40

So, I will try to install apache as a service instead.

Don't think that make sense in your situation:
--> If Apache is not running as service, it's already using the privileges from your user account. (exactly what happens, if you change the service to log on with your user account)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Cannnot Find Apache Under Services

Postby ryy705 » 04. September 2009 03:35

I seem to have been a domain name issue. I was able to log in using server's IP instead.
ryy705
 
Posts: 4
Joined: 02. September 2009 23:22


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests