apache wont run!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache wont run!

Postby poco-pinguino » 31. August 2009 15:28

ok, be nice to me, i have no idea what im doing and thats a dangerous thing, believe me!

downloaded xampp, installed it ok, rebooted laptop, opened control panel on it, clicked start next to apache...and nothing.

it says busy, then 'apache service started'.

was advised to do a port check, when i do, it says 'openports.exe has stopped working' and sends me to download/update IE v8!!

~ I dont have skype
~ mysql isnt running
~ firewall allows xampp
~ i use vista

Help? :(

(pls assume youre talking your mothers thru this, cos thats about my level atm!)
poco-pinguino
 
Posts: 7
Joined: 31. August 2009 15:19

Re: apache wont run!

Postby Wiedmann » 31. August 2009 15:48

downloaded xampp

Which XAMPP?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache wont run!

Postby poco-pinguino » 31. August 2009 15:56

XAMPP 1.7.2 sorry
poco-pinguino
 
Posts: 7
Joined: 31. August 2009 15:19

Re: apache wont run!

Postby Wiedmann » 31. August 2009 16:05

There was/is another Apache installed on this pc, before you have installed XAMPP?

Because:
it says busy, then 'apache service started'.

The XAMPP 1.7.2 installer does not install a service.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache wont run!

Postby poco-pinguino » 31. August 2009 16:07

there was one downloaded, it didnt install properly, so i uninstalled what it had done and re-downloaded. what have i done wrong? :oops:
poco-pinguino
 
Posts: 7
Joined: 31. August 2009 15:19

Re: apache wont run!

Postby Wiedmann » 31. August 2009 16:11

what have i done wrong?

At some point you have installed Apache as Windows service. And this service is not working with your current installation.

- open a command prompt: Click on the "Shell" button.
- execute: sc delete Apache2.2
- close the shell
- close the Control Panel
- start the Control Panel
- try again
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache wont run!

Postby poco-pinguino » 31. August 2009 16:14

[SC] OpenService FAILED 5:

Access is denied.


this is what i get, is that normal?
poco-pinguino
 
Posts: 7
Joined: 31. August 2009 15:19

Re: apache wont run!

Postby Wiedmann » 31. August 2009 16:19

is that normal?

If you are not logged in as Administrator, yes.


That should also work:
Can you remove the checkmark at the checkbox "Svc"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache wont run!

Postby poco-pinguino » 31. August 2009 16:21

Can you remove the checkmark at the checkbox "Svc"?


wheres and whats that? sorry :oops:
poco-pinguino
 
Posts: 7
Joined: 31. August 2009 15:19

Re: apache wont run!

Postby Wiedmann » 31. August 2009 16:22

wheres that?

In the Control Panel.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache wont run!

Postby poco-pinguino » 31. August 2009 16:26

sorry but i have no idea what that is or where in the control panel
poco-pinguino
 
Posts: 7
Joined: 31. August 2009 15:19

Re: apache wont run!

Postby Wiedmann » 31. August 2009 16:31

have no idea what that is

poco-pinguino wrote:downloaded xampp, installed it ok, rebooted laptop, opened control panel on it, clicked start next to apache...and nothing.

How can you open the control panel, if you don't know what it is?

or where in the control panel

Open it and look in the Windows for a checkbox with the label "Svc"...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache wont run!

Postby poco-pinguino » 31. August 2009 16:35

ah sorry, misunderstood. control panel on xampp.

ok, check box unticked

sorry, what next? :oops:
poco-pinguino
 
Posts: 7
Joined: 31. August 2009 15:19

Re: apache wont run!

Postby mukeshsnp » 06. September 2009 03:31

today i installed xampp first time on my xp and i face same problem.
after reading solutions at board, i made changes and now its working fine.
1. i had skype, which was using port 80 as alternative incoming port. i changed that.
2. i uninstall IIS from Add Remove Program =>Windows Components

after that at Xampp control panel, i unchecked Svc Apache and click ok to remove Apache Service.
after that at Xampp control panel, i checked Svc Apache and click ok to install Apache Service.
then i clicked start button and it started fine..

hope this is useful.
mukeshsnp
 
Posts: 1
Joined: 06. September 2009 03:23


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests