Problem installing XAMPP on Windows XP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem installing XAMPP on Windows XP

Postby timjh » 30. August 2009 07:10

Hello,

This is my first-ever Web-server installation, and it was not successful. I downloaded and installed the XAMPP 1.7.2 code onto my Windows XP machine, which seemed to go fine. However, I am unable to start either Apache or MySql from either the XAMPP Control Panel or the command line. I checked the Apache error log, and got this:

    (OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: unable to listen for connections on address 0.0.0.0:80
    no listening sockets available, shutting down

Again, I'm a newbie, but I'm wondering whether the problem has to do with the address shown in the error message -- my understanding was that it should be 127.0.0.1.

I would greatly appreciate any help!

Timjh
timjh
 
Posts: 3
Joined: 30. August 2009 06:59

Re: Problem installing XAMPP on Windows XP

Postby Izzy » 30. August 2009 07:35

Are you using Skype?

If so here is how to fix Skype so you can have both Skype and Apache running at the same time:
Skype uses ports 80 and 443 by default.

You can alter that behavior by going to:
Tools\Options\Connection

Untick
Use port 80 and 443 as alternative for incoming connections

You will have to decide a different port to use for incoming connections before Skype lets you save your changes.

Use ports between 49152 through 65535.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem installing XAMPP on Windows XP

Postby timjh » 31. August 2009 01:43

Hi Izzy,

No, I'm not using Skype.

Tim
timjh
 
Posts: 3
Joined: 30. August 2009 06:59

Re: Problem installing XAMPP on Windows XP

Postby Izzy » 31. August 2009 05:05

Do you have IIS running?
(Microsoft's Internet Information Server) - usually inetsvr.exe)

Run xampp-portcheck.exe in the xampp folder and see what is using the ports 80 and 443 then paste back the results.

Make sure that your firewall/zonealarm etc. is not interfering - temporarily disable and try again.

You are logged into XP as an administrator not an ordinary user?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem installing XAMPP on Windows XP

Postby timjh » 01. September 2009 04:29

Thanks for the ideas -- here are the results:


Do you have IIS running?
(Microsoft's Internet Information Server) - usually inetsvr.exe)

I checked, and IIS is not running.

Run xampp-portcheck.exe in the xampp folder and see what is using the ports 80 and 443 then paste back the results.


XAMPP PortCheck v1.4 by (c) 2009 Carsten Wiedmann (FreeBSD License)
Send bug reports to the author at <carsten_sttgt@gmx.de>,
or go to the XAMPP homepage at http://www.apachefriends.org/.

This script uses openport.exe:
Copyright (C) 2005 Diamond Computer Systems Pty. Ltd.
Official website: http://www.diamondcs.com.au/

Please wait a moment...


RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 free
Apache (WebDAV) 81 free
Apache (HTTPS) 443 free

MySQL 3306 free

FileZilla (FTP) 21 free
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 free
Mercury (POP3) 110 free
Mercury (IMAP) 143 free
Mercury (HTTP) 2224 free
Mercury (Finger) 79 free
Mercury (PH) 105 free
Mercury (PopPass) 106 free

Tomcat (AJP/1.3) 8009 free
Tomcat (HTTP) 8080 free

Press <Return> to continue.


Make sure that your firewall/zonealarm etc. is not interfering - temporarily disable and try again.

I disabled the firewall and attempted to start Apache, to no avail.

You are logged into XP as an administrator not an ordinary user?

Yes
timjh
 
Posts: 3
Joined: 30. August 2009 06:59


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests