Problem running php after moving files to server

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem running php after moving files to server

Postby OrcaSoul » 27. August 2009 07:02

I just made a small image gallery inside my XAMPP local server - and it works just fine.

I then uploaded the folder to my Godaddy based server...when I tried to run it I get the header - but no footer or body with the images...

I built this using the PHP Easy Downloader V2.0 template from http://www.ironclad.net/scripts/.

The gallery is at http://www.orcasoul.com/ANT/

Any hints?
OrcaSoul
 
Posts: 57
Joined: 24. August 2009 23:51

Re: Problem running php after moving files to server

Postby Izzy » 27. August 2009 07:32

Try adding this line as the first line of a .htaccess file and upload to the web root (where your site index.php file lives) of your server - or add it as the first line to an existing .htaccess file:
Code: Select all
AddHandler x-httpd-php5 .php
Please let me know back if that helps or not.

I believe that GD uses php 4 for the free servers and you have to tell it to use php 5 for your scripts and may be that is why it works in your Apache in XAMPP with php 5 but not in Apache of GD with php 4.

BTW GD have a support facility for their servers and maybe it would be worth contacting them if the above does not fix your problem.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem running php after moving files to server

Postby OrcaSoul » 27. August 2009 08:25

Thanks for the tip - I created an .htaccess file & added the code into it, and then uploaded it.

It didn't seem to work...just took a long time to load...

I'll contact GD in the morning, see what they have to say.

Thanks.
OrcaSoul
 
Posts: 57
Joined: 24. August 2009 23:51

Re: Problem running php after moving files to server

Postby OrcaSoul » 28. August 2009 00:05

An update - I contacted Godaddy, and they responded that the account was not configured for PHP...but it was just a matter of upgrading it to run the script. I followed the instructions, and now need to wait 24 hours for it to take effect.
OrcaSoul
 
Posts: 57
Joined: 24. August 2009 23:51

Re: Problem running php after moving files to server

Postby Izzy » 28. August 2009 00:12

Thanks for the update - it had to be something at GD blocking the pipes. :)

All is well that ends well, and BTW often GD do things quicker than they tell you.

Good luck.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem running php after moving files to server

Postby dmphotography » 29. August 2009 12:01

@IZZY;
Godaddy has amazing customer service! I don't like all the "try to get you to accidentally buy something you don't need" crap you have to deal with when purchasing something, but the fact you can pick the phone up and get instant support from someone who knows what they're doing is priceless.
It's been the best hosting experience I've had.

@OrcaSoul;
I see you got your gallery working, but you have a permissions issue that flashes when you click on an image to enlarge it. I managed to catch it and it looks as simple to fix as changing the directory permissions to 777.

Code: Select all
Warning: fopen(file_info/descriptions/IMG_1577.JPG.dsf)[function_fopen]: failed to open stream: Permission denied in D:\Hosting\2436763\html\ANT\index.php on line 1211


It also gives a warning about fwrite(), which is due to the fopen()failure.

This should be easy to fix, although it is odd to have a read/write problem on a Windows server. I'd contact Godaddy if you can't get it fixed and have them do it for you since it's on a Windows server.
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
dmphotography
 
Posts: 191
Joined: 15. December 2008 14:25
Location: Columbus, MS
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests