php 5.2.10 php.ini for xamp 1.7.2?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

php 5.2.10 php.ini for xamp 1.7.2?

Postby Stellar » 25. August 2009 21:08

anyone can share php.ini for php 5.2.10?xamp 1.7.2,i need to run php 5.2 since on php 5.3 there is deprecated error..
Stellar
 
Posts: 4
Joined: 25. August 2009 21:02

Re: php 5.2.10 php.ini for xamp 1.7.2?

Postby Izzy » 27. August 2009 02:47

Why not install the XAMPP version that includes the php version you require then when all the script authors have finally caught up then simply install the lasted XAMPP version again?

Upgrading PHP has always had deprecated code issues from way back and it looks like it will continue into the foreseeable future.

Back versions of XAMPP can be obtained from the SourceForge Windows Archive

You can also download the appropriate version in a zip format and extract the files you require.

Alternatively contact the script's author and see if there is an upgrade to fix the deprecated code error message issue or are at least are contemplating a script update (or is there even an entry in the scripts configuration that will allow you to eliminate php error messages?) - XAMPP has, in the php.ini file, disabled this error message in 1.7.2 error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED.

I am not sure if it would be a good idea to simply use an older version php.ini on the latest version of php - others may be able to help with this observation.


This Advanced Forum Search has some useful comment from one of XAMPP For Windows developers.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: php 5.2.10 php.ini for xamp 1.7.2?

Postby Stellar » 27. August 2009 10:46

because on 1.7.2 the apache version newer than 1.7.1a,you cannt just blindly run vulnerable old apache server on live server,
already disabled the error_reporting,the error still persist,i just asking user who might have php 5.2.10 ini for xamp 1.7.2 or else i will build apache and php from sratch lol
Stellar
 
Posts: 4
Joined: 25. August 2009 21:02

Re: php 5.2.10 php.ini for xamp 1.7.2?

Postby dmphotography » 29. August 2009 12:23

Stellar wrote:because on 1.7.2 the apache version newer than 1.7.1a,you cannt just blindly run vulnerable old apache server on live server,
already disabled the error_reporting,the error still persist,i just asking user who might have php 5.2.10 ini for xamp 1.7.2 or else i will build apache and php from sratch lol


Download XAMPP 1.7.1, which contains Apache 2.2.11(I think) and PHP 5.2.8. It is a secure and stable release. XAMPP isn't intended on being used as a live server platform, so therefore I hope you have thoroughly researched possible vulnerabilities and fixed them. Otherwise, it won't matter what version of Apache you're running, a hacker will have a hayday on your server.

What you're talking about doing by reverting and crossing a version of PHP XAMPP wasn't designed for poses a greater security risk than using an older setup, especially if you don't know what your doing. (Which if you did, you'd know better than to attempt doing what you're talking about doing.)
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
dmphotography
 
Posts: 191
Joined: 15. December 2008 14:25
Location: Columbus, MS
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests