xampp start up problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp start up problem

Postby soccertainer » 25. August 2009 20:51

I can't get apache to start in the xampp control panel but it had been working fine. I'm getting advised when I try to start the service to check the system event log which gives me the error "The Apache service named

reported the following error: >>>
The specified IP address is invalid.
"
Can anyone advise what I should do here please? Any help would be greatly appreciated.
soccertainer
 
Posts: 7
Joined: 11. August 2009 14:44

Re: xampp start up problem

Postby Stellar » 25. August 2009 21:06

check your httpd.conf this line

Code: Select all
Listen 80


delete if there is ip behind like Listen 127.0.0.1:80 change into above just the port number
Stellar
 
Posts: 4
Joined: 25. August 2009 21:02

Re: xampp start up problem

Postby soccertainer » 25. August 2009 22:00

thanks for the assist, but there was no IP in there, still having the same issue :(
soccertainer
 
Posts: 7
Joined: 11. August 2009 14:44

Re: xampp start up problem

Postby Stellar » 26. August 2009 00:07

so the error comes when you tried run the apache?or when you accessed the pages?if when accessing the pages,try to check your .htaacess,if not go to C:\xampp\apache\logs , delete all files inside,try to rerun the apache and post here the error.log.
Stellar
 
Posts: 4
Joined: 25. August 2009 21:02

Re: xampp start up problem

Postby Izzy » 27. August 2009 02:50

soccertainer wrote:I can't get apache to start...
Have you tried starting Apache using the C:\xampp\apache_start.bat file as usually it will return a more helpful error message why it can't start?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp start up problem

Postby Welsh » 02. September 2009 01:46

Same issue and i get this at startup from the apache_start.bat
Code: Select all
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted.  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
Welsh
 
Posts: 1
Joined: 02. September 2009 01:44

Re: xampp start up problem

Postby Izzy » 02. September 2009 03:43

You may have another server using port 80 like Skype or IIS which you need to re-configure them to use another port.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests