no ip conection

Problems with the Windows version of XAMPP, questions, comments, and anything related.

no ip conection

Postby sneeky » 21. December 2003 17:13

ok i have xampp up and running whithout perl.

i started apache and mysql.
i can open http://localhost/ or http://127.0.0.1

but when i try to open the webpage whit my ip i cant get it working.

http://213.93.164.6/

my network goes like this Modem --> router - --> My webserver and my computer

the router has no firewall also the webser dont have iit yet. my computer has a firewall (norton internet securety) but i dont think that effect my webserver. i have running windows 2003 on my webserver. and dissabled the standart webserver there.

so can anny one tell me what is going on?
sneeky
 
Posts: 3
Joined: 21. December 2003 17:06

Postby Kristian Marcroft » 21. December 2003 18:12

Hi,

it is NOT possible to access your Webserver from behind your Router with your public IP Address.

Your Router will not forward the request.
The Router will only forward incoming requests.
But since you are already in the LAN you don't have an incoming request...
Since you never leave your LAN (because your Router realizes that he has already found the IP)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby sneeky » 21. December 2003 18:57

so what do you mean whit this?

that i can not connect to my own public ip but other can do?

so you see my webpage?
sneeky
 
Posts: 3
Joined: 21. December 2003 17:06

Postby Kristian Marcroft » 21. December 2003 19:07

Hi,

not quite....
You still have to forward the Port 80 to your server, and deaktivate the Firewall in the Router....

When I scan your IP I get the following answer:

Port State Service
53/tcp open domain
80/tcp filtered http
135/tcp filtered loc-srv
137/tcp filtered netbios-ns
138/tcp filtered netbios-dgm
139/tcp filtered netbios-ssn
445/tcp filtered microsoft-ds

1. you should close the Ports 135 - 139
2. forward 80 443 21 and 20

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby sneeky » 21. December 2003 19:40

thanks it works now :-)
sneeky
 
Posts: 3
Joined: 21. December 2003 17:06

Postby amayain » 14. January 2004 05:36

Hey, i am having the same problem....
I can view my page from localhost, however i cannot view it (nor can anyone else who isn't on my router view it) using my IP. I have the 80, 443, 21, and 20 ports properly forwarded and i have no firewall.
Any ideas?
Thanks
amayain
 
Posts: 1
Joined: 14. January 2004 05:33

Postby Golyc » 16. August 2004 02:34

my adsl (awful) service block 80 and the most important port the e-mail port only is not blocked ... it sux !!!
Golyc
 
Posts: 25
Joined: 11. August 2004 01:48


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 69 guests