Unable to install Drupal 6.13 on Vista with Xampp 1.7.2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unable to install Drupal 6.13 on Vista with Xampp 1.7.2

Postby jonnyxu » 22. August 2009 20:00

Hi.

I'm trying to install Drupal 6.13 on a Windows Vista system with Xampp 1.7.2 (basic package), but get the following error:

Code: Select all
Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.
Error 500
127.0.0.1
22.08.2009 19:07:47
Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0


I think it has to be Xampp-related because I've sucessfully installed Drupal with a manual installation of Apache HTTP Server 2.2.13, MySQL 5.1.37 and PHP 5.3.0 by
following these three guides:
* How to Install Apache 2.2 on Windows Vista
* How to Install and Configure PHP 5 to Run with Apache on Windows (not CGI binary)
* How to Install MySQL on Windows Vista and Configure PHP 5 to Use It

While I certainly could use this manual install, I prefer to use the Xampp package because it makes it easier when updating to the latest software.

I have also successfully installed Drupal 6.13 on a Vista system with Xampp 1.7.1 (basic package), but as said I can't get it to work with Xampp 1.7.2 (basic package)

Any idea why, or what I might do wrong?
Last edited by jonnyxu on 22. August 2009 20:03, edited 1 time in total.
jonnyxu
 
Posts: 5
Joined: 22. August 2009 19:47

Re: Unable to install Drupal 6.13 on Vista with Xampp 1.7.2

Postby Wiedmann » 22. August 2009 20:02

Any idea why, or what I might do wrong?

No, I can't read the error.log on your pc...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Unable to install Drupal 6.13 on Vista with Xampp 1.7.2

Postby jonnyxu » 22. August 2009 20:06

Edit: I'm sorry, this log was from Xampp 1.7.1. I will post the correct log in a moment, I just have to reinstall 1.7.2
jonnyxu
 
Posts: 5
Joined: 22. August 2009 19:47

Re: Unable to install Drupal 6.13 on Vista with Xampp 1.7.2

Postby jonnyxu » 22. August 2009 20:28

Here's the C:\xampp\apache\logs\error.log

Code: Select all
[Sat Aug 22 21:25:46 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 22 21:25:46 2009] [notice] Digest: done
[Sat Aug 22 21:25:49 2009] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Sat Aug 22 21:25:49 2009] [notice] Server built: Jul 22 2009 11:35:54
[Sat Aug 22 21:25:49 2009] [notice] Parent: Created child process 5096
[Sat Aug 22 21:25:51 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 22 21:25:51 2009] [notice] Digest: done
[Sat Aug 22 21:25:53 2009] [notice] Child 5096: Child process is running
[Sat Aug 22 21:25:53 2009] [notice] Child 5096: Acquired the start mutex.
[Sat Aug 22 21:25:53 2009] [notice] Child 5096: Starting 150 worker threads.
[Sat Aug 22 21:25:53 2009] [notice] Child 5096: Starting thread to listen on port 443.
[Sat Aug 22 21:25:53 2009] [notice] Child 5096: Starting thread to listen on port 443.
[Sat Aug 22 21:25:53 2009] [notice] Child 5096: Starting thread to listen on port 80.
[Sat Aug 22 21:25:53 2009] [notice] Child 5096: Starting thread to listen on port 80.
[Sat Aug 22 21:26:03 2009] [alert] [client 127.0.0.1] C:/xampp/htdocs/xampp/drupal-6.13/.htaccess: order not allowed here
jonnyxu
 
Posts: 5
Joined: 22. August 2009 19:47

Re: Unable to install Drupal 6.13 on Vista with Xampp 1.7.2

Postby jonnyxu » 22. August 2009 20:54

Never mind, I managed to fix it.

I opened C:\xampp\apache\conf\httpd.conf and added the following to the bottom:

Code: Select all
<directory "C:\xampp\htdocs\xampp">
AllowOverride FileInfo Limit Options Indexes
</directory>


It seems to have fixed the error 500. :)
jonnyxu
 
Posts: 5
Joined: 22. August 2009 19:47

Re: Unable to install Drupal 6.13 on Vista with Xampp 1.7.2

Postby Wiedmann » 22. August 2009 21:10

Never mind, I managed to fix it.

Yes and no. The directory "\xampp\htdocs\xampp" is for the XAMPP demopage.

If you want install something, install it into the DocumentRoot, which is "\xampp\htdocs", or create a new subdirectory in your DocumentRoot.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Unable to install Drupal 6.13 on Vista with Xampp 1.7.2

Postby jonnyxu » 22. August 2009 21:15

I see. That makes sense. Thank you! :)
jonnyxu
 
Posts: 5
Joined: 22. August 2009 19:47


Return to XAMPP for Windows

Who is online

Users browsing this forum: Gharas and 62 guests