http://localhost/ - not working - after starting xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

http://localhost/ - not working - after starting xampp

Postby zharuth » 20. August 2009 14:20

Hello there,

OS: Windows XP Professional, SP 2.

Few days back i had xampplite 1.7.1, and was able to access http://localhost/ and phpmyadmin...... Today it suddenly stopped working :evil:

In firefox after i type http://localhost/ nothing happens, just blank white screen.

I removed all the files in xampplite folders and re-installed ver 1.7.1 again, it's of no use. Then i installed xampplite 1.7.2 (latest), which i had downloaded from xampp website, again it's of no use. Apache and MySql are running.

I tried using locally installing wordpress, as i have a theme ready and want to convert that design to wordpress, test it and start using online.

Running 'Port-check' on xampp control panel showed this -->

RESULT
------

Service Port Status
=============================================================
Apache (HTTP) 80 C:\xampplite\apache\bin\httpd.exe
Apache (WebDAV) 81 free
Apache (HTTPS) 443 C:\xampplite\apache\bin\httpd.exe

MySQL 3306 C:\xampplite\mysql\bin\mysqld.exe

FileZilla (FTP) 21 free
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 free
Mercury (POP3) 110 free
Mercury (IMAP) 143 free
Mercury (HTTP) 2224 free
Mercury (Finger) 79 free
Mercury (PH) 105 free
Mercury (PopPass) 106 free

Tomcat (AJP/1.3) 8009 free
Tomcat (HTTP) 8080 free

---------------------------------------------

I also Have skype installed but it's not using 'Port 80'.


When i run file:///C:/xampp/htdocs/index.php - it shows "Something is wrong with the XAMPP installation :-( "


Please help with this problem.

thanks
Sharath kumar
Last edited by zharuth on 22. August 2009 21:42, edited 1 time in total.
--
regards
Dave
zharuth
 
Posts: 6
Joined: 20. August 2009 13:59
Location: Australia

Re: http://localhost/ - not working - after starting xampp

Postby zharuth » 20. August 2009 17:17

Will anyone please, please help me solve this issue???????????????
--
regards
Dave
zharuth
 
Posts: 6
Joined: 20. August 2009 13:59
Location: Australia

Re: http://localhost/ - not working - after starting xampp

Postby xfsgpr » 20. August 2009 22:04

I followed the instructions given by ADOBE for dreamweaver but you can have a look at install sections here:

http://www.adobe.com/devnet/dreamweaver/articles/setting_up_php_02.html

Let me know if it helped. If you want version 1.6.8 Win32 then you need to search on Sourceforge website.

hth
xfsgpr
 
Posts: 27
Joined: 20. August 2009 21:45

Re: http://localhost/ - not working - after starting xampp

Postby Izzy » 20. August 2009 22:12

Do you get the XAMPP Welcome Page if you type http://127.0.0.1 in your browser?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: http://localhost/ - not working - after starting xampp

Postby zharuth » 20. August 2009 22:28

xfsgpr wrote:I followed the instructions given by ADOBE for dreamweaver but you can have a look at install sections here:

http://www.adobe.com/devnet/dreamweaver/articles/setting_up_php_02.html

Let me know if it helped. If you want version 1.6.8 Win32 then you need to search on Sourceforge website.

hth


Thanks for the reply....I have already followed the installation section before posting the problem here. Xampp was installed properly and also Apache and MySql are running in Xampp control-panel.......Just when i enter

http://localhost/
http://localhost/xampp/index.php

Blank screen and No error messages, it just shows the loading icon, but never loads anything. :(
--
regards
Dave
zharuth
 
Posts: 6
Joined: 20. August 2009 13:59
Location: Australia

Re: http://localhost/ - not working - after starting xampp

Postby zharuth » 20. August 2009 22:30

Izzy wrote:Do you get the XAMPP Welcome Page if you type http://127.0.0.1 in your browser?



Nope,.... Blank screen and No error messages, it just shows the loading icon, but never loads anything.
--
regards
Dave
zharuth
 
Posts: 6
Joined: 20. August 2009 13:59
Location: Australia

Re: http://localhost/ - not working - after starting xampp

Postby Izzy » 21. August 2009 00:17

Try these few things so we can eliminate them from the equation:

Stop any running XAMPP components, reboot XP and then try again to access localhost after again starting and making sure that Apache and MySQL are showing the green running indicator in the XAMPP Control Panel.

If you have another browser IE or Opera for example then try to access http://localhost using a different browser - Firefox has been reported recently in these forums to show this problem in XP but not on every Firefox\XAMPP installation.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: http://localhost/ - not working - after starting xampp

Postby zharuth » 21. August 2009 08:51

Izzy wrote:Try these few things so we can eliminate them from the equation:

Stop any running XAMPP components, reboot XP and then try again to access localhost after again starting and making sure that Apache and MySQL are showing the green running indicator in the XAMPP Control Panel.

If you have another browser IE or Opera for example then try to access http://localhost using a different browser - Firefox has been reported recently in these forums to show this problem in XP but not on every Firefox\XAMPP installation.



Tried 1st step yesterday for several times, nothing happened, even though Apache and MySQL are showing the green running indicator in the XAMPP Control Panel.

2nd step, i tried in Opera, IE, Google Chrome, again nothing happened...........Though this time i installed complete Xampp package (not Lite package), it's still the same. :(
--
regards
Dave
zharuth
 
Posts: 6
Joined: 20. August 2009 13:59
Location: Australia

Re: http://localhost/ - not working - after starting xampp

Postby flameproof » 12. February 2010 06:01

I got the same problem suddenly. Maybe it's related to a virus attack, or virus scan. My findings (Win Xp):

Firefox 3.6
http://localhost/ >> white page
http://127.0.0.1/ >> white page
http://192.168.1.103/ >> forwards to: http://192.168.1.103/xampp/ >> OK

https://localhost/xampp/ >> forwards to: https://localhost/xampp/ >> OK
https://127.0.0.1/ >> forwards to: https://127.0.0.1/xampp/ >> OK

Chrome
All above work fine

At these point I lack ideas what it could be.
flameproof
 
Posts: 7
Joined: 12. February 2010 05:51

Re: http://localhost/ - not working - after starting xampp

Postby gollyg » 21. February 2010 11:29

A white screen normally indicates a php error. Check your php error log. If there is a problem with the server you will normally get some kind of output from the browsers built in error message.
gollyg
 
Posts: 1
Joined: 21. February 2010 11:26

Re: http://localhost/ - not working - after starting xampp

Postby MC10 » 21. February 2010 19:57

Could you install the Firebug extension on Firefox? It'll help out with errors.
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: http://localhost/ - not working - after starting xampp

Postby roryley » 27. February 2010 01:47

I would like to thank flameproof for the solution to blank white screen with no source code in firefox while using xampp. Its the only one that worked for me. In short use https://127.0.0.1/ this will forward you to a page that will ask you to add a security exception, follow the prompts and eventually you will see in the address bar "127.0.0.1" in blue then "https://127.0.0.1/xampp/splash.php". You may now surf to any localhost address you like so long as 127.0.0.1 in blue remains at the front of the address and "https://" is used opposed to just "http://".

Firefox 3.6 | winxp sp3 | xampp 7.2.3
roryley
 
Posts: 1
Joined: 27. February 2010 01:11

Re: http://localhost/ - not working - after starting xampp

Postby flameproof » 10. March 2010 08:11

roryley wrote:I would like to thank flameproof for the solution to blank white screen with no source code in firefox while using xampp. Its the only one that worked for me. In short use https://127.0.0.1/ this will forward you to a page that will ask you to add a security exception, follow the prompts and eventually you will see in the address bar "127.0.0.1" in blue then "https://127.0.0.1/xampp/splash.php". You may now surf to any localhost address you like so long as 127.0.0.1 in blue remains at the front of the address and "https://" is used opposed to just "http://".

Firefox 3.6 | winxp sp3 | xampp 7.2.3


Yes, https://localhost/ works fine - but why? Or more important, what does http://localhost/ gives me a white screen?

I don't think the error is PHP related. *.html pages show also up as a blank page. Even a non existing page will result in a white screen.
flameproof
 
Posts: 7
Joined: 12. February 2010 05:51

Re: http://localhost/ - not working - after starting xampp

Postby RiverLee » 31. March 2010 05:17

Slightly different but similar problem.

When I point my browser at http://localhost:8080 I am redirected to the splash.php file but nothing loads. Nothing loads when directing my browser to the index.html file either.

I have tried https://localhost:8080 and receive this response:

Data Transfer Interrupted

The connection to localhost:8080 was interrupted while the page was loading.


Could someone please help me with this?

I should also point out that this is all within Firefox, the only other browser I have is IE and nothing shows up there when directing my browser at http://localhost:8080, the https://localhost:8080 is continually connecting.
RiverLee
 
Posts: 1
Joined: 31. March 2010 05:10

Re: http://localhost/ - not working - after starting xampp

Postby eldalye » 08. November 2010 15:50

I had the same problem. I use xampp on a virtual machine running xp, and the host machine is within a proxy server.
I had to specify "don't use proxy settings for local addresses" under Internet Options/Connections.

Then all worked fine for me.
eldalye
 
Posts: 1
Joined: 08. November 2010 15:45


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests