Unable to connect to localhost or apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unable to connect to localhost or apache

Postby Russell1984 » 18. August 2009 15:01

I've just downloaded xampp in order to learn how to create Wordpress themes. It's been a very steep learning curve this morning but eventually I got there. I was reading the literature, in particular the information relating to security following this heading: "A matter of security (A MUST READ!)" at the following link:

http://www.apachefriends.org/en/xampp-windows.html#1157

I took its advice and familiarised myself with all the links on my localhost. Earlier I had unblocked port 80 by removing Skype and this allowed me to free up port 80 and connect to the apache server. Later, however, I later clicked on the link for http://localhost/ within this area - I do remember reading something relating passwords / privelges but I can't remember if this was here or within the mySQL area.- or phpmyadmin.

Anyway, since then I have retried to connect to my localhost and am unable to connect either via a web link or the admin button on the xammp control panel. I know this is some kind of security / network issue but have no idea but was is causing it or how to solve it. I'd be very grateful if anyone can shed any light on this because at present I am unable to activate my apache server and use the web development evironment. I hope this makes sense because I'm using langauge that I don't yet fully understand myself!

Any suggestions would be gratefully received.

Thanks to all in advance.

Rusell
Russell1984
 
Posts: 6
Joined: 18. August 2009 14:44

Re: Unable to connect to localhost or apache

Postby Wiedmann » 18. August 2009 15:11

am unable to connect either via a web link or the admin button on the xammp control panel.
...
I am unable to activate my apache server and use the web development evironment.

You can't:
- connect to the running server?
- or can't start the server?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Unable to connect to localhost or apache

Postby Russell1984 » 18. August 2009 15:39

Sorry. I can't get access to my own computer which is acting as a 'local server' having converted into one following the directions outlined here: http://themeshaper.com/wordpress-theme- ... -tutorial/

Thanks
Russell1984
 
Posts: 6
Joined: 18. August 2009 14:44

Re: Unable to connect to localhost or apache

Postby Wiedmann » 18. August 2009 16:08

I can't get access to my own computer which is acting as a 'local server'

So you can start Apache (a green "running" in the CP), but you can't access it with "http://localhost/"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Unable to connect to localhost or apache

Postby Russell1984 » 18. August 2009 16:17

Thank you. I feel like I'm getting somewhere.

Apache will not start or run via the xampp control panel. The green light winks then goes out immediately.

mysQL will run, however, via this control panel but will not let me access admin. When I click on admin, and am directed to the following link: http://localhost/phpmyadmin/ - it returns a blank white page featuring no source code.
Russell1984
 
Posts: 6
Joined: 18. August 2009 14:44

Re: Unable to connect to localhost or apache

Postby Russell1984 » 18. August 2009 16:20

It also will not run via the link: http://localhost/ or http://127.0.0.1/ - these pages are all white and blank with no source code. I'm using Firefox v 3.5.2.
Russell1984
 
Posts: 6
Joined: 18. August 2009 14:44

Re: Unable to connect to localhost or apache

Postby Wiedmann » 18. August 2009 16:24

Apache will not start or run via the xampp control panel. The green light winks then goes out immediately.

What can you read in the Apache "error.log"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Unable to connect to localhost or apache

Postby Russell1984 » 19. August 2009 09:40

Hi Wiedmann


I hope this is the material your asking for. I don't understand a word of it. I just hope you can. Its come from the error document within the logs folder which was within the Apache folder. Here's it all. Thank you.

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[Tue Aug 18 11:26:31 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 18 11:26:31 2009] [notice] Digest: done
[Tue Aug 18 11:26:45 2009] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Tue Aug 18 11:26:45 2009] [notice] Server built: Jul 22 2009 11:35:54
[Tue Aug 18 11:26:45 2009] [notice] Parent: Created child process 5632
[Tue Aug 18 11:26:47 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 18 11:26:47 2009] [notice] Digest: done
[Tue Aug 18 11:26:48 2009] [notice] Child 5632: Child process is running
[Tue Aug 18 11:26:48 2009] [notice] Child 5632: Acquired the start mutex.
[Tue Aug 18 11:26:48 2009] [notice] Child 5632: Starting 150 worker threads.
[Tue Aug 18 11:26:48 2009] [notice] Child 5632: Starting thread to listen on port 443.
[Tue Aug 18 11:26:48 2009] [notice] Child 5632: Starting thread to listen on port 80.
[Tue Aug 18 11:28:41 2009] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
C:\Documents is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
and is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Settings\Mr is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Hogan\My is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Documents\XAMPP\xampp\perl\site\lib is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
[Tue Aug 18 11:45:54 2009] [error] APR does not understand this error code at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Base.pm line 106.\n
[Tue Aug 18 11:45:54 2009] [error] [client 127.0.0.1] Handler for type-map returned invalid result code 620018, referer: http://localhost/xampp/navi.php
C:\Documents is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
and is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Settings\Mr is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Hogan\My is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Documents\XAMPP\xampp\perl\site\lib is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
C:\Documents is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
and is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Settings\Mr is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Hogan\My is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Documents\XAMPP\xampp\perl\site\lib is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
[Tue Aug 18 11:46:04 2009] [error] APR does not understand this error code at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Base.pm line 106.\n
[Tue Aug 18 11:46:04 2009] [error] [client 127.0.0.1] Handler for type-map returned invalid result code 620018, referer: http://localhost/xampp/perlinfo.pl
C:\Documents is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
and is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Settings\Mr is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Hogan\My is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Documents\XAMPP\xampp\perl\site\lib is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
C:\Documents is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
and is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Settings\Mr is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Hogan\My is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
Documents\XAMPP\xampp\perl\site\lib is in the Perl include path, but is not a directory at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Modules.pm line 298.
[Tue Aug 18 11:51:24 2009] [error] APR does not understand this error code at C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/perl/site/lib/HTML/Perlinfo/Base.pm line 106.\n
[Tue Aug 18 11:51:24 2009] [error] [client 127.0.0.1] Handler for type-map returned invalid result code 620018, referer: http://localhost/xampp/navi.php
[Tue Aug 18 13:12:11 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Aug 18 13:12:11 2009] [notice] Child 5632: Exit event signaled. Child process is ending.
[Tue Aug 18 13:12:12 2009] [notice] Child 5632: Released the start mutex
[Tue Aug 18 13:12:13 2009] [notice] Child 5632: All worker threads have exited.
[Tue Aug 18 13:12:13 2009] [notice] Child 5632: Child process is exiting
[Tue Aug 18 13:12:13 2009] [notice] Parent: Child process exited successfully.
[Tue Aug 18 14:05:52 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Tue Aug 18 14:06:40 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Tue Aug 18 14:07:52 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Tue Aug 18 14:09:50 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Tue Aug 18 14:23:27 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Tue Aug 18 14:23:36 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Tue Aug 18 16:13:15 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Tue Aug 18 16:14:12 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Tue Aug 18 16:16:04 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Tue Aug 18 16:17:36 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
[Wed Aug 19 04:40:39 2009] [crit] (EAI 11001)APR does not understand this error code: alloc_listener: failed to set up sockaddr for ::
Syntax error on line 46 of C:/Documents and Settings/Mr Hogan/My Documents/XAMPP/xampp/apache/conf/httpd.conf:
Listen setup failed
Russell1984
 
Posts: 6
Joined: 18. August 2009 14:44

Re: Unable to connect to localhost or apache

Postby Wiedmann » 19. August 2009 10:20

Have you changed something in the httpd.conf or your network configuration during the start attempts?

Your OS?

BTW:
it's better to install XAMPP in "C:\" and not in "C:\Documents and Settings\Mr Hogan\My Documents\XAMPP".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Unable to connect to localhost or apache

Postby Russell1984 » 20. August 2009 15:07

Hi Wiedmann

I never amended anything in the httpd.conf but I may unwittingly have done something detrimental in the network configuration. I was tearing my hair out to trying to the cause but failed pathetically I'm afraid. I decided to throw the towel in and uninstalled it to reinstall. Voila, it worked! I've now regained all connections and the problem is solved.

I'm satisfied with the outcome on this occassion and must thank you for your support.

I suspect I might just well be back in the not too distant future......Thanks!

Russell
Russell1984
 
Posts: 6
Joined: 18. August 2009 14:44

Re: Unable to connect to localhost or apache

Postby flashgraham » 08. February 2015 15:38

Hi,
I also have a problem with a blank white page at "localhost/phpmyadmin/"
This is the Firefox error console message below for the white page source code:
SyntaxError: missing ; before statement get_scripts.js.php:1
ReferenceError: $ is not defined messages.php:245
ReferenceError: PMA_commonParams is not defined phpmyadmin:2
ReferenceError: AJAX is not defined phpmyadmin:354
Use of getPreventDefault() is deprecated. Use defaultPrevented instead. jquery-min.js:3

Any help would be very much appreciated,
Thank You!
flashgraham
 
Posts: 2
Joined: 16. June 2013 08:34
Location: Holmfirth UK
Operating System: Windows 7 Professional


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 73 guests