Apache and MySQL won't start in 1.6.8 install on Win XP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache and MySQL won't start in 1.6.8 install on Win XP

Postby redplanet » 18. August 2009 11:48

Hi

Have been using xampp for a few years now with no problems but all of a sudden Apache and MySQL won't start - tried new uninstall/new install in on different drives and instal goes fine as usual, but no joy with apache/mysql.

MY SETUP:
Windows xp SP3
xampp-win32-1.7.0-installer.exe
Zone Alarm firewall v8.0.298.000

I had Virgin Media installed this week and am running a virgin ethernet web connection - the xampp problems have started since then so this may be related, but i'm not sure.

REMEDIES:
I've tried starting apache via the xampp control panel and the .bat file but no joy.

I CAN open http://localhost/xampp/ so my installation appears to be working - here's Status messages:
MySQL database DEACTIVATED

For phpMyAdmin I get the following error:
#2003 - The server is not responding
Connection for controluser as defined in your configuration failed.

I've added 127.0.0.1 to my trusted zone in ZoneAlarm as "localhost" but no joy.

Can anyone advise me here please???

Thanks in advance
Redplanet
redplanet
 
Posts: 6
Joined: 18. August 2009 11:13

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby Wiedmann » 18. August 2009 12:27

I've tried starting apache via the xampp control panel and the .bat file but no joy.

I CAN open http://localhost/xampp/ so my installation appears to be working

How can you access "http://localhost/xampp/", if you can't start Apache?
--> no Apache, no webpage
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby redplanet » 18. August 2009 12:38

My mistake - i can't access it, here's the error i'm getting:
Failed to Connect
Firefox can't establish a connection to the server at localhost.
redplanet
 
Posts: 6
Joined: 18. August 2009 11:13

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby Wiedmann » 18. August 2009 12:43

I've tried starting apache ... and the .bat file

What's the output from this batchfile?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby redplanet » 18. August 2009 14:01

am only getting:
Apache 2 is starting ...
(btw - i'm away from this post intermittently today but will be checking back whenever i can as it's really urgent for me - thanks)
redplanet
 
Posts: 6
Joined: 18. August 2009 11:13

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby Wiedmann » 18. August 2009 14:19

am only getting:
Apache 2 is starting ...

Then Apache should be running. Maybe you want verify this with the Windows task manager?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby redplanet » 18. August 2009 17:15

It's not running in task manager - see the screengrab below for what happens in the xampp control panel when i try to start apache and mysql:

Image
redplanet
 
Posts: 6
Joined: 18. August 2009 11:13

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby Wiedmann » 18. August 2009 17:37

see the screengrab below for what happens in the xampp control panel when i try to start apache and mysql:

For now I'm not interested in the Control Panel...
(please don't mix different things)

It's not running in task manager

Just to be verified: You can't see Apache ("httpd.exe" or "apache.exe") in the task manager, while you have this command window open:
Code: Select all
Apache 2 is starting ...

(don't close this window)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby redplanet » 18. August 2009 19:11

okay, with apache_start.bat running i do see 2 separate iterations of "apache.exe" in Task Manager, but not "httpd.exe"

the first apache.exe is using 22,236k and the second 24,396k and they are seperated in the list by 9 other processes (incase this is of use to you)
redplanet
 
Posts: 6
Joined: 18. August 2009 11:13

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby Wiedmann » 18. August 2009 19:56

okay, with apache_start.bat running i do see 2 separate iterations of "apache.exe"

Ok. At this point Apache is running and you can access it with your browser.

Regarding the Control Panel:
It looks like you have also installed the Windows services:
- stop Apache /MySQL (if they are running with the batchfile)
- delete the services (e.g. with "sc")
- reinstall the services

If you don't need the Windows services, just delete the old ones. Now you can start Aapche also with the Control Panel.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache and MySQL won't start in 1.6.8 install on Win XP

Postby redplanet » 18. August 2009 20:43

Great, getting there now - can see the xampp/localhost homepage and browse, and I've started and opened phpMyAdmin and created a user etc. I'm having to do this with the batch files but it's running at least.

Not sure what you meant by this though:
- delete the services (e.g. with "sc")
- reinstall the services

Could you let me know what these are and how I delete/reinstall them please? I can see "services.exe" - is this the one to delete services?
I started it but it not sure what it does so don't want to tinker.

Thanks for it all so far!
redplanet
 
Posts: 6
Joined: 18. August 2009 11:13


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests