Not php.ini in xampp\apache\bin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Not php.ini in xampp\apache\bin

Postby crossbound » 21. August 2009 16:02

Yes the file belongs to Textpattern. Looks like the code is ensuring that magic quotes are turned off at runtime:

set_magic_quotes_runtime(0);

I guess I could quote out that line, since magic quotes are disabled in the php.ini anyway. (just tried it and it works)

It doesn't really solve the issue of errors being displayed with "display_errors = Off", but is a working fix for now.
crossbound
 
Posts: 6
Joined: 18. August 2009 03:07

Re: Not php.ini in xampp\apache\bin

Postby Wiedmann » 21. August 2009 16:08

Yes the file belongs to Textpattern.

So this script have an issue with 5.3. (even the author thinks not ;-) )

It doesn't really solve the issue of errors being displayed with "display_errors = Off",

I only can say the same as above:
XAMPP doesn't show E_DEPRECATED errror.
--> So if you have not changed the default "php.ini", this script is setting error_reporting and display_errors itself to some value.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Not php.ini in xampp\apache\bin

Postby crossbound » 21. August 2009 16:32

Okay, I finally found the file in textpattern that sets -> @ini_set("display_errors","1");
Thanks for bearing with me. took me some time to find the right code.

I appreciated your help!
crossbound
 
Posts: 6
Joined: 18. August 2009 03:07

Re: Not php.ini in xampp\apache\bin

Postby crossbound » 21. August 2009 17:39

I was able to change the right line of code
error_reporting(E_ALL);

to:
error_reporting(E_ALL & ~E_DEPRECATED);

works like a charm now. Again, Wiedmann, thank you for your insight and for pointing me in the right direction.
crossbound
 
Posts: 6
Joined: 18. August 2009 03:07

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests