Not php.ini in xampp\apache\bin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Not php.ini in xampp\apache\bin

Postby ttorrentte » 17. August 2009 16:40

Hi friends, I have a problem. I don't want to see the php warnings on the screen so I change display_errors to 'off', but the warnings are still in the screen. Looking for a solution in Google, I read that it must to be a php.ini in xampp\apache\bin but... I haven't one.
When I run php.info() I see:
Configuration File (php.ini) Path: No value.
Loaded Configuration File: C:\xampp\php\php.ini
What can I do? anybody can help me?
Thankyou.
ttorrentte
 
Posts: 5
Joined: 17. August 2009 16:31

Re: Not php.ini in xampp\apache\bin

Postby Wiedmann » 17. August 2009 16:47

I don't want to see the php warnings on the screen so I change display_errors to 'off', but the warnings are still in the screen.

Which file have you changed?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Not php.ini in xampp\apache\bin

Postby ttorrentte » 17. August 2009 17:02

I have changed xampp\php\php.ini but there isn't any change. (I restarted apache too)

My XAMPP version is 1.7.2 installer for win32
ttorrentte
 
Posts: 5
Joined: 17. August 2009 16:31

Re: Not php.ini in xampp\apache\bin

Postby Wiedmann » 17. August 2009 17:32

I have changed xampp\php\php.ini

According to phpinfo, that's the correct one.

but there isn't any change.

You have verified this with phpinfo()?
--> http://localhost/xampp/phpinfo.php
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Not php.ini in xampp\apache\bin

Postby ttorrentte » 17. August 2009 18:46

Yes, the http://localhost/xampp/phpinfo.php shows:
Configuration File (php.ini) Path: No value.
Loaded Configuration File: C:\xampp\php\php.ini

I will trying with and older version.
ttorrentte
 
Posts: 5
Joined: 17. August 2009 16:31

Re: Not php.ini in xampp\apache\bin

Postby Wiedmann » 17. August 2009 19:05

Yes, the http://localhost/xampp/phpinfo.php shows:
Configuration File (php.ini) Path: No value.

If you want verify your display_errors setting, you should look for "display_errors" in phpinfo, not for "Configuration File (php.ini) Path".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Not php.ini in xampp\apache\bin

Postby ttorrentte » 17. August 2009 19:35

Thanks for your help, Wiedmann. I uninstalled 1.7.2 version, and install 1.7.0 version with instaler and everything OK. Now, I have the php.ini in wampp\apache\bin.
May be a bug in 1.7.2 version?
Thanks.
ttorrentte
 
Posts: 5
Joined: 17. August 2009 16:31

Re: Not php.ini in xampp\apache\bin

Postby Wiedmann » 17. August 2009 20:24

May be a bug in 1.7.2 version?

No.

(Of course, if you have installed 1.7.0 now, it's now not possible to help you with your original problem... Because it's now not possible for you to answer my questions.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Not php.ini in xampp\apache\bin

Postby ttorrentte » 17. August 2009 21:33

Have you got any problem?
1º I have to work, and I cant be 24 hours stopped.
2º I Have answered your questions. I looked at phpinfo, and there isn't changes, and in the screen I can saw the warnings.
3º In the FAQs say something about a php.ini in the xampp\apache\bin and I haven't one in that path.
4º I said thanks to you.
5º I only said 'may be' a bug, like a suggest, but if you are sure it isn't, where is the problem, why I haven't a php.ini in that path?
ttorrentte
 
Posts: 5
Joined: 17. August 2009 16:31

Re: Not php.ini in xampp\apache\bin

Postby crossbound » 18. August 2009 03:21

I do get an error message as well (deprecated function), but trying to change "display_errors = Off" in the php.ini did not yield any results. And yes, I did restart Apache using the XAMPP control panel after making the changes.
phpinfo() gives me the following:

Loaded Configuration File: C:\xampp\xampp\php\php.ini (which is the file I edited)

and in the core section of phpinfo() display_errors shows "Off" for both the Local as well as the Master Value

I'm using Xampp 1.7.2 on Windows Vista 64bit

Thanks for your help, and please let me know if you need more information.
Billy
crossbound
 
Posts: 6
Joined: 18. August 2009 03:07

Re: Not php.ini in xampp\apache\bin

Postby Wiedmann » 18. August 2009 07:55

crossbound wrote:I do get an error message as well (deprecated function), but trying to change "display_errors = Off" in the php.ini did not yield any results.

and in the core section of phpinfo() display_errors shows "Off" for both the Local as well as the Master Value

So regarding php.ini, it's verified that display_errors is off. (no bug at this step)

Just a siedenote:
In the default "php.ini" I have disabled deprecated warnings, even if display_errors is on.

Next question:
Is this your own script or is this message from a class you are using or a software package (like a forum software)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Not php.ini in xampp\apache\bin

Postby crossbound » 19. August 2009 02:39

Wiedmann,

Thank you for your response. I am using Textpattern, and have been using it for a good while on different web projects and never had any problems with it. The only difference is that I was running it on either Linux or OSX and maybe an older version of PHP.
I did try to disable deprecated warnings in the php.ini but it didn't help.

I will do some more research. Maybe I can find somebody in the TXP community that came across this issue.
crossbound
 
Posts: 6
Joined: 18. August 2009 03:07

Re: Not php.ini in xampp\apache\bin

Postby Wiedmann » 19. August 2009 10:05

I did try to disable deprecated warnings in the php.ini but it didn't help.

As I've written above, this is already done in the default php.ini from XAMPP.
Code: Select all
error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED


I am using Textpattern,

Maybe this script is setting it's own error_reporting/display_error value and is overriding the php.ini default (many scripts are doing this).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Not php.ini in xampp\apache\bin

Postby crossbound » 21. August 2009 13:33

I did a little research (didn't have much time to go into depth), but it seems like that the current version of Textpattern does have an issue with PHP 5.3
I was not able to get the details and I'm not sure if the issue is really related to display_errors. For the time being I probably will have to revert to a previous version of PHP.
Thank you for your help!
crossbound
 
Posts: 6
Joined: 18. August 2009 03:07

Re: Not php.ini in xampp\apache\bin

Postby Wiedmann » 21. August 2009 13:49

but it seems like that the current version of Textpattern does have an issue with PHP 5.3

Is the filename from your deprecated error message related to Textpattern?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: Bonniem and 63 guests