fresh install and php won't start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: fresh install and php won't start

Postby Dave A » 05. August 2009 21:17

thank you. that clears things up a bit: however when i type in the following in the address bar: http://ec.localhost all i get is the xampp welcome screen and it says i've sucessfully installed xampp?? why can't i get my file index.php? thanks for all your help so far. :D
this is what happens to address bar: http://ec.localhost/xampp/
Dave A
 
Posts: 49
Joined: 02. July 2009 16:07

Re: fresh install and php won't start

Postby Izzy » 06. August 2009 06:28

Dave A wrote:thank you. that clears things up a bit: however when i type in the following in the address bar: http://ec.localhost all i get is the xampp welcome screen and it says i've sucessfully installed xampp?? why can't i get my file index.php? thanks for all your help so far. :D
this is what happens to address bar: http://ec.localhost/xampp/
Replace or delete the original XAMPP installation index files, index.php and the index.html file with your own index.php or index.html file in the C:\xampp\htdocs folder.

Now when you type http://ec.localhost/ it should give your site.
(assuming the rest of the site is in the htdocs folder)

To get the XAMPP Welcome Page you would now type http://localhost/xampp/ in your browser.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: fresh install and php won't start

Postby Wiedmann » 06. August 2009 08:11

http://ec.localhost all i get is the xampp welcome screen and it says i've sucessfully installed xampp??

I guess you have defined "ec.localhost" as "127.0.0.1" in your hosts file?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: fresh install and php won't start

Postby Dave A » 06. August 2009 12:58

yup, here's my hosts file:
Code: Select all
# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost
127.0.0.1   ec.localhost


and here's my vhosts.conf file:
Code: Select all
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost 127.0.0.1:80

<VirtualHost 127.0.0.1:80>
  DocumentRoot C:/xampp/htdocs/
  ServerName localhost
</VirtualHost>

NameVirtualHost *:80


<VirtualHost *:80>

ServerName ec.localhost
DocumentRoot "C:/xampp/htdocs/ec/test"
ErrorLog C:/xampp/htdocs/ec/test/logs/error.log
CustomLog C:/xampp/htdocs/ec/test/logs/error.log common
<Directory "c:/xampp/htdocs/ec/test">
Options Indexes FollowSymLinks
AllowOverride All
order allow,deny
Allow from all
</Directory>
DirectoryIndex index.php index.html
</VirtualHost>

#
# VirtualHost example:
# Almost any Apach   


can u see any glaring mistakes?
Dave A
 
Posts: 49
Joined: 02. July 2009 16:07

Re: fresh install and php won't start

Postby Wiedmann » 06. August 2009 13:05

can u see any glaring mistakes?

change the line:
Code: Select all
127.0.0.1   ec.localhost

to:
Code: Select all
192.168.0.1   ec.localhost

(or whatever your LAN IP is)

Also you can remove the line:
Code: Select all
NameVirtualHost 127.0.0.1:80


And if you want, you can change both: "*:80" to "192.168.0.1:80"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: fresh install and php won't start

Postby Dave A » 06. August 2009 13:31

i added another test site and now php won't start: here's my vhost.conf file:
Code: Select all
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80


<VirtualHost *:80>

ServerName ec.localhost
DocumentRoot "C:/xampp/htdocs/ec/test"
ErrorLog C:/xampp/htdocs/ec/test/logs/error.log
CustomLog C:/xampp/htdocs/ec/test/logs/error.log common
<Directory "c:/xampp/htdocs/ec/test">
Options Indexes FollowSymLinks
AllowOverride All
order allow,deny
Allow from all
</Directory>
DirectoryIndex index.php index.html
</VirtualHost>

NameVirtualHost *:80

<VirtualHost *:80>
ServerName reg.localhost
DocumentRoot "C:/xampp/htdocs/reg/7"
ErrorLog C:/xampp/htdocs/reg/7/logs/error.log
CustomLog C:/xampp/htdocs/reg/7/logs/error.log common
<Directory "c:/xampp/htdocs/reg/7">
Options Indexes FollowSymLinks
AllowOverride All
order allow,deny
Allow from all
</Directory>
DirectoryIndex index.php index.html
</VirtualHost>

i just copy and paste and changed relevant info and updated hosts file
Dave A
 
Posts: 49
Joined: 02. July 2009 16:07

Re: fresh install and php won't start

Postby Wiedmann » 06. August 2009 13:57

and now php won't start

What does this mean exactly?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: fresh install and php won't start

Postby Dave A » 06. August 2009 16:07

it means that when i click on start for apache it says running then running disappears and doesn't stay on.
Dave A
 
Posts: 49
Joined: 02. July 2009 16:07

Re: fresh install and php won't start

Postby Wiedmann » 06. August 2009 16:58

it means that when i click on start for apache

So instead of "php", Apache can't start.
--> start Apache with the batchfile and read the error message.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: fresh install and php won't start

Postby Dave A » 06. August 2009 18:49

sorry for wrong terminology .. i guess i really am a newbie.
so here's my apache batch file contents:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
[Thu Aug 06 13:45:31 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
can't figure that out .. unless i have virtualhost *80 to many times? :?:
Dave A
 
Posts: 49
Joined: 02. July 2009 16:07

Re: fresh install and php won't start

Postby Wiedmann » 06. August 2009 20:08

(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:80

If you search the forum for this error you can find the answer:
There is already a program/server running, which is using port 80.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: fresh install and php won't start

Postby Dave A » 06. August 2009 22:01

thanks for your tip. i searched and found a lot of german posts and not much in english. so when i click on apache from control panel it says directory mismatch. i've also deleted second test site so now i have just one site to test. i have two partitions on my pc c and f. i have the files pointed to c: where they are in htdocs. and xampp is on c: any clues. you've been incredibly patient with me .. thank you
Dave A
 
Posts: 49
Joined: 02. July 2009 16:07

Re: fresh install and php won't start

Postby Mitch » 07. August 2009 04:33

Einstein was a rare exception, I guess, when he said "A judge is a law student who marks his own examination papers"

WIEDEMANN - you are a bad judge - and arrogant too ... oh never came to my mind before but, are you trying to replace GOD too?
Mitch
 
Posts: 4
Joined: 07. August 2009 02:35

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 81 guests