Error-MySql said: Cannot connect: invalid settings.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error-MySql said: Cannot connect: invalid settings.

Postby abhijitp » 30. July 2009 08:27

There was no password set for user 'root' on localhost. It was showing a warning at the bottom that the root has no password..etc.

Now I am getting this error message when i changed the password. And also my portal is not working. How do it resolve it?
abhijitp
 
Posts: 12
Joined: 18. March 2009 14:06

Re: Error-MySql said: Cannot connect: invalid settings.

Postby Wiedmann » 30. July 2009 09:25

Error-MySql said: Cannot connect: invalid settings

I guess that's from phpMyAdmin?

Now I am getting this error message when i changed the password.

You must also set this password in the phpMyAdmin configuration file.

And also my portal is not working.

The same for your portal software.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Error-MySql said: Cannot connect: invalid settings.

Postby abhijitp » 30. July 2009 09:35

You must also set this password in the phpMyAdmin configuration file.


Where will i find this file? Is it C:\xampp\phpmyadmin\config.inc.php ?
If yes, then its still not working (same error) after doing this:

Code: Select all
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;


Changed to :

Code: Select all
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'test';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;
abhijitp
 
Posts: 12
Joined: 18. March 2009 14:06

Re: Error-MySql said: Cannot connect: invalid settings.

Postby abhijitp » 30. July 2009 09:37

Hey, its working..I deleted all cookies and temp files and clicked refresh and it worked.

Thanks!!
abhijitp
 
Posts: 12
Joined: 18. March 2009 14:06

Re: Error-MySql said: Cannot connect: invalid settings.

Postby lina88 » 18. July 2012 09:55

I had similar problems which persisted after re-installation of XAMPP.

clearing the cookings did the job for me at the end!
lina88
 
Posts: 1
Joined: 18. July 2012 09:52
Operating System: windows


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests